Ctd hell!

btw, i put an additional 16 gb ram…(initally 16 gb ram), so now 32 gb, to get more power
thats a crucial 16 gb ram…both installed on slot 2 and 4…coudl it be the reason ( i think i read some stuff that i could cause)
but i m afraid that 16 gb is not enough to rum the sim with my configuration…

I’ve only got 16GB and even with my humble RTX2060S I am running Ultra on most things since SU5 (and manually adjusted LODs) though I fly over countryside and avoid cities (and I only have a 1080 monitor). It has also been pointed out that the alledged ‘dumbing down’ for XBox in SU5 has dropped the memory requirement to 8GB and a lot of people with far more powerful systems than mine are understandably annoyed.

1 Like

Apologies for promoting my own thread, but this really helped me, & it may possibly help some of you.

Same here. Constant CTD in world map during 1 month now and no solution. I can’t even start a flight.

That sounds just like the issue I was having when I’d accidentally removed my page/swap file - the world map would move just a little then freeze, or if I went to fly via an ‘activity’ the flight would get about 80% loaded then crash with an error.

I just CTD’d on my way to Sochi. Probably for the best, I was way too high because ATC had not directed me to descend properly. This may have been because they spend most of the flight telling me to expedite my climb to FL290, which I was already at. I look at these more like features. The sim realized I was going to have a very terrible landing and just said “well, you’re done”. Just trying to adopt a more positive attitude like some of the others on here have recommended.

1 Like

CTD loading a flight in the pre release FBW, no addon scenarios in that region other than the aircraft without liveries. Just had configured flight plan on map, set to start cold at a gate, but 85% into the loading screen I was back at the desktop… I decided to insist one more time before changing anything and without even restarting the pc I reopened the sim and this time everything worked as “expected”. This shows how bad the stability of this platform is after SU5 and the two so called “patches” that were provided. Flight experience was this SU5 wonderland with with clear visibility but full of thunders, positive temperatures at FL260 with ATC asking me to expedite my climb to FL240, the beacin and landing lights that no longer work since as FBW informed came mistakenly reverted by the update, and the list goes…
I would be extremely happy at this point to just receive an offline installation and license of SU4 that I can use with addons and never connect and use the Azure Bing online world with weird Xbox and other one time players constantly crashing 747s in Lukla and Courchavel, Rio and where not, and waive Asobo need to provide me any further fix for anything in their development roadmap, including the world updates which are a waste of development resources in my opinion. If you can’t provide different versions but attempt to provide a platform claiming to support 2 flight models (modern and legacy) which to my best knowledge noone uses, changed the mouse working mode a year after the product launch and also kept the new legacy mode somehow working in a messed way for everyone to continue using, things are clearly not going to improve. And what really hurts is that they were already very very good before this update. Yes people had to use at least a 3080 to really enjoy it with VR, and that’s life. By forcing everyone to run the same code supporting such functionalities in a console is wrong, and I hope Asobo and Microsoft really get their #### together on this delayed, hopefully for good additionnal reflection about what happened on the last months. We’ll soon know. I am updating other sims and preparing other games to replace this HD space if that doesn’t happen and that’s it at least for me. With a lot of sadness, but it’s just no longer really flying anywhere now…

I get CTDs and freezes (whole system-wide freezes) at night in the sim, a perfectly working sim during daytime in the sim. It’s unexplainable. It’s been over a month of installing every SDK of every language recommended and known to man, fiddling with this and that suggestion from this or other members of the community, getting called stupid by others, frustrated and red-faced at some people, uninstalled and re-installed the game twice already since SU5…honestly I didn’t pay upwards of 100£ for this experience, we should be allowed our money back. Yes, even after a year…

It’s frightening that so many users report about CTD. Immediately after the patch I also had the problem that the SIM got stuck when booting up. I then decided to do a complete new installation. The content of the Community folder was deleted and the instruction: turn off live traffic, paint jobs, and also ground traffic at the airports. I finally tried to start the sim and EVERYTHING worked 100%.
It only happened a few times that I had a few seconds of freezes, but these never crashed my sim. The FPS after the patch are just great <3

yeah! and if you turn off the clouds, and also the simulator, FSP will be great!:slight_smile:

CTD almost everywhere - since a few days CTD. Today I spent more time with my loading screen to MSFS rather than flying - it`s annoying and disappointing…

MSFS, drivers and Windows are updated - I don`t ask for support - I want to express my disappointment only.

Have a great evening guys.

2 Likes

I can confirm that the ctd’s I am experiencing have something to do with the community folder. Empty community folder means no ctd’s for me, but as soon as I add a mod, doesn’t matter wich one, I have ctd’s while flight is loading. This only happened after Version 1.18.15.0. I have not experienced a lot of ctd’s since the release of the sim. Always ran pretty stable.

I think its a shame when its suggested that you need to do a complete reimstall to get the game to work.
I mean ■■■. Its a game we pay money for. They need to do their testing properly before releasing updates, This time it went reallly bad and I believe its due to the fact that the update was must for the xbox release.

1 Like

I have to get this off my chest.
I have used MSFS for about a year. Until Aug 16 2021 I never had a CTD. I have never added third party mods. I have a fairly top line system. I took a trip and shut my PC down for a week (Total disconnect from mains power). When I returned on Aug 24 I rebooted PC and tried to run MSFS. It would get to the Rhinocerous screen then just CTD. I tried for a few days with no luck. Then I didn’t touch MSFS for a few weeks; I just did other things. A week ago I tried MSFS and it has been working great since then. i DID NOTHING TO TRY FIX THE CTD’S.

So, I guess MY POINT is that no one knows why several thousand users (out of two million plus) suffer CTD’s.
No one knows how to troubleshoot and fix CTD’s.
The causes of CTD’s are idiopathic.
There are so many combinations of PC’s, Xboxes, user mods, etc etc that this problem cannot be solved because the cause is not discoverable.
Thus endeth my lesson.

Yeah, I totally agree and came from a very similar situation. Support took my msinfo, found that the exe was crashing. Which was overstating the obvious to me. I ended up deleting my CH Controller software and reinstalling it. It gave back some semblance of play, but it still CTD’s at any given moment for any given reason, hence your other projection, with no end in sight… yet… That too is not acceptable to have that many users worldwide be down for so long. It’s very disappointing indeed. Not fun being at the mercy of the developers.

If I were having continued CTD, and I have had such, I would find something else to do. For two years now I cannot use Steam games: they CTD after about thirty seconds. Solution: I don’t use Steam anymore.