Ctd hell!

Request #121257 CTD 1.18

Upgraded to v1.18 - Nothing but CTD’s since then!!!

Went thru all of the CTD suggestions as posted!

This is ridiculous! Considering all the suggestions, it looks like you have to have a dedicated machine just to run the game!

There are literally THOUSANDS of gamers out there with this issue!!!

All the forums are complaining about this and not one statement has been released addressing the issue - Extremely disappointed!

I have a PC that is littered with SDKs of various languages (C#, VB, Perl, Python, SQLLite, Unreal, yada yada); a couple versions of MS Office (2010, 2013); three versions of Visual Studio; around 150 installed games (>100 on Steam alone); dozens upon dozens of apps from many companies (iTunes, Google Earth, Photoshop, Garmin, FiiO, Comodo, AVG, Splashtop, Firefox, Chrome, Putty, Blender,…); several DosBox programs and a few emulators; Uplay, Epic, Steam, Origin, GOG, Rockstar launchers; numerous symbolic links/junctions; and, apart from a recent series of CTDs where I’d accidentally deleted my pagefile (I was moving it from one partition to another - did I mention I have >9 partitions across 6 drives?!), I’ve not experienced any real issues with MSFS 2020 even when running multiple applications - hell, I’ve even been defragging, ripping CDs, updating Steam games, and such, whilst running MSFS (and alt-tabbing between them whilst doing so). And I’m ‘only’ running an i5-9600K and a RTX2060S with 16GB of RAM

3 Likes

you are true.
CTD almost always.we cannot be flying and waiting for a ctd behind the next cloud.

1 Like

In my case, It’s usually a case of which control on the cockpit wil crash the sim for me this time.
If I want to complete a flight I have to avoid touching anything that I can really get away with not touching… complete nightmare

Yup, same here. I had a perfectly stable sim (incredible, I know) until SU5 and the two subsequent patches which have been awful. However, instead of CTDs I get “fatal freezes”, which are basically just a variation of the CTD because I have to exit the sim and kill it.

I reinstalled the whole frickin’ sim just to make sure I didn’t have a corrupt install and it’s the same thing. My desktop is used almost solely for gaming and some photo editing, so yeah. It’s the sim.

I can’t even get on to the main menu, CTD during the loading screens. Extremely frustrated.

Yup, despite some hot fixes the sim isn’t stable it seems.
I never had a single crash previous to SU5 through every version of MFS.
Since SU5 I have had 2 systems ( anew build) and still get seemingly random CTD

1 Like

I have a dedicated PC that’s only used for Flight Sim. I get CTD’s every single time I try to play. I’m almost to the point where I’m going to leave the game alone until WU6 hits. I get CTD’s in the landing challenges, in the bush trips, in free flights. Type of aircraft seems to make no difference. I’ve tried it with Community folder completely empty. I’ve done a complete MSFS re-install (that was a time consumer). It’s too bad that MSFS doesn’t have a way for us to create a user dump and send it to them for analysis. :frowning:

Same thing happened to me the other day.

I ran the MSFS app repair in Windows Settings and believe it or not, it fixed the CTD’s.

2 Likes

You’re not alone guys…during last year, i had ctds here or there…ONLY for the sim, i bought a new computer (1500 euros), new monitor 3440*1440 (350 euros), i got a new cabled connection (box direct to comp), because of some issues with the comp itself, because they put only 400 w on a gaming comp, i replaced it and put a corsair 750 W, and and and…and still, having ctd…again, ctd can be caused by a lot of things…i m not that tech savvy, but to in my case, it happens with certain liveries, or airports, like yesterday, it was in KSAN…it is, of course, very frustrating…but i dont want to complain to much comparing to some guys here having constantly ctds, or game even not launching etc…so, every day, you are flying and just hoping for the best…coz you prepare the flight, simbrief, cockpit preparation, etc…ready to fly, …you fly…sometimes you land, sometimes not, you go just grab a coffee, and frustrated, you put the sim on the side until next day…not excited about SU or WU, because we know, some points will be resolved, but other things will be broken…well, what to say the, just remain patient ? dont know…just wanted to share this with you guys…cheers up

1 Like

yep, same here, yesterdat it was to knob between eng 1 and 2…three times…pffff

The last week i have not a single Ctd even with overclocked Cpu and Gpu and lots of mods.
The week before Ctd-s every flight.
I dont get it.

Why split the votes? And provide zero information for anyone to help?

Are there? How do you know? See this poll:

As I post this, there are only 335 people who have voted - you’d think there would be a lot more if “literally THOUSANDS” of people had this issue and “All the forums are complaining”

In terms of statements, try these - they all mention the work they are doing on CTDs:

3 Likes

Just a quick thought: I noticed that, in a particular 3rd party plane, I couldn’t turn off the Magnetos and it turns out that some of the attributes for them, in the generic xml code for cockpits, had been altered since SU5 - could it be that you’re flying a 3rd party plane whilst experiencing this?

it might be well the reason…i tried then another livery, and again and again, even other airport…still the same…i was fed up…i fly with the fbw…i should have tried the default 320…i didnt…but next time then i guess

1 Like

even with the new installation …may be not the topic here, but every single day, after like 20 min after being on the comp (not the sim), i m getting a freeze, so i have to manually swith off and on again…i thought before it’s beacuse of a lack of psu, but even with my powerful one, it happens…i m wondering what could be the issue then since it thought the psu was the problem…i m wondering now, if it could be my AVG sofware (from AVG brand) ?? what do you think ?

Coincidentally, I’m running the free version of AVG (complete with ‘nag screens’ that pop up now and again) but I’ve not experienced anything so far with it.
I did have a continued series of CTDs a few days ago - it turned out that I thought I’d moved my system’s pagefile.sys file from one SSD partition to another but I’d actually removed it completely! Turning it back on solved the problem - I guess that MSFS called on the system for some extra space and crashed at that point. It got me wondering if people’s problems are related to the page (aka swap) file in some way but I’m not sure what to suggest.

some people say also, that all these kinds of avg are kinda useless and causing a lot of issues in the normal operations of a computer, and that the windows 10 defender is more than enough to get protected…but i m surfing a lot, a lot of buying online, etc…and i feel more “secure” having a proper avg software…i wonder if i should uninstall it (i have the paid AVG softawre and anti track add on)…because now my main issue now is the random freeze on the comp even not in the sim…

I know what you mean. I’ve had the bare bones Defender in the past, and I’ve tried Bitdefender, AVG, and a few others too (and even paid for one in the past).

That doesn’t sound good :frowning:

BTW, regarding the PSU: I’m running an XFX 750W 80+ Bronze Certified Single Rail PSU to drive my system and I’ve got an RTX2060S and an i5-9600K with 6 drives and 6 fans - I always have an eye on the potential power draw of my GPU when I’ve upgraded but it never comes close (even when I had a pair of GTX560s).

having the corsair 750 W 80+ gold…gtx 2060, and I5-10400…random freeze but not with bizzing sound, as before…the fan is more silent when using the sim…so the psu fan is more efficient i guess, and oh i forgot sometimes the sound is gone, i noticed that the realtek driver is gone from my manager (under sounds and control)…i m really confused…tried to get help from internet, but so many advice and opinions…getting lost in the whole thing…only swith off and on the comp for now