CTD immediately and every time after pressing yellow 'FLY' button

All the official Asobo stuff can stay there. Assuming both OS and official are on your C drive just open a new folder on your desktop and move anything 3rd party over, just don’t name the folder ‘official’. In theory this shouldn’t actually move anything but will just change the location tag in their metadata.

When you decide to risk it again just move everything back into official or even just what you need for your trip.

To get an updated season files to work with SU5, email me with a screenshot of the seasons you purchased to bijanstudiola@gmail.com and I will send you the updated files.

1 Like

Has anyone here tested if disabling Game Mode helps?


Nope - doesnt work (turning off game mode)

I have also removed all of my custom market place airports and the usa world content - the issue still occurs at KORD.

I am of a mind that we are running into some type of memmory issue at large airports or locations where it cant load all of the content…but I will see if I can find some type of thing where I can load

Anybody is till having constant CTD’s?. If so can you please let me know your CPU model and its base clock?.

I have done 5 or 6 flights, I have had at least 4 CTD and all of them just setting up the flight plan! my PC was reading 60-65 FPS at the time, the Temps are in the 60-65 range for CPU & GPU so zero stress on any hardware whatsoever.

What is the worst problem now is using the Cessna 152 I set-off in that aircraft and within 6 or 7 minutes the frame-rate drops from 45 to 5 and sticks on 5, this is just cruising @ 1500ft say,
GPU workload drops to 19%
CPU workload drops to 11%
FPS = 5
This only happens in the one aircraft 152, still looking into why?

P.S. I have tried many Challenges and two FBW flights, all Super Smooth & zero stutters.

There is definitely still a problem with the Sim, whether it is Asobo and the Xbox modifications
or Asobo and the lack of testing to assess implications of PC owners controller hardware who knows!

If Asobo had said empty the comm’s folder and then remove all settings from all PC controllers and delete all profiles then I would have been a lot further ahead.

AMD Ryzen 3700X Base Clock speed 3.6 GHz

Window 10 pro 64
Thrustmaster Airbus SideStick & 2 Lever Quadrant
Ryzen 7 3700X
Corsair Vengeance LPX 32GB (DDR4-3200)
Gigabyte 1TB M.2 PCIe NVMe
Gigabyte B550 AORUS ELITE
MSI Optix 3440 x 1440

Probably not helpful to those that have tried it PLUS I might be jinxing myself…

Just another report of a reinstall fixing my issues. Since installing the sim and up to before installing SU5 I pretty much never had any CTD’s. Since then I have had repeated CTD’s after a short while (couple minutes?) into any flight. Noted that I had not reinstalled the programme since the initial install at the original release last year so I suspected things might have gradually been going south over the many months. So I took a deep breathe and decided to do a reinstall.

The reinstall went very well indeed: downloading and installing the full 126GB de Luxe version took about 1 hour & 45 minutes: without the whole world hitting the servers on the SU 5 and Xbox launch day things went briskly. Had to add back some of the world updates etc. but that also went quickly.

Held my breath and started the sim without anything in my community folder… and no CTD. Gradually added back my preferred add-ons (Bonanza G36 community update, a custom livery with improved prop graphics, WT G1000 v 0.4.0, Bijan’s scenery and lastly NoHandlebar. And still no CTD so far.

Keeping my fingers crossed that this has truly fixed the issue and that it does not sneak back in again…

1 Like

I’m managing with 16GB ram and 2 GB vram so I doubt it … virtual memory would be different, however I always let Windows handle that and I always make sure there’s space enough on my C drive.

1 Like

Whoever mentioned the drive formats and swapping and such, I wanna kiss you… I started getting CTDs when pressing fly after SU5 was released, having moved my install over to an internal ssd that I dug up. MSFS used to be on a spinning platter drive and it launched, even with SU5 installed, and I could fly.
But after I moved the install over to the ssd, repeated ctds, even after a full clean install.
Today, I moved the install back to the hdd, wiped the ssd and formatted it again. But to NTFS this time.
Moved MSFS back, and guess what? No ctd when pressing fly. Hallelujah! So far, it seems to be working. I guess partition format really DOES matter.

So in a nutshell? If MSFS is installed on an exfat partition and you are crashing, try installing it on an NTFS formatted partition.
I shouldve known better honestly…


Such an easy mistake to make too and if they don’t already then Asobo need to highlight it in their install notes.

Just be careful with the addons as there’s no guarantee how a CTD will be triggered. Some of them are bound to need an update.


To be clear - this does not occur at every airport - I started a flight at CYUL this am no problem…its just certain large airports near large cities (KORD - EKCH - EGLL - KJFK).

what kind of framerates are you getting before the CTDs? If they suddenly drop it’s a sign of throttling back, mostly due to high temps somewhere, cpu, gpu or chipset as ram would usually bsod.

Anything is worth a try, we have seen that just changing a configuration option with a radio button can easily cause a CTD. I did not try that when l was trying to create a CTD.


1 Like

I uninstalled Ryzen Master a long time ago as it was one of the things causing me stutters

Indeed: so far the basic ones that I pretty much always use seem to be OK. But I have just had another CTD with FSimstudio’s Vancouver airport. Will have to see if it is coincidental or fundamental. I know it is a very demanding add on: used to cripple my frame rate before. Now it was better in terms of framerate but maybe not 100% right for SU5.

1 Like

Thanks a bunch, it worked flawlessly! Now I just have to test it with a long haul flight.

1 Like

If it was bought in the market report it to both the makers and Asobo

Nope not from the market.