CTD in A320/A32NX when clicking switches; Audio-issue?

Hi, everybody!

I’m just as enthused as most of you about VR in MSFS, however, at least on the A320 and the A32NX I have not been able to complete a flight in VR, as it always crashes to desktop, always when I click on a switch in the cockpit. In the NX, this happens already when I switch on the batteries, after connecting the aircraft to ground power, and in the stock version it happens at various points. The crashes do not occur in 2D. I have been having issues with sound in this program, I have the MSI MPG Z390 Gaming Edge AC-motherboard, and apparently this requires you to install a program and driver by Nahimic; ever since, at least I was not able to establish a stable Bluetooth-connection with my BT-speakers, when I started up FS2020. Don’t know if that has anything to do with the problem, but in some forum I saw someone mentioning a problem related to an Audio-driver, I just can’t find that entry anymore. Other specs: Windows 10/64bit, I9-9900K (not overclocked), GTX1080ti, 32 GB RAM. HMD is Oculus Rift S. The A32NX is on version 0.5.1, which should be the latest. If anybody has an idea - or even a solution, I’d be glad to get it.

Kind regards

I have been having the same issue with my Oculus Rift. It crashes to desktop using the A32NX mod at random points during the flight. Very frustrating.

My sim won’t load a flight and CTD on the latest version 0.5

I have solved the problem (at least about the CTD) by changing from windowed to fullscreen mode - ever since, the CTDs occur only very rarely (given that an FS without CTDs seems virtually impossible ;-)), so you may want to check your setting.

Same issue for me. Also happens much less often in full Screen .Quest 2 with link

I just updated to the new release from 5 days ago and it’s working great

This is happening to me, often when clicking Anti ice going through cloud layers after takeoff… incredibly frustrating when using VATSIM getting clearance.

Rift user.
Testing full screen now.

Constant CTD in VR A32NX clicking various buttons, it doesn’t even seem to have a favorite button click to crash with. Very Random.

As a reminder:

Before creating a topic in the Bugs & Issues categories, assure no mods or 3rd party add-ons are installed per the guidelines of this section.

The purpose of the Bugs & Issues categories is to discuss issues that affect the base simulator (MSFS default content). Please do not discuss issues with third-party addons, or modifications in this category.

If you believe your issue may be caused by a third-party addon/mod, empty your community folder, restart the simulator and try to reproduce the error.

All issues caused by, or involving third-party addons/mods should be reported to the third-party developer. All issues related to the core simulator (MSFS default content) can be formally reported through Zendesk.

So I’m gonna do more testing in a little while, but rolling back my nvidia driver to 457.30 helped me. I was able to do 2 short hops last night with no CTD. Fingers crossed.

Reproducing also for me with G2 and windowed mode. It looks like its reproducing when clicking on the cockpit buttons or switches at the overhead panel - when mouse cursor is at the top of the 2D window.
Today, i’ve tried 5 times to do checklist before flight, and it crashed every time - was not able to taxi to the runway :frowning: .

Didn’t checked yet with fullscreen mode, as then switching between MSFS and any other app is blocked (that makes access to any chart impossible :/) - see this topic.

Very frustrating!

If just noticed that in windowed mode, it’s actually possible to click close window button in right top corner even when window is maximzed, see:


MSFS will close if you click the mouse button in such cursor position, so i suspect that this actually not a CTD, but “UX flaw” when using mouse in VR :wink:

Hi there!

Actually, the bug has not been an issue for me anymore since I started playing in fullscreen mode. When I have to switch windows, I press Alt+Enter, make sure that I don’t press any button in the cockpit while in windowed mode and change to the other window.

But I am aware that this can be a bit annoying if you have to do it frequently - I actually have my laptop running at the same time for charts and lift the HMD to have a look, but I understand that many VR-pilots don’t want to lift their HMDs. There needs to be an app to import other windows into the cockpit, not sure if that already exists.

Regards

This is no longer issue for me as well, as task switching is now possible with fullscreen mode in VR as well.

There needs to be an app to import other windows into the cockpit, not sure if that already exists.

Yes, this would be very handy, but i haven’t found any so far.