CTD in World Map!?

I reached out to support and they told me to follow the steps of deleting game save files for Steam and try again, unfortunately I had to say goodbye to my progress, logbook etc (There’s also a guide to delete progress for MS store.)… Third party software and community folder was not my issue as it turns out…

It worked! no more CTD’s when clicking “ready to fly”. The detailed progress was lost tho (ie: logbook), but the overall achievement is still there (ie: before this my next milestone was 50 hours, now my next milestone is 100 hours…) but the progress bar is empty.

Now I’m just wondering how do I restore the full progress.

2 Likes

I managed to finally get to fly in World Map mode last night without a CTD. The only thing I did differently was in Steam:

Right click “Microsoft Flight Simulator”
Select “Properties…”
In General, at the bottom is “Launch Options” - I added: -FastLaunch

Prior to doing that, I was never able to even get into the plane in World Map mode and I’ve tried nearly everything I’ve found online to fix this.

1 Like

@ PhoenixHahn it worked the first time, but when I re-enabled Steam Cloud and restarted, it’s CTD again :frowning:

but that sounds more like an issue with your controllers or the settings. I assume you not needed to delete all your settings :relaxed:.


@Dargelis3433 … you can remove ( or backup ) the input files first. Or the more safe way: try to clean the controller settings in game menu. Only if that will not help, you can try the “big hammer solution” and remove all online-files.

May be you can also backup some files before, the local cache folder and the link to Steam-Cloud is mentioned here:

The steps to delete all Steam files, you find here:

( so you can also try to partly remove files, e.g. only the input_xxx files first )

1 Like

The problem still persists – CTD when clicking “Ready to Fly” under World Maps Free flight

I followed the instructions related to local steam cache by deleting the folder
D:\Program Files (x86)\Steam\userdata\myusernumber\1250410\

  1. Disabled Steam Cloud → Started MSFS → World Map Free Flight → Successful circuit flight on a stock Cessna 152 → Closed MSFS
  2. Enabled Steam Cloud → Started MSFS → World Map Free Flight → CTD

It may be a bug on how Steam/MSFS writes these config files which MSFS can’t read properly. Formatting, encoding, or file matching error perhaps?

Prior to the Steam Cloud procedure, I performed the following:

  1. Deleted input customization in-game, all in default settings - keyboard, mouse, Honeycomb Alpha and Bravo, Thrustmaster T-Rudder, Hotas 4, and T.16000M
  2. Uninstalled Add-ons FSUIPC, Space Desk, Better Bravo Lights
  3. Disabled online functions - maps, traffic, weather
  4. Deleted/disabled Rolling Cache and Manual Cache
  5. Switched between DX11 and 12
  6. Enabled/disabled Vsync, DLSS, Antialiasing
  7. Moved Community Folder contents
  8. Deleted Content.XML and folders DCE, SceneryIndex, SceneryCache in user App data/Roaming folder
  9. Cleared all pending Windows Updates
  10. Checked /etc/hosts file for entries
  11. Updated NVIDIA Drivers to 517.4 - Also switched from Game Ready to Studio
  12. Updated Gigabyte BIOS to f62

All ended up in CTD, even in Safe Mode.

I replied to a Bug Report related to this error as well – CTD, but only when in World Maps

BTW, I was able to restore my logs by overwriting the files in the \userdata folder using the backup I made before disabling online sync.

2 Likes

hmmm, no issues here… on which language is your system ?

Steam itself not write the files, it simple copy it onto the cloud.

And is somewhat special in the error log you can find in windows event viewer ?

Thanks for the follow through, MichaMMA. My PC is in US English.

The same CTD error came out when I downloaded SU10 Beta a few weeks ago. I rolled it back to SU9 without touching any configuration and the error disappeared. My general specs:

  • Windows 11 in C:\ 240G NVME
  • Steam and Steam Library in D:\ 240GB Kingston SSD
  • Nvidia RTX 2060
  • 32G RAM
  • AMD Ryzen 5 2600

Here’s the latest Application Error Event log:

Faulting application name: FlightSimulator.exe, version: 1.27.21.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 1.27.21.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001b37702
Faulting process id: 0x3f74
Faulting application start time: 0x01d8d2855f6eac42
Faulting application path: D:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: D:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Report Id: 2095e55a-1b96-4658-8944-aec7a72a6dcb
Faulting package full name:
Faulting package-relative application ID:

And here’s the corresponding WER Information:

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: FlightSimulator.exe
P2: 1.27.21.0
P3: 00000000
P4: FlightSimulator.exe
P5: 1.27.21.0
P6: 00000000
P7: c0000005
P8: 0000000001b37702
P9:
P10:

Attached files:

These files may be available here:
\?\C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_FlightSimulator._eb4c49b5b9d3a9e78e2a9f98d0fec9c082732e_07a80085_8a170eb9-0e60-433b-a159-3ab5dc7bd29c

Analysis symbol:
Rechecking for solution: 0
Report Id: 2095e55a-1b96-4658-8944-aec7a72a6dcb
Report Status: 4100
Hashed bucket:
Cab Guid: 0

Thank you.

:frowning: … the 0xc0000005 , that give us no hints.

If we stay by a Steam-Store-Load issue, then can only guess somewhat is with " D: drive ". Is it formated in NTFS ? Not sure whether the old issue with exFat is gone in meanwhile. You can may be also check , whether Anti-Virus solution do some strange things here.

And had you checked that the former files are realy removed from cloud ( with the online steam cloud link ) ? Not that it loaded again old files from Steam. All cases I remember are about invalid controller profiles, but may be I forgot somewhat in meanwhile :grin:

Yeah, that 005 doesn’t give us any clue.

The game drive is in NTFS and I’m quite sure I followed the Steam cleanup instructions. Anyway, I’ll go through the solution once more. Will check the anti-virus as well.

Danke!

2 Likes

It’s working! Uninstalled AFC Bridge and Air Manager, Disabled Steam Sync, deleted inputprofile_XXX. Restarted MSFS 3 times and no more CTD! Hope it stays that way after the controllers are reconfigured.

2 Likes

Sad to say CTD is back again after remapping my controllers. I have Honeycomb Alpha and Bravo, Thrustmaster T.1600M and T-Rudder, and Thrustmaster Hotas 4. Kept Steam sync off this time. It may be something about MSFS not being able to read what it writes. Will update once I have trace results.

1 Like

a question… have you this option enabled too ?

I not rechecked that report, just remembered on you and that the issue comes back with steam sync off.

It seems to be working with the Objectives Off solution. Enabled Steam sync as well and no CTD even after a few restarts. :slightly_smiling_face:

1 Like

I’m having mysterious CTDs since SU10 too. . .I’m going to check all these. Seem to be peripheral related, as when I would switch from TM throttles and controllers to Honeycomb A&B, the sim woudl CTD whenever I click “fly now.” I got into a habit of any time a sim refresh would come out, I would reset all the controls to default and that seemed to work, but not now. Go figure. :disappointed_relieved:

I am reluctant to delete cloud save (I’m on windows store) when I don’t trust that’s the solution.

The problem only appears when starting from an airport. If you click some random place in the map (not an airport) the sim works fine. I have reinstalled the sim after trying all (other) solutions I can find (and figure out how to perform).

To many posts to read (with non-working solutins…) - I don’t know what the “objectives off” solution means.

To turn objectives off – Assistance Options, Notifications, toggle the Objectives.

HI,
Thank you.

desactive OPTION => OPTION Assistance => Notifications => Objectif “desactive”.

Works for me.

thanks.

1 Like

note that the credits go to @dbckd999 :

as I mentioned 13d ago :wink:

1 Like

This just worked for me. Finally able to get past Ready to Fly!

This has worked for me as well.thank you!