When ASSISTANCE OPTION > NOTIFICATION > OBJECTIVES is enabled, the program crashes when the ready to fly button is pressed on the world map

Symptom: When everything is initialized and the minimum installation is installed, selecting any airport on the world map and pressing the ready to fly button ends without displaying an error.

Taken from the Windows event viewer.

Error 2022-10-01 10:56:02 PM Application Error 1000 (100)

Faulting Application Name: FlightSimulator.exe, Version:, Timestamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, timestamp: 0x00000000
Exception code: 0xc0000005
Error Offset: 0x00000000001b37702
Faulting process ID: 0x1a58
Faulting application startup time: 0x01d8d59d15c54b50
Faulting application path: C:\Users*[my name]\STEAM_GameFile\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Users*[my name]
Report ID: a235117b-cbc7-4afe-9844-b74d9a4124c0
Faulting package full name:
Application ID relative to the faulty package:


I wrote this article to help others get lost in their errors.
This article uses a translator. If there is something you don’t understand, please point it out.


Thank you very much, this work for me and my case was world flight after select airport and plane click fly then ctd. your method work for my case and I already on flying 1 round. Thank you very much.

1 Like

You made my week. This solved my constant CTDs in World Map flights. +1 for your workaround.

1 Like

I can confirm it worked for me too !

1 Like

THANKYOU worked for me.

1 Like

Thank you. You saved my day! It worked for me too :slight_smile:

1 Like

Thanks… Worked for me too…

1 Like

Awesome! That worked perfectly,I spent the weekend deleting add-ons, sfc’s, restoring, fooling around with config files, etc etc etc…THANK YOU !!!
Is there a permenant fix? If not I just happy having MSFS at 99%…

1 Like

@dbckd999 Thank you so much. I created an account here just to let you know this fixed my problem.


1 Like

This did not work for me, as I already had de Objectives set off before the CTD started happening

1 Like

This worked for me, thank you for posting.

1 Like

Great, surched many Days, this hint works FINE

1 Like

After DAYS troubleshooting and logging a ticket with support, this is the solution!
Confirm this issue using Premium Deluxe and the MS Store version / Windows 11 / NVidia Geforce 1070 and multi monitors (have not tested single monitor).

MS need to hotfix this urgently.
(I’ve just updated my ticket with this info)


(BTW I’m wondering if it’s something to do with multiple monitors).

1 Like

I’ve got an update.

I reinstalled FS2020 again. For some reason my profile wasn’t downloaded and it was set as default. No progress or anything. I checked the XBOX app and the data was still there. However everything was set to default in FS2020 and settings were cleared, that also means OPTIONS → ASSISTANCE OPTION > NOTIFICATION > OBJECTIVES was set to on.

And so it worked! The game ran fine.

So then I tried to recover my user profile

I logged in and out of the game, nothing happened,
I restarted FS2020, nothing happened.
I rebooted my computer and finally it sync’d. My user data was back.

So I tried to reproduce the error, and this time it crashed as always. The game would not run.


So it’s a combination of my user profile and this setting set to ON that causes the crash. That’s why it may be difficult for developers to reproduce?

1 Like

EVEN MORE INFO (and full steps to repro).

I finally remembered I used to have a third monitor where I unpoped and positioned the objectives window. I took that monitor away and that’s when the crashes started happening.

I wanted to test this so I set OPTIONS → ASSISTANCE OPTION > NOTIFICATION > OBJECTIVES to ON and it crashed as always under world map.

I then reintroduced the missing monitor and unfortunately it made no difference (crash).

Now I did notice that the game doesn’t crash if I goto Activities → Flight Training → Take off and Landing → Take off. So I did this and in the game closed the objectives window (unpinned the window from extra monitor I reintroduced) and put it back into its default position, unpinned on the main montior, and restarted FS2020… BINGO it worked!

So now OPTIONS → ASSISTANCE OPTION > NOTIFICATION > OBJECTIVES can be set to ON without crashing!!

(For clarity please note I’ve never used the experimental multi monitor options in any of these scenarios).


Clean install of FS2020.
Goto home.
Goto World Map
Type LAX at departure airport and select.
Click Fly (and wait).
Click Fly Now.
Unpin “objectives” window and place on another external monitor.
Exit current FS session.
Exit FS application.
Turn off/remove external monitor.
Start FS2020.
Type LAX at departure airport and select.
Click Fly (and wait).
Click Fly Now.

If it does work, it may be that the developer has fixed this, however they may not have introduced clean up code on user profiles.

Regardless this may supply enough info for people to get their objectives window back.

1 Like

Yet another update.

After doing all this and getting it to work, if I pop out the objectives window from the default position on main monitor, then exit and fly again through world map it will crash. So I have to go back to flight training and set the window back to the default “unpoped” position for it to work again (as explained previously).

Oh well. At least I know more about the bug and can repro this easily (and have a better workaround).

1 Like

Final update (hopefully).

From support:

“The fix for the “ready to fly” crashes has been implemented in SU11 beta and should resolve your issue”… “which should be some time in early November.”

1 Like

What is BTW?
It seems to be an issue that has nothing to do with multiple monitors.
I’ve been experimenting with a single monitor in the process of resolving the error and the error is the same.

I think the process of finding the error is the same. I’ve also played maverick missions and it worked fine with no issues.
So I guessed there was something wrong with the steps to set up something before we set off.

BTW = By The Way