CTD involving number of USB game controllers

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
There is an access violation related to USB controllers. When installing or updating FS2020, I get a CTD when any USB game controllers are plugged in. If I remove them all, it will install/update.

If I have all 11 of my USB game controllers in (for my sim pit), opening the controls menu causes a CTD with the following crash debugger error:

0xC0000005
The thread tried to read from or write to a virtual address for which it does not have the appropriate access.

When I have 10 or less USB game controllers plugged in, I no longer get the CTD.

The devices are limited in the code and this needs to be increased in order to solve this basic issue.

Additionally, I have been reaching out to support and the discord but have had zero help.

Provide Screenshot(s)/video(s) of the issue encountered:
N/A, its a CTD

Detail steps to reproduce the issue encountered:
Install/update with any USB game controllers plugged in
Run/go to controls menu with >10 USB game controllers plugged in

PC specs for those who want to assist (if not entered in your profile)
Windows 10 20H2
ASUS ROG Strix X570e
Ryzen 9 5900x
MSI GeForce 2080 Ti
64GB 3600MHz DDR4
M.2 NVMe Drive

Did you submit this to Zendesk? If so, what is your ticket #?
Yes: #94545

Thanks for linking this, exactly the same problem! Support has left me hanging for about 2 weeks in my ticket, sadly.

1 Like

I have had this 0xC0000005 CTD for months. Each time, just before the CTD, the audio wavers for a second. The only error in the eventlog is this errorcode, and a warning about a disk that has been removed suddenly, which is probably the result of the CTD rather than the cause.
I filed 2 tickets for it, and received the same standard troubleshooting guide.
After months living with these CTD’s I finally discovered the cause: USB devices.

I had almost giving up on finding the cause. I have filed two tickets about this issue and got the standard troubleshooting guide each time. Those didn’t help. I also tried almost every “fix” in these and other forums and none of them really helped. One of these tips was completely reinstalling MSFS and I did that several weeks ago. At first it looked like it worked, and I posted so in these forums.
I was wrong though, because after a few flights those CTD;s returned.

I left MSFS alone, afraid even to start it up again, until a thread about this issue on Avsim caught my eye. This stimulated me to try again.
I have a specific test route from ESUE to EGPN (low alt IFR) that is guaranteed to give me a CTD, usually before I am halfway the North Sea. It does not matter whether I use AI traffic, community mods, simconnect clients etc. or not. It crashes without these or with these.

This time however I decided to do the entire flight without ANY USB controllers. I only had 1 USB hub, a mouse and a keyboard connected. To take off I made use of the AI pilot, and switched to autopilot enroute.
This time, the flight completed without CTD!

After some testing I have found that it doesn’t make a difference whether I have community addons, or simconnect cliens running, or traffic or Azure ATC. Each test is the same: without USB devices the flight is completed, with (some of) them plugged in, it Crashes To Desktop.

After getting my hopes up with several fixes that appeared to work, but proved not to after a few more flights I tested this more thoroughly. I have flown this in several configurations, but the only change that makes a difference between CTD or not is whether I have UBS devices connected or not.

It could be my X570 chipset, of which AMD has recently acknowled to have USB issues, or it could be MSFS, which also had issues with USB devices. They might be related.

I have a likely cause for my case of 0xC0000005 crashes. I don’t have solution yet though. Perhaps Asobo or Microsoft needs to come with another patch, or AMD. I could sell my motherboard and CPU and go back to Intel. With over 300€ spend in the marketplace already I am too invested in MSFS and besides, when it works, it is a fantastic flight simulator, the best I ever ‘played’, and I have been doing so from the FS 5.0 days.