Immediate CTD Opening Control Options (1.12.13.0)

Brief description of the issue: Trying to load Controls causes an immediate CTD

Provide Screenshot(s)/video(s) of the issue encountered: CTD

Detail steps to reproduce the issue encountered: Select Options -> Controls

I tried to remove “AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\SystemAppData”, which was recreated, but the result is the same. Immediate CTD on trying to open Controls.

2 Likes

The issue appears if you have more than 10 devices (mouse, keyboard, +8 peripherals).

You can enter “Controls” with 10, and connect the 11th without a CTD.

However, if you enter “Controls” with more than 10 connected, CTD.

2 Likes

thats a widnows issue. max was always 10.

1 Like

It is not a Windows issues, it’s new to this update:

  • MSFS did not CTD in the previous version (it simply didn’t show >10)
  • Windows USB Game Controllers shows ALL of the devices correctly and can calibrate/test etc.
  • Other software (FSUIPC, Joystick Gremlin, Elite Dangerous) can see all of the devices correctly
4 Likes

Same issues here, I have 13 peripherals. Really don’t want to remove some as I use them in other sims.

2 Likes

Never had a CTD once until I updated to this newest update and now its completely unplayable

2 Likes

I meet the same thing since the update. And indeed the game considers more than 10 peripherals because it counts the keyboard and mouse too bad!

1 Like

same for me. everything was ok before last update. II used to have 15 leo bodnar boards connected plus mouse, keyboard, saitek autopilot, 5 saitek instrument panels, 2 saitek radio panels, rudder pedals.
Now when i connect mouse& keyboard and more than 10 devices i have a CTD as soon as I try to acces the control options, just like in the video posted.

1 Like

Nvidia came out with new drivers today. Try and see if that fixes the issue(s)

1 Like

This happens to me too but I found that if I log out of the microsoft store, reboot my PC, then log back into the microsoft store the problem goes away.

1 Like

I am encountering the same issue since update 1.12.13.0.

Had no issues till then. Ans since I just received my new yoke, I can’t even set it up, so FS2020 is a no-go till this issue is fixed.

I did change some of my USB devices around, But have no clue what file stores the control info. In FSX you could just remove the cfg file, and FSX wouls create a new one.

Well, just though about it some more… Guess this is another reason to use FSUIPC and Linda LUA.

2 Likes

So, today I decided to give suggestions posted above a try.

Signing out of Microsoft store, rebooting PC and signing back in : No Go :frowning:

Deleting the folder in the packages directory: No Go :frowning:

Unplugging a powered hub with some control devices: Success, BUT…

Unplugging a Hub, which results in not being able to use the devices connected to it (in my case Throttle Quadrant, 2x GoFlight radio panels, 1 I/O USB board) is not what I call a resolution.

Microsoft/Asobo need to fix this issue if they want Flight Simmers with an extensive set up (maybe even a full cockpit) to stick around.

And NO, this is not a Windows OS limitation, as all my controllers work just fine in X-Plane 11 and Prepar3D. It worked fine in the previous versions of FS2020 (with maybe some controllers not showing up in the Controls menu.

3 Likes

Same problem here, never had any issues with my Pokeys Cards but now the CTD when trying to enter the Control Settings. This for me was not an issue previously. It appears the latest update has caused the limitations.

2 Likes

I have the same problem which I believe was introduced in MSFS2020 v1.12.13.0 , since the CTD behavior started only recently. I do have more that 10 controls installed, since my sim rig supports both flying and racing.

2 Likes

In the midst of updating FS2020 to the latest world update, released today.

HAs anyone tried getting the Control Options to load to see if the CTD with more than 10 controllers has been fixed?

1 Like

I just attempted it, and still CTD. Same thing, more than 10 controllers. I am able to unplug a few controllers, and fiddle with binds(9 controllers). If I want to bind the controllers I have unplugged, I have to unplug one or more of the other controllers, and keep shuffling them till I bind what I want. Then I close M$F$2020 plug all my controllers in, and restart M$F$2020. I just cannot adjust a darned thing until I go through the process of shuffling controllers to be below the 10 limit and bind, rinse and repeat. :dizzy_face:

Incredibly silly if you ask me.

I would recommend loving/liking the thread to get the attention of M$F$2020 Devs.

3 Likes

Yeah,

I already put my vote in.

Crazy that something like this requires votes in order to draw attention.

It should not be happening to begin with.

3 Likes

Keeping this thread alive and cross posting my issue on it.

This needs to be addressed. VKB software had the same limitation and they fixed it shortly after it was reported. Something as big as MSFS2020 needs to get this addressed especially if they wish to cater to sim pits.

2 Likes

My fix that I posted earlier in the thread no longer works for me either. I am unable to go into the controls menu to change my aircraft binding when I change aircraft. I read somewhere that uninstalling the US language pack, then re-installing it helped but it did’nt work for me. Stuck now.

1 Like