CTD on official LSZH

Please tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?

Xbox

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Few minutes after loading LSZH the game crashed. Sometimes on loading screen. If you landing on airport I get CTD right after touch the ground or few minutes later.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Load or land on LSZH

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

AFTER PREMIERE OF AIRPORT IN OFFICIAL PATCH

Did you try deleting your Rolling Cache?
If so, did you try with any Marketplace purchases uninstalled?

I tried with clean cache. I tried with clean install of whole game. I tried bigger cache. I tried in night and day conditions. In day I can do only taxi if I hurry up, in night it is going to crash right after or few minutes later after click Fly button.

I tried with no AI Trfaffic no live traffic no multiplayer. Every time I had that same issue.

I have the same issue with asobos LSZH

Do you have any other Marketplace purchases installed?
Any particular airplane that you tried, or does it happen with any aircraft?

I tried with default planes and 3 party planes. I get the same results.

1 Like

Not having Xbox I’m not sure of what options you have.
Do you have the option to uninstall the LSZH airport from the Content Manager?
If so, try uninstalling.
Then shut down sim.
Restart sim and re-install it, see if that helps

I have the same issue. It is not possible to load LSZH. If I try, the loading is very long and then I have a CTD. I have also tried to land in LSZH departing from another airport, but when I arrive in approach the sim freeze and CTD.
That happens with Xbox X and default airport.

1 Like

Please tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?
Xbox

Are you using Developer Mode or made changes in it?
N/A

Brief description of the issue:
Whenever you taxi to your assigned runway or stand after landing that ATC give you the sim stutters and then suddenly crashes to desktop. However when you spawn on the runway the sim works as it should.

Provide Screenshot(s)/video(s) of the issue encountered:
Unable to get

Detailed steps to reproduce the issue encountered:
Select Zurich airport and a destination to fly to.
Select a jetliner (they’re the only ones I use so unsure it will happen with other aircraft)
Select a stand to spawn at
Start the aircraft up and request clearance from ATC (where they give you your altitude) then request your taxi route.
Request pushback or use reverse thrust (doesn’t matter which)
Start taxiing along the route ATC have given you then it will eventually start crashing, doesn’t matter if you’re in cockpit view or external view, the sim stutters then crashes

Select arrival airport in this case Zurich
Select an aircraft
Land at assigned runway that ATC give you
Exit runway as you normally would then request taxi to the gate from ATC
Follow the route ATC gives you
Then the sim crashes

PC specs and/or peripheral set up if relevant:
N/A

Build Version # when you first started experiencing this issue:
Build version 1.23.12.0 only experienced it since updating to the current build never used this airport until then

1 Like

1.25.12.0 here - still very much same issue. Also tried with Beechcraft turboprop to see if it is limited to airliners. No, issue persists.

I am not starting on stand though - just direct departure from RW28

1 Like

Hate the WU Switzerland to broke this beautiful airport. Every time ctd

I still have the same problems with msfs version 1.25.12.0. It doesn’t matter which airplane I use, the game constantly crashes. This airport is unusable since months!

Still experimenting with these CTDs on XBOX, although switched to play on PC for time being.

I am getting constant crashes spawning in LSZH as soon as intro cinematic are over whenever I have AI or even Live traffic ON. But I also get CTD later while taxying to runway even with all traffic and weather off - clear skies custom preset, mid-day.

Conclusion → while turning on traffic exacerbate the issue, it still happens without it. Most likely we are looking at multiple causes/race condition or performance thresholds/limits/timeouts being reached here.

LSZH is definitely unplayable. I’m on Xbox Series X. Did a completely clean install with just Premium Deluxe additional content and it still crashes a few minutes after loading in the gate.

I thought that this was caused by the disastrous Sim Update 9 consequences on Xbox, but I’m so sad to find here that actually this is already a thing since way before.

Insanely frustrating!

No patch nothing…
They destroy Zurich for us

SU 10 Beta does not fix this just yet. My educated guess is this has to do with rendering of other aircraft models and either missing some resources to load or missing memory to load them into.

That’s too bad. I hope this is on their radar for a fix.