CTD upon dev tools loaded during game startup

Please tag your post with #pc and/or #xbox. #PC

Are you on Steam or Microsoft Store version? Microsoft Store

Are you using Developer Mode or made changes in it? Yes but no changes are made.

Brief description of the issue: Not sure if dev tools is the main cause, the game crashes without error just after dev tool bar appeared during initial game startup and sometimes it crashes with error “the memory could not be read” my virtual memory is set to max 8gb and my physical memory is around 30% before launch and around 50% during loading

Provide Screenshot(s)/video(s) of the issue encountered: https://filestore.community.support.microsoft.com/api/images/1694d3f1-1016-4926-9275-21af87928eaf?upload=true

Detail steps to reproduce the issue encountered: Enable dev mode then exit the game without disabling it.

PC specs and/or peripheral set up of relevant: 16GB RAM DDR4 2666MHZ, GTX 1660Ti, Ryzen 5 2600, Thrustmaster Warthog

Build Version # when you first started experiencing this issue: The latest build

set it to 8 MIN and 20 MAX and ensure enought free disc space

additional note about your dev.tool issue:

I don’t think memory is the problem. Because when I first got the game there was no issue with memory(virtual at 8gb set by system) with the game settings I had. The problem only began when I turned on that dev mode.

it’s as allways - just give it a try then you can be sure :slight_smile:

( a max size of 8GIG is in generally not much… the basic rule (our experiance) in relation to MSFS is/was that you have to ensure that the system can reach 32GIG memory ).

If that not help, then as mentioned may be you have to start offline and also may be you have to try to remove your settings ( there are some topics in forum ). So far I remember is the setting for dev.mode somewhere stored in cloud-settings. Removal of own setting files may be also help If you changed manually some mount-points with help of dev.tool.

I manage to… I think? get rid of the dev mode by going offline at the start of MSFS then relogin and resetup. But the problem still persists… so I’m having a memory problem? Though I’ve already set the virtual memory according to your suggestion the system only allocate 8gb
Imgur
and how do I make MSFS use physical memory instead of virtual? my physical mem is only at 50% on loading and it crashed. It’s weird how I’m able to play it fine no issues whatsoever when I first started playing MSFS until I tried to install custom liveries

The issue is not gone with minimum 8GIG setting ? Then the problem is not caused from this and you can decrease the minimum value ( I still would not recommend to set a lower max than 20 )

the usage is not alone MSFS, it’s how ( and for what ) windows use virtual memory. The memory consume of MSFS is since SU4 or 5 ( can’t remember ) drasiticly decreased. But as many other simulators too, its needs still a big portion of of it. Important is here the “commited memory” ( you can see this e.g. in resource manager , its a different value than the Taskmanager show you per default ). As more mods, liveries, etc you have installed , as more memory is often used. And then is of course all the other applications , the OS itself, etc…

You can also check with help of the taskmanager the used virtual memory of an application. Within the defails page you can choose lots of columns.

But if these setting not fix your issue, hmmm…
Have you already tried to remove all mods ( should be step number one ) and is the Safe mode again available ?
Have you made former some special settings in Dev.Mode ? ( so far I know Dev.Mod is not necessary for community mods )
Have you running some special tools in parallel ( afterburner, etc… ) ?
Are there other error message logged than these “could not read…” ?

Other than MSFS I play DCS World(I haven’t mod it yet but plan to) running it high to ultra setting the task manager shows it uses up to 80-90%(mid-game) mem and stays around there, the game is pretty smooth 40-50 so MSFS should be no problem I even set MSFS per Nvidia Geforce optimal setting which is low to high. But all that aside I’m confused as to why I can’t at least get to the main menu, I would understand if the game crashes when I attempt to play or mid-game… do I need to overclock my system now? (afterburner)

With how it is right now, I already did a clean reinstall of the whole game by removing (MSFS, Appdata/Package, Official&Community Folder). I also launched in safe mode when I get the option to do so.

I don’t think so, all I did was flick the dev switch and be on my way and you’re right the tutorial I watched just did that to find the community folder… :confused:

Nope, none.

Well… there is this crashdump but I’m not sure what to make out of it

Microsoft (R) Windows Debugger Version 10.0.22415.1003 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\ReMiKU\AppData\Local\CrashDumps\FlightSimulator.exe.1552.dmp]
User Mini Dump File: Only registers, stack and portions of memory are available


************* Path validation summary **************
Response                         Time (ms)     Location
Deferred                                       srv*
Symbol search path is: srv*
Executable search path is: 
Windows 10 Version 19043 MP (12 procs) Free x64
Product: WinNt, suite: SingleUserTS
Edition build lab: 19041.1.amd64fre.vb_release.191206-1406
Machine Name:
Debug session time: Sat Oct 30 09:45:45.000 2021 (UTC + 8:00)
System Uptime: not available
Process Uptime: 0 days 0:00:48.000
................................................................
.............................
This dump file has an exception of interest stored in it.
The stored exception information can be accessed via .ecxr.
(610.440c): Security check failure or stack buffer overrun - code c0000409 (first/second chance not available)
Subcode: 0x7 FAST_FAIL_FATAL_APP_EXIT 
For analysis of this file, run !analyze -v
ucrtbase!abort+0x4e:
00007ffe`75ab286e cd29            int     29h
0:006> !analyze -v
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************


KEY_VALUES_STRING: 1

    Key  : Analysis.CPU.mSec
    Value: 1421

    Key  : Analysis.DebugAnalysisManager
    Value: Create

    Key  : Analysis.Elapsed.mSec
    Value: 47981

    Key  : Analysis.Init.CPU.mSec
    Value: 561

    Key  : Analysis.Init.Elapsed.mSec
    Value: 292246

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 99

    Key  : FailFast.Name
    Value: FATAL_APP_EXIT

    Key  : FailFast.Type
    Value: 7

    Key  : Timeline.Process.Start.DeltaSec
    Value: 48

    Key  : WER.OS.Branch
    Value: vb_release

    Key  : WER.OS.Timestamp
    Value: 2019-12-06T14:06:00Z

    Key  : WER.OS.Version
    Value: 10.0.19041.1

    Key  : WER.Process.Version
    Value: 53.1.0.0


NTGLOBALFLAG:  0

PROCESS_BAM_CURRENT_THROTTLED: 0

PROCESS_BAM_PREVIOUS_THROTTLED: 0

APPLICATION_VERIFIER_FLAGS:  0

CONTEXT:  (.ecxr)
rax=0000000000000001 rbx=000000830f37db70 rcx=0000000000000007
rdx=000000000000000f rsi=00007ff761ac9a80 rdi=000000830f37d3b0
rip=00007ffe75ab286e rsp=000000830f37d190 rbp=000000830f37fcd0
 r8=0000000000000002  r9=000000830f37d138 r10=0000000000000013
r11=0000000080220000 r12=ffffffffffffffff r13=00007ffe758be828
r14=0000000000000001 r15=000000830f37d3b0
iopl=0         nv up ei pl nz na pe nc
cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000202
ucrtbase!abort+0x4e:
00007ffe`75ab286e cd29            int     29h
Resetting default scope

EXCEPTION_RECORD:  (.exr -1)
ExceptionAddress: 00007ffe75ab286e (ucrtbase!abort+0x000000000000004e)
   ExceptionCode: c0000409 (Security check failure or stack buffer overrun)
  ExceptionFlags: 00000001
NumberParameters: 1
   Parameter[0]: 0000000000000007
Subcode: 0x7 FAST_FAIL_FATAL_APP_EXIT 

PROCESS_NAME:  FlightSimulator.exe

ERROR_CODE: (NTSTATUS) 0xc0000409 - The system detected an overrun of a stack-based buffer in this application. This overrun could potentially allow a malicious user to gain control of this application.

EXCEPTION_CODE_STR:  c0000409

EXCEPTION_PARAMETER1:  0000000000000007

STACK_TEXT:  
00000083`0f37d190 00007ffe`75ab1f9f     : 00000083`00000003 00000000`00000003 00000040`00001000 00000000`01000000 : ucrtbase!abort+0x4e
00000083`0f37d1c0 00007ff7`61ac9ada     : 00000000`14c02000 00000000`14c02000 00000000`00000000 00000000`ffffffff : ucrtbase!terminate+0x1f
00000083`0f37d1f0 00000000`14c02000     : 00000000`14c02000 00000000`00000000 00000000`ffffffff 00000000`00000000 : FlightSimulator+0x27c9ada
00000083`0f37d1f8 00000000`14c02000     : 00000000`00000000 00000000`ffffffff 00000000`00000000 00007ffe`7573c347 : 0x14c02000
00000083`0f37d200 00000000`00000000     : 00000000`ffffffff 00000000`00000000 00007ffe`7573c347 00000000`00000000 : 0x14c02000


SYMBOL_NAME:  ucrtbase!abort+4e

MODULE_NAME: ucrtbase

IMAGE_NAME:  ucrtbase.dll

STACK_COMMAND:  ~0s ; .ecxr ; kb

FAILURE_BUCKET_ID:  FAIL_FAST_FATAL_APP_EXIT_c0000409_ucrtbase.dll!abort

OS_VERSION:  10.0.19041.1

BUILDLAB_STR:  vb_release

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

IMAGE_VERSION:  10.0.19041.789

FAILURE_ID_HASH:  {e31753ac-c98a-8055-3663-47e707543d20}

Followup:     MachineOwner
---------

as mentioned, you can check the “commited memory” in resource manager. The diff is by DCS often not much high, but it exist too.
Snap 2021-10-31 at 12.42.40
( commit in german: Zugesichert )

no… please not :slight_smile:

As you reported your issue comes with a setting / usage of dev.tools . The virt.mem setting was just a “standard” try and we tested that it’s not the issue in your case. Not change to much at your system compared with the last known “ok config”.

If the game will now start also not in safe mode… hmmmmm… After the Re-Installation, you had must re-do the whole configuration of MSFS ? ( I try to find out whether still somewhat is loaded from cloud ).

But the important thing from dump is : c0000409 ucrtbase ( :grimacing: )

I assume this stands in meanwhile for a lot of reasons and we have some existing topics about. From (older) sound-driver isses, connect issue (firewall, anti-vor), over account issues ( re-login in xbox app ) till unknown-issues ( assumption is often a setting stored within the cloud ).

Not that you run from the first issue with dev.mode into a second one :thinking: … ( or first one was just a sympthom ).

To be sure… you can also not start the game offline ?

now, as example the login is done before, etc… ( these xbox login caused for some users issues, in special if they “play” with different windows/xbox/… users and accounts ) . But there is a lot of other stuff done before the menu will be opened.

How far is the Blue-Bar ( in % ) if the loading crashs ( 50% , 80% … ) ?

PS::

this is not a good idea… I can not recommend this Geforce “Auto Opt… Setting” and we had some topics about where this caused issues… of course if it runs fine before, you not need to change it, but if have effects…

These are the screenshot I took just before the crash:
Imgur
Imgur

:sweat: Does Microsoft not have any option to reset everything (cloud, local, game settings etc…) for a fresh start. The supposedly reset button in the app settings doesn’t seem to help aswell…
Imgur
(or the repair)

Yes. I tried to cut off the internet just before “checking for updates” and I can’t get anywhere with this:
Imgur
Then I tried cutting off the internet after the checking but it loaded the game as usual up to the crash point.

I see… here I thought that the official Geforce driver update that comes with Microsoft flight simulator banner would mean optimal compatibility or the such with the game :confused:

hmmm… these 50% Blue-Bar… this seems like the Login issue… have you checked that you can login with help of the xbox app or tried a Re-Login ?

And, to be sure, may be check all the other reasons for a …409 & ucrtbase… ( e.g. try disable anti-virus tools e.g. BullGuard, check US lang pack, check time settings, some users report issues with Xbl * settings in Auth-manager , or also ensure that game-services running in case gamepass, )

For a reset I remember at these post:

I think in general is this one a good additional topic:

But there are still some other open topics where users describe same/similar issue, where users also checked all well known reasons but seems to have any kind of login (accouting) -issue. Can’t remember for “THE final solution”…

Sorry for the very late reply but I kinda have given up on the game trying to fix it in the time span until this reply. The solution you provided I had tried a couple but to no avail however today I did a clean install of Windows 11 and also removed all windowsapp folders and started fresh, I do not know which and how it got fixed but it did… I’m back now! sigh~
Imgur

1 Like