CTD when Joystick is connected

Hi all, so I hope someone can point me in the right direction. So a recent MS update crashed my PC and I had to start from scratch. After installing MSFS, I ran into the situation that everytime a Joystick is connected, MSFS performes a CTD. What I found out after hours of testings is the following:
When I delete all joystick profiles in C:\Users\username\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\SystemAppData\wgs\000901F93F966DE8_00000000000000000000000069F80140 and manage to start MSFS offline, all is working perfect. As soon as MSFS is syncing cloud data, the profiles are restored and it ends in a CTD.

So my big questions is: How do I reset the cloud data? I tried this fix but unfortunately it did not work for me. Any help or suggestion from the community would really help.

Thanks

I second the request. I did a clean install of MSFS and decided to plug in my long-neglected Thrustmaster joystick instead of my yoke and throttle (to fly planes using a joystick) and got an immediate CTD. I unplugged the joystick and started the sim again. Then as soon as I plugged in the joystick–CTD.

1 Like

I always plug in all peripherals before starting the sim.

1 Like

YES-- I wish this could be addressed. ie Thrustmaster “Top Gun” FF Joystick

RUns fine if FSX is installed on the Computer.
CTD if MSFS is run.
(MSFS CTD during loading if Joystick is pre-plugged in)
(MSFS CTD is plugged in after a full start as well)

Plugging in a Joystick should NOT crash MSFS !!!

3 Likes

It doesn’t matter when you connect the joystick. Either before or in game - results in a CTD.

3 Likes

EXACTLY … make no difference… still a CTD

1 Like

Steam or MS Store purchase?

MS store. It looks like there is a workaround for the steam version.

There is to the MS Store as well.
Go to c:/users/(username)/AppData/Local/Packages/Microsoft.FlightSimulator_8wekyb3d8bbwe/SystemAppData/wgs folder
There should be two folders there, one called “t” and the other with a huge alphanumeric name like 000901F6… Open that one.
Under that folder, there are a bunch of other Alpha Numeric (ie 69D9FE4C2AB94940B11A4D26A23A9561) name folders. Open each one, and you’ll find a container. file, and then another “file” with another huge alpha numeric name (i.e. A1036E4CDAAB21882AD5630E81466F). Open that file up with NOTEPAD or NOTEPAD ++. If you get nothing but screen barf, exit out and go to the next folder. Don’t touch that folder.
Go to the next numbered folder and continue opening the alpha numeric files. As you go through these folders, some of those alpha numeric files will contain your controller data that’s easily readable… If you find one, exit the editor and delete the folder it’s in.
Delete all the folders that reveal they belong to a controller until the only thing left are Number folders with alpha numeric files that can’t be read.
Restart Flight sim. All your previous profiles will be gone.

Thanks for that. However, I have already tried this. Does not work.

1 Like

Sorry to hear that, I have never heard of those being restored again.
After reading the thread again I realized you had already done so.
What model is the Thrustmaster?

Thrustmaster A320 Flight Stick and Quadrant + Thrustmaster Rudder

1 Like

The first thing comes to mind is drivers for it, are they up to date?
I actually heard of one person in a similar setup who found the solution was to shut down the PC, connect the joystick to it, and start everything back up.
Might be worth a try, but sounds kind of iffy as to its success.

Appreciate your help. It is a clean install of Win 10 and MSFS. All drivers are up to date. Shutting, down restarting - connected or disconnected. I troubleshooted for 2 days now and it really comes down to the syncing, actually the download of the profile files. You can monitor it. If you delete them, they are downloaded the next time you start MSFS. During the startup phase of MSFS, when there is the blue loading bar (basically I have three phases there), everything works fine for the first two sections (if you want to call it like that) During the second phase the profiles are synced (if you delete the profiles manually, you will get a notification window about the sync in progress). After that, when the 3 stage of the blue bar should start, it immediately crashes to the desktop.

And by the way, I have opened a ticket, but the recommendation I got is basically: update everything and remove all Addons. THey did not even read my request…

1 Like

Is the usb port “asleep” in power management?

No, all is set to full power.

1 Like

So, are you saying you can’t get MSFS to start at all now?

Yes. Unless i unplug all joysticks. Flying by mouse and keyboard is no joy

1 Like

The trick of removing the “null” profiles, or otherwise damaged profiles, does work but you must disable online features first, otherwise cloud sync just pulls them down again.

If you do this, a brand new “default” profile will be created the next time the controller is plugged in.

The method for doing this, I think, varies from platform to platform.

You may want to read on from this point:

There appears to be TWO issues here:

    • USB controller stops working after a time where it has worked, and now causes a CTD when it is plugged in.
    • A new USB controller (certain Joystick models) cause a CTD every time, even the 1st time they are used.

#1 can probably be corrected by deleting the profile, and letting it build again

#2 is being caused by a specif model Joystick, and the Asobo MSFS2020 crashing when it sees that particular make joystick ??? (for whatever reason, unknown to the user)

The one thing I am certain of is that EVERYONE with the Thrustmaster “Top Gun” FF joystick, have, and always have had, 100% a CTD when that joystick is detected by MSFS2020, yet it works fine on any Joystick Test program, and even with FSX, on a W10 machine.

1 Like