CTD when loading since unpdate to 40th

Since todays update I can’t load MSFS. I get the screen with the plane flying, then the black screen and the CTD. Tried multiple times with same result. Finally uninstalled and reinstalled but the same issue. Running as admin doesn’t do anything.

Worked fine before the 40th update.

3 Likes

I am experiencing the same issue. I was able to play it yesterday after installing the update, but today it CTD every time during the loading of the game itself. I even removed all of the files out of the community folder. Same result.

1 Like

same issue for me

Same here. First took 2 days to download and now i get CTD after flying 15-20 min. Not to mention the long boot up time. Been with FS2020 from the beginning and this is the worst update I have ever experienced. Sim UD10 was a dream come true, 11 is a frustrating CTD fest! This is getting old real quick.

Please upvote this report so the devs will be aware of it. Sim wont start after 40th anniversary update

2 Likes

Update: Knowledge of how to troubleshoot and solve past updates has paid off. No more CTD, it still takes awhile to load but to be honest this sim is gorgeous!! Nice 40th!

Are you not going to give some insight into what knowledge from the past you applied?

I have had the same issue for 3 days with two occasions re-installing the game. I had no issue with the SU11 Beta nor prior updates. Since Friday, once I have all of the updates downloaded and installed, I get the following crash seconds into loading. I am assuming it is server-related but I’m happy to troubleshoot if not. As a side note, prior to downloading the updates, when the plain-vanilla sim is downloaded with no SU/WU packages and online functionality is disabled, it will load albeit with the marketplace greyed out. As soon as I download the rest of my packages and enable online play, I get this behavior. Not sure whether I should take another day off or begin troubleshooting. Some information from the devs about the state of things would help.

I have never had to re-install the sim. I empty my community folder before update, make sure everything is current and updated on my pc, windows, ms store and nvidia drivers (drivers only) without Geforce Experience. After taking literally 2 days to download I had ctd,s every 15-20 min into flight. Reinstalled the previous nvidia driver 522.25 and the ctd,s stopped. Now here’s the part I don’t understand but it works for me. I put back my community folder, reinstalled the latest nvidia driver 526.86 again without Geforce Experience and although the sim takes awhile to load it runs beautifully, no ctd,s. I sincerely hope this helps, this sim is a love/hate relationship. Best to you.

Go through each of the following steps one at a time. Copy each line, one at a time , paste it into Power shell (Admin rights)…

and it will then run. Wait until each runs and finishes before you move on to the next one.

When you are completely finished, Restart your computer and then try to see in MS2020 will start and run properly

Dism.exe /online /Cleanup-Image /checkhealth

Dism.exe /online /Cleanup-Image /scanhealth

Dism.exe /online /Cleanup-Image /Restorehealth

sfc /scannow

Dism.exe /Online /Cleanup-Image /AnalyzeComponentStore

Dism.exe /Online /Cleanup-Image /StartComponentCleanup

RESTART your computer as the last step. Then go for a test flight.

1 Like

Thanks. I got it working.

I’ve reinstalled for the last time. Over the few day I reinstalled several times I used most of my internet time with Comcast.

Finally got it working. Blue smoke and mirrors.

Always avoid reinstalling because it often does not resolve the issue. You can be assured that running the commands above ensure your OS is clean and corrupt free. Saves a lot of time.

Same thing here. Was working pretty well until the 40th Anniversary update. Now I’m getting CTD’s at the very first loader splash screen (before checking for updates). Odd thing is that one in every ten attempts it will load perfectly fine and then i can fly for hours without a problem. Very odd and annoying as hell.

Tried all the usual stuff like making sure everything’s up to date, SFC, DISM cleanup, cache clearing, complete reinstall etc. Nothing make as a difference.

opt into the SU11 beta, that fixed it for me