CTD with no Log (Even not in Event Viewer)

CTD and no log

I know it is very very weird but its real. I tried a lot of things. Tried to usb unplug. Driver updates etc. Delete simconnect, reinstall game. Delete caches. but I cant solve this problem. Everything happens in 1 or less than 1 hour. Sometimes after 30min, sometimes 50 min and CTD!. Its not just happening on the air. Sometimes I open main menu and wait for see any crash to desktop and Its crashing even in Main Menu.

I’ve been dealing with this for 3 weeks. I havent any ctd when game relased and few months but after last updates my game constantly crashes with no logs. I tried this but it didnt worked too. So please help me

CTD=Crash to desktop

There is a simconnect issue that is causing CTD’s that recently arose.
ASOBO is aware of the issue, and have found the solution.
It should be out with this week’s update.
Until then, search the forum for “AI Simconnect”.
You will find lots of info.
The solution is to put as little info through Simconnect as possible.
The more it handles, the more unstable the sim becomes.

FYI, the moderators are a bit strict on posting in the Bugs & Issues section, as per the site rules, so you should search all the other sections of the forum that may pertain to your issue before you post here.
This section of the forum is for proven bugs that you can’t find a solution elsewhere on the forum.

Thanks for your reply but I didnt find any solution in this forum. I saw a lot of things and tried them but none of them can solve my problem.

If my ctd’s left trace (log or entry in the event viewer) i will spesifically search for it but there is no trace. No any solution for my problem in this forum.

Like I mentioned, this is a bug from Simconnect.
I very much doubt it is your sim.
The answer to your problem is in my post above.
AI and addon mods that connect to the sim through Simconnect are causing this.
The more you run through Simconnect the less stable the sim becomes.

For more information use the search function for “AI Simconnect”, and then filter for “latest post”

I have nothing working with simconnect. I deleted all simconnect clients and my aı traffic is off. Still CTD’s. I have no addon mods or anything buyed from marketplace.

Ok, that’s important to know.
No addons either, so no conflicts.
At the top of this page, under “Support”
There is a search function there, type in CTD.

Here is a link to the most important post in there in this regards.
There is a lot more info in the forums too.


This is a start, let us know if you’ve already tried these.

My friend, i spend my all free time in this forum and zendesk. This is first thing i tried :smiley:

1 Like

My apologies, it’s hard to know what everyone’s understanding of the sim is or how much time they spend here!!
Is there any clue or hint or indication from the sim before it happens?
What about your data limitation, that ok?
Did you try with all that data connection section’s sliders off (sim looks terrible with it off- but)

:smiley: Not any indications. Not freezing. Its like ALT+F4 combination. Suddenly closing. My Internet is 35mbps and i set limit 20mbps in msfs. But as i said its weird because its happening not just in airplane. Its happening Main Menu, mid air, ground etc.

Do you know how I test solutions? :smiley:
I open game and wait :smiley:
Im not flying :slight_smile: just waiting and generally it closes itself in one hour

1 Like

SOLVE: dont go illegal ways to play game. Buy it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.