CTDs after SU10 update

Gurus :rofl::rofl::rofl: They probably Googled how to fix it when they got there! Some guy on YouTube said do it this way let’s do that :rofl::rofl:

Nothing like patching over a patch… Think it’s time for bandages or plastercasts now :+1:

Hey thats what most people do here isnt it? I know the fix, go into reg and turn this setting to 0 instead of 1, or if you do a total reinstall of windows, then when hopping on one leg while rotating to the left that will fix it … I’ll stick with the nekid goat dance fixes any problem any time.

1 Like

I’m getting tired!! Disabled fullscreen opt. enabled Nvidia debug mode, played arround with graphic settings, sfc/scannow, tried almost all workarounds I was able to find. I’m afraid to start a flight, only to get disappointed by a CTD. Asobo please, your product is unplayable. =((

Same Error: 0xc0000005.

Ryzen 5 3600
RTX 2060 Super
32gb Ram
Win 10

I think I got my sim working again !
What I have done was change the graphic setting to medium and make small adjustments on shadow.
Then I use TAA, turn on V-sync and set to 50% refresh rate.
Now I have done a 35 mins flight, and TPE-HKG-TPE flight (In sim time 5Hrs) without crashing.

If you are running out of ideas what to do, maybe you can try my settings.

Mine wouldn’t even start in safe mode this morning, about 5 hrs in to a full re install of msfs :yawning_face::yawning_face:

Since the SU10 update, I have not been able to fly. All good up until clicking “Ready to Fly”, then CTD. For a time I was getting a “The memory could not be read” error, then just CTD with no error. Now back to the memory could not be read error again. I’ve tried just about everything but a reset or reinstall, hoping this will be addressed before having to go through reinstalling.

Have you tried relaunching over and over again to see if the sim ‘catches’ and will actually run. This morning being an example here it took 5 CTD’s before I could actually get to the airport and fly, and then the performance was dismal at best.

I’ve tried over and over many times. Same result. I’ve never had problems until this update.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Not sure what OP’s steps means.

Provide extra information to complete the original description of the issue:

I get a CTD every time I click Start to Fly since updating to SU10. Never had problems before. Sometimes I get an “The memory could not be read” error, sometimes no error, just straight to desktop. I AM able to fly in the Destinations module. I hope this gets resolved. I’ve followed as many workarounds as I’ve been able to find, but no help.

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Fault bucket 1599167045803452784, type 5

The problem you encountered is different from me. I never crash at the click of Start to Fly. My problem was the sim would crash every time after I got into the cockpit for 5~30 mins, sometimes on ground, sometimes in flight. The error code in the event viewer was 0xc0000005, faulty model sometimes shows VCRUNTIME140.dll, but most of the time FlightSimulator.exe.
Yesterday I found that I too have the problem that Sim would CTD when select another player or a friend from the world map. But this is not a big deal, I’m satisfied as long as I can fly normally without CTDs.

Have you tried this post? MSFS Application Error - memory could not be read
And this one? CTD in World Map!? - #22 by PhoenixHahn

I was too optimistic. I fly TPE-NRT today and got 2 CTDs with VCRUNTIME140.dll, and the always 0xc0000005. Seems I have to do some more debugging now… or just wait for Asobo to address it and fly P3D for now.

That file is part of the Microsoft Visual Studio

Be sure Winodws is completely up to date…current version is 21H2 19044.2075 don’t forget to check the ‘view optional update’ category.

Or just download the latest VC++ Runtimes.


Yes, I’m currently on this version.

Thank you. I had re-installed this for several times, but the VCRUNTIME140.dll error still would show up sometimes. And the faulty module is not in the Windows/System32 folder, but in the C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.30704.0_x64__8wekyb3d8bbwe. Which I doubt can be updated by the package you post since the folder and files are still there after I uninstalled every C++ Redistributable library. And after I re-install the latest library downloaded from microsoft, the “Date Modified” are still the same.

Yes, that’s the version that comes with the sim. Even if you could update it, bad things might happen. :slight_smile:

Are those errors random? Do they happen often enough where, if you were to change anything, would you notice immediately that things had gotten better?

The first thing to try would be to rename the Community folder, and re-test, but I know from experience that this is a difficult thing to prove. You can’t make one flight that doesn’t crash and call that a successful test, as that could have been random also.

Today I got 2 CTDs when flying from RJTT to RJCH. One with faulty module FlightSimulator.exe and one with VCRUNTIME140.dll. I had tried to remove all folders in the community folder and fly with default 787, but I still got CTD problem. The whole week after SU10 came out I got CTD on every flight 5~30Mins into cockpit. The sim is simply unflyable. After the World Update and I adjusted the graphic setting, the problem improved a lot. At least I can fly a turnaround flight TPE-HKG-TPE. But still CTD may happened sometimes. Like last time I’m flying TPE-NRT and got 2 CTDs. Today HND-HKD 2 CTDs.


You can check whether it happens allways at same place ?

But I also remember we had older issue related to VCRUNTIME140.dll at specific location , which are in relation to working-title Gxxx. Also after removal from community folder, some files are left somewhere and needed manuall removed. ( what I remember ). Example topic: Game randomly crashes mid flight

But for the vcruntime error are different reasons possible, from libs up2date, system issue, mods…
You can also try the usually things like limit the fps to check whether that have an positive effect.

Not these CTDs happened at the same place. Take today for example, the first CTD occurred on climbing out from RJTT near RJSF. The second one happened near Aomori when descending into RJCH. The flight RJCC-RJTT in the afternoon had no problem. And after 2 CTDs enroute RJTT-RJCH, I fly from RJCH back to RJTT with no problem.

I’ve not had a single CTD with SU10 or WU11 that was in flight. I’ve had a ton trying to load a flight, and a couple while loading the sim, but if I click Fly, and I actually get to spawn the plane then I’m good.

1 Like