CTDs after SU10 update

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Tried but still CTDs

Brief description of the issue:

I got CTDs after 10~60 Mins into cockpit. The crashed module was VCRUNTIME140.dll right after SU10 update, but after I remove then re-installed the vcredist it became FlightSimulator.exe. It just crashed everytime that I tried to fly for 20 flights but no way I can reach my destination. The spot where CTD occurs are different everytime. Sometimes during pushback, most of the time mid-flight.

Provide Screenshot(s)/video(s) of the issue encountered:

MSFS CAL201 TSA→PVG 松山→浦東 A Pilot's Life - YouTube

Detailed steps to reproduce the issue encountered:

no steps taken, just a normal flight then CTDs

PC specs and/or peripheral set up if relevant:

CPU: i9-9900K
RAM: 32GB
GPU: RTX2080 Super
Controller: Saitek flight sim yoke with rudder peddle, throttletek B747 throttle. Track IR 5

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

2012500147676043614
1616986124745345598
2155825440777406942
And much more…

Build Version # when you first started experiencing this issue:

1.27.21.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Right after my report, the VCRUNTIME140.dll crash come back again!
The Fault Bucket ID is 1398041194045492204 this time.

Topic moved into Community Support > CTD Help for assistance.

Look in event viewer and see what the exception was. If its the 000005 one it helps to install an older driver (at least here). Also if it is that is what alot of us are experiencing as of su10

Thank you for the reply!
Do you mean the 0xc0000005 code? If yes, it’s exactly the one I encountered.
And the older driver you suggested is that nVidia driver? Thank you very much.

Yes thats the code, and yes the Nvidia driver. In this instance its them its not you Hahahahaha.

Installing an older driver wont completely fix it but it makes it better to where you should be able to get a flight in at least. Good Luck

Thank you for pointing me out the direction, I’ll definately try that and will report back!

I’ve not had any before today, and I flew for hours yesterday. Today I haven’t managed to even spawn in yet without crashing.

image

At first I thought it was the airport, PANC, then I tried URMM, and it crashed there as well. I haven’t even had a chance to change anything on my PC since yesterday. I might try switching MP servers, stuff like that.

Well MP server change, setting AI, and live players off didn’t help. Still can’t even spawn in…weird.

Ive having a terrible day with the sim all day. Im starting to wonder if they called Nvidia for help, they sent a couple of guru’s out who looked at the code and said no no no you cant do it that way, showed them the right way and now they’re scrambling with a rewrite to fix.???

Switched from the Black Square Caravan to the steam 172, and I spawned in! Even weirder. Guess I’m flying this tonight. :rofl:

Im flying the ski in that other sim, it runs just fine ;p

A few other things to try. I could disable the 750 mod, but again it was working fine all day yesterday.

The one I installed was 516.94, the latest for now. With your suggestion, I revert back to 516.59, then 511.79 but the same problem persist. I still got crash after 10 to 30 mins into cockpit. Thank you for trying to help. Are there any other suggestions? Thanks in advanced.

Well you could uninstall the vid driver *(everything), then reboot, open windows update and let that install the windows version of the driver. If this is how your doing it, then you could do the opposite, get a copy of

DDU from 3dgurus, then download the nvidia WHQL driver you want to use, boot into single user mode in windows, then use ddu to uninstall all traces of your driver. Then disconnect you network (pulling the cable is enough), reboot windows into normal mode, then install the nvidia driver that you previously download, reboot and then plug the network back in.

Thank you, but still no joy. When using the driver from window I got CTD even more faster then before.

Im getting them here too, rolled back to a real old driver the other day, they went away for the most part for a day, and now they’ve returned. My reshade all of a sudden isnt working correctly for MSFS either.

Ive got Xplane 11.5 so I get my daily flight in, and Im getting ready to buy the latest version 12, just because Im so sick of the BS this game seems to becoming.

1 Like

So no news on this yet?

nope. Having the same issue

Nope they are aware of the problem but blah blah blah…

Its kind of funny the day the studio driver dropped windows updated as well, and then 12 hours later or so we got SU10. For win 11 users there is an issue with windows running debug mode routines in DX12, which in turn kills fps and performance.

I just read an article yesterday that said the ms and nvidia we’re working on the problem and the new fixed driver for that problem will be out this week. So theres that lol???

I noted the 3 different releases with in 24 hour of each other and made a joke if the sim gets worse we wont know who’s to blame MS, Nvidia or Asobo ;p