CTDs ever since patch to fix stutters

Ever since the patch that was supposed to fix stuttering was released, I usually have a CTD within 1/2 to one hour during a flight. I didn’t encounter any crashes before this except maybe once or twice when I tried to exit to the main menu. I also didn’t have any stuttering problems to begin with so the patch was really a detriment for me. I have a new setup with a i9-10850 cpu with a 3080 rtx gpu and 32 GB of RAM. Anyone else have similar issues?

One of the most common reasons is problems between addons and overclocking.

  • So first try again with an empty Community folder.
  • MSFS is notriously sensitive to slight instabilities. Since the last update I had a few CTDs as well and dialed the RAM and CPU speeds back a tad. Runs smoothly now and no more CTDs. Also running D.O.C.P / XMP values can easily trigger CTDs.

Have you messed up anything on your Monstrous hardware ?
You know , overclocking and such…
Have you try edit-modify anything from the original software?

I read you
Greetings

I’m running at stock speeds. I have some Addons like Navigraph and air manager usually running. I can try without them. But I never had any issues before. The only other thing I have in my community folder are some add on missions I’m not using right now.

I understand.
Your post an answer has served me well. Thank you.
The next step would be to dig deep inside Windows , and i meen deep , deep in an forseeable -no results- effort to find the problem,
The problem is the sofware itself , some serious lack off “respect for standards” or something. There is no solution other than waiting for them to bee fixed by the ones who developoed and sold it.
You better enjoy your half an hour wonderfull spectacle the software effectively delivers.

I am stoping to search for a more powerfull Laptop , mine is 2016 and has NEVER given up on a multitude of intense 3d applications ( FSX + a handfull off engineering tools i use)

This software somehow “rejects” my Radeon R7 M440 graphics card , to no avail. It is an old one, basic one 4Gb ram , but instead, I run MSFS 2020 perfectly fine ( very low settings ) on the integrated intel 620 graphics chip on “low power mode” by windows,
There is no logic to it. ( "Particularily sensitive ??? … to what ?)

And I enjoy the hell out of it, have used the SDK to place an airstrip near my place in the woods and continue to develop interfaces using Simconnect.

It is what it is.
Calm down , do NOT blame your Hardware nor Windows.

Enjoy.
Thanks again.
Greetings

Thanks. Do you think the Air Manager plug in can be causing issues?

I think not.
But I am just following my logic ( 30+ yeras of software - Fsimm … logic )
I do not use AirManager . But I visited the page and looked at the System requirements…
Nothing fancy , pretty light.
The concept is an independently running desktop application wich will communicate with the sim trough Simconnect …
I use Simconnect with MSFS 2020 with no problems at all.

Surprisingly , the Simconnect API that provides MSFS is similar ( if not identical ) to previous MS Sims… FSX and the like… Even Prepar3D uses the “same”
MSFS 2020 has , eventually crippled or modified Simconnect’s capabilities for things like “Weather”… wich is obvious since the weather algorithm now is totally different …

Enough of that, I would bet on my “No it does not”…

In its webpage, Airmanager does NOT say it runs with MSFS 2020, check it.
This , as I tried to explain , does NOT mean it will not work

One question : Does it run for you in MSFS 2020 ?
I guess it does.

You can try with or without it…

Like many things in life, on face of a problem, the one accountable for it will always try to point to others for its own fault. It is a sport as you say.

In this case , the “Bad Boy” is “Community folder”, older hardware, overclocking… whatever…

Maybe so… but my guts say otherways.

Hope it helps
Greetings

For me the CTDs I seen seem to be related to aircraft models (mainly for AI and ground traffic).
Try setting in General → Traffic → Use Generic Models for AI to ON and possibly also for the Multiplayer to ON.
And then see if that helps.

The CTDs I encountered seem to happen when approaching/overflying a bigger airport where MSFS spawns ground aircraft with their models (you can see that happening in LittleNavMap).
Similar issues were there last autumn (October I think) where using generic models helped as well.

The 4.0 beta version of Air Manager works with MSFS 2020. It has a plug in but I am not sure if that can crash the flight sim.

Do not think so.
Grteeings

I am having same issuse never crashed before last update been in since the alpha trails . Not your hardware or windows.

Glad to know I am not the only one with issues. The game was working well for me before the last update to fix the stutters people were experiencing.

I think the only CTD I had before this was when I exited to the main menu. I think it happened once or twice then. But now it is pretty consistent that it happens sometime during a flight.

Same here, rarely had ctd b4, now every session!! running a 7900x (10c/20t) 3090 and 32gb, no overclocking at all (xcept XMP on memory).

I hope Asobo is looking into this.

i just went back to driver 257.51 and massively helped both stutters and CTD, was getting ctd every launch, in game, an menus, as well as airports looking like a slide show with a 3090, issues still there but much better…

I was on an older nvidia release before and it’s about the same as the latest release. A CTD during a flight.