Cursor focal point misaligned in instrument views

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Brief description of the issue:

When using instrument views in VR, the focal point of the cursor is misaligned, with the left eye being the correct cursor position, requiring me to close my right eye to interact with switches.

Provide Screenshot(s)/video(s) of the issue encountered:

While these screenshots are from a third party aircraft, Concorde, the issue is the same with aircraft included in the sim. The reason I show this aircraft is that the fuel panel is important to operate to fly the aircraft correctly and it is at a completely different seating position to the pilot, ie. the flight engineer’s console, thus requiring me to use instrument views in VR.

First, the normal pilot view to show the cursor correctly aligned

Left eye
Right eye

So far so good. Now for the fuel panel instrument view

Left eye (correct cursor position)
Right eye (cursor position out by more than one switch position)

Detailed steps to reproduce the issue encountered:

Go into VR, load up an aircraft like the standard A320 NEO. Press CTRL 3 to go to the gear lever instrument view. Try to move the cursor over the gear lever and note the difficulty the misaligned cursor provides. Close your right eye, like a pirate!, and operate the switch and note the displeasure of having to do this to operate every switch/knob in instrument view.

A320 NEO Instrument View 3

Left eye (correct)
Right eye (misaligned)

PC specs and/or peripheral set up if relevant:

i9 10850K/3080/32GB/SSD/Reverb G2

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

A new finding relating to this issue. If you bring up the toolbar (nominally tab key in VR) in normal pilot view, the misaligned cursor now presents itself, as the cursor seems to be on a sphere aligned with the toolbar. Closing the toolbar puts the cursor back on the correct plane with cockpit switches.

As such, it seems that in instrument view that the cursor is pulled closer on the the toolbar window sphere, as if the toolbar is showing, yet it is not possible to open and close the toolbar in instrument views, so it cannot be resolved by the user. Something to consider in finding a fix for this issue.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

please fix this!

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

This problem started in SU8 and an early March hot fix was supposed to fix the bug but it didn’t for everyone. Someone in the forum stated that turning off the Home Cockpit option cured the bug, not for everyone

If relevant, provide additional screenshots/video:

This problem still exists in


Likewise, this issue still persists in the current SU9 public release,

Vive Pro headset, here.

I figured out what provokes the mouse ‘splitting’ between eyes: It’s certain viewpoints. In my case, the “left-eye” mouse remains the primary mouse that will toggle things in the cockpit.

In the Concorde, sitting in the default position, things are fine, but if I lean my head back into the “flight engineer’s” view window, OR use the Ctrl+0 toggle to go back the flight engineer’s positon, the mouose splits. In the concorde, the split persists even if I return to the default view via hotkey

In the FBW A320, it’s similar, but slightly different. Almost all Ctrl+# viewpoints split the mouse, but in the A320, the default viewpoint via hotkey, returns the mouse to its proper place


Same issue here, upvoted the thread.

It’s happening on all aircraft, normal view is fine but go to one of the panel views ad I get two cursors. Have to close my right eye and just use the left eye cursor.

Hopefully they fix this soon.

1 Like

Can confirm, as well. I have to close my right eye to make sure the mouse cursor is over the correct instrument panel switch/button/etc. I don’t know if this comment adds any value, other than to pester the poor developers at Asobo. :wink: Regardless, you developers have created an amazing piece of software here. Thank you!

FYI, using a Quest 2 on my system. It’s the same on all aircraft.

For a while there, I thought my 53-year-old eyes had gotten worse overnight. Everything else was going south after 50, so… :stuck_out_tongue:

Also, any updates on this?

Microsoft Store version, no Developer Mode

The cursor position is different for each eye, leading to “double vision” in VR.

Can confirm. This bug was originally introduced with Sim Update 5, but was fixed in Sim Update 6. However, Sim Update 7 brought back the issue, and now looks even worse in Sim Update 8.

Asobo, please fix the “dot” cursor when using the mouse in VR!

This bug makes it very nauseating to fly in VR since it causes double vision!

@Jummivana any chance to raise this to the devs? It might not be on their radar since they “fixed” it already in SU6.


Can you provide details on which VR headset you’re using? Thanks!

Reverb G2 for me.

Also Reverb G2 but I don’t think it maters. It looks like the cursor is always the same distance from the observer instead of moving over the cockpit surfaces.

Had the same problem in the past, su7 probably.

The real problem was that the mouse cursor didn’t follow cockpit depth, was always hovering at the same distance (too close) from the viewpoint.

I did a re-install and the issue has gone.

From what I’ve been able to work out, the cursor is correctly positioned in the left eye but wrong on the right.

I certainly find closing my right eye helps enormously when I need to click something accurately.

Been meaning to suggest an option to limit the cursor drawing to the left eye only.

Oculus Quest 2 in my case. But I only see double cursor on some planes. Not at all.

Same here, Reverb G2

Same here, Reverb G2. The left eye is the correct cursor position. I have to close my right eye to aim my pointer, like a pirate arrrr! :joy:

To add, this issue is particularly worse when using one of the instrument views. I first noticed it with the FBW A320. Being the good little beta tester I like to think I am :slight_smile: and realising I would be pinged for using a third party aircraft, I also tried it on the stock C208B and stock 747-8 and it does the same thing. This was not happening on SU7.

Some example pictures, cropped to show the cursor discrepancy:


Left eye
a320 left
Right eye
A320 right


Left eye
C208B left
Right eye
C208 right

This is interesting, I am not able to reproduce this all the time, I saw it in the Seneca V, but haven’t seen this in a32nx, TBM and Dreamliner

Reverb G2.

I can confirm that this is still an issue with instrument views in the new Beta version