DC-6 by PMDG not working at all for me

Hi,

I recently bought the DC-6 for MSFS from PMDG. And I have had many issues with it. First of all whenever I move any of my control surfaces they don’t move in the game at all. The yoke just stays the same. Same in the outside view I can’t see the rudder, elevator’s or ailerons moving at all. There is also an issue in which there is a very long delay between when I move my control surfaces and when it reacts. I also can’t seem to set up my engines with my TCA throttle quadrant. I have had the same issue with the CRJ from Aerosoft. I have tried binding my L Axis-X to both Eng. 1 and 2 and L Axis-Y to Eng. 3 and 4. This works to an extent as when I move the throttle in full power it responds in the game but for maybe half a second. It then goes straight back to idle. If anyone knows how to fix these issues please let me know,

Thanks

2 Likes

I’ve not had any problems but have you tried turning off the gust lock? This will lock the control surfaces in place if on.

With the throttles - have you handed them over to the engineer? Turn off the tick box for him on the AFE page of the tablet.

These may not be correct but that’s all I can think of!

5 Likes

Both problems are now fixed. Thanks!

1 Like

No problem! The gust lock has never started as on for me so I don’t even know where it is! Just knew it had one somewhere!
Happy flying!

the sluggishness could just be the plane itself. It’s not the most nimble thing :wink: Here is a video that shows both issues, where the lock is and what the ‘norm’ is for mobility for comparison.

2 Likes

there is a red lever on the right side of the seat that blocks the ailerons to avoid damaging the plane with the wind when it is parked

That gust lock ended my first flight a bit earlier than planned!

1 Like

have you solved with the proposal above, or what was the soloution for this

It was the gust lock, wasn’t it? If people just would read manuals…

Karl

2 Likes

Not quite sure why can I not release the Parking Brakes (always at Set, or returned to Set right after Released), check Gust lock disengaged, and Throttle Levers are also not working with any of my controllers (direct with mouse, XBox Controller, or TCA Airbus Quadrant). Still try to read instructions and video tutorials to find out the problems.

My DC-6 cannot move 1 cm from parking ramp until now.

Not sure about the parking brake, it may be something to do with hydraulics not being set correctly? Or chocks on the tablet?

With the throttles, make sure the AFE doesn’t have control of them. Untick whatever checklist was last finished and you will have control again.

That’s all I can think of. I am not discounting the fact that their may be bugs but I cannot stress this enough for the DC6: At the very least watch the tutorials on YouTube. With these alone I have had many successful flights with 0 problems. The manuals will give you more insight but you should be fine with the tutorials and AFE.

2 Likes

I will check again the parking brake problem. I checked and AFE unsticked/deactivated, but Throttle Levers behave not normally, with mouse either. Would have to read again manuals and video tutorials to see what happened with mine.

1 Like

Could also be a bug! Just because I don’t have it doesn’t mean there aren’t any! If it persists check over on the PMDG forums - maybe someone has posted a solution there.

I found the only way to keep my airplane moving is keeping toggle parking brake (in my case, press Y+B on XBox controller) all the time when the airplane on ground/runway until lifted up, as soon as I release the buttons, the parking brake returns to Set and the airplane stops. I have to do the same when landing. Is this normal or a bug?

For the throttles, I have to use key F2, F3 as PMDG suggestion until they release a solution for controllers.

At least my DC-6 has its airborne for the first time. Amazing airplane!

Who has what sensitivity settings? At low throttle, the airplane does not have minimum rpm. And you can’t use reverse. How did anyone get out of it?

To use reverse your throttles need to be set back to idle. Then you can click the red lever in between both throttles. That activates reverse mode. You can then advance your throttle but they will be in reverse mode. To get out of it, go back to idle.

You can assign a key to it by mapping that key to “water rudder”

Thank you. I know all that. The problem is specifically with TCA Airbus. It specifically can’t be put into idle mode.

1 Like

What throttle axis are you using? If you are using Axis 0-100%, you are probably right. For the DC-6, use the regular Axis 1-4 and assign Axis 1 & 2 to the left throttle and Axis 3 & 4 to the right throttle. 320 Sim Pilot shows a working throttle setup in his DC-6 video. Since you will now be using the full travel of the throttle, it is helpful to flip the little side switches on each throttle to stow the reverse levers. Also, there are two long plastic pieces oriented front to back on the underside of the throttle quadrant, secured with two screws. Unscrew one of the pieces and flip it end to end. Repeat with the other. This will remove the detents so you get a smooth throttle experience. Switching the Axis should make idling/reverse pitch possible. Doing the rest will make the experience better.

2 Likes

I have the same problems

I noticed my flight yoke was inactive but starting working for takeoff…my rudder pedals were always responsive.