Default 787-10: No longer able to go direct to a waypoint + missing/invisible waypoints

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

Attempting to load up specific waypoint in the FMC now does not work. and does not elicit a response in FMC or change in track/route.
Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Attempting to overwrite the next waypoint in the FMC with another, I.e. the equivalent “direct to” function in the 787, does not change anything whatsoever after I press ‘EXEC’
This has to be related with the “direct to” bug on the a320n in which it erases the flight plan and leaves the route page with the text “untitled”

Flight plans created on the World Map do not upload correctly in the FMC. They have “holes” in them, missing waypoints (see the picture attached). When the aircraft reaches such a waypoint, it loses navigation completely and instead turns back to the very first waypoint. Even though the flight path is displayed correctly on the ND, the autopilot doesn’t follow it from that point.

It’s also not possible to edit flight plans or fill in the “holes” by adding waypoints. Therefore it’s impossible to navigate the B787-10.

2 Likes

Do you think the new Airac update plays a significant part in the bugs thats surfaced across the default airliners, including this waypoint issue on the 787? I also have experienced what you described above when using the world map to create a flight plan.

I know you’ve mentioned elsewhere that you don’t believe this is a custom liveries issue, particularly in regards to the frozen avionics bugs, but Ive seen a couple comments now that seems to indicate otherwise, especially because one user said that the new 4simmers a320n livery update fixed the issue.

I have yet to test the A320N after the livery update, and I am in the process of testing the 78710 without 4simmer’s 787 liveries.

I could test the same route without custom livery, however I don’t see how it could affect flight plan generation. Liveries are just textures basically. The plane model is the same. The A320neo pack update only added two new liveries, I haven’t read any other change on 4Simmers’ Facebook page. I don’t think the two are related in any way. As for the AIRAC, I’m not an expert on that. What I do know is that every waypoint is present on the World Map, where you can see the waypoints in order at the top of the screen. Everything is fine there. But as you load the flight these “holes” (for lack of a better term) appear.

I had a flight with the 787 this morning from Abu Dhabi to Medina, that was fine. But now this other route doesn’t work. So I guess it’s a case by case basis. I have no idea what causes it, but it makes using the 787 basically a lottery. You have to check all the legs in the FMC to see if it’s even feasible to take off.

Also, we should test the 747 as well, it’s a Boeing too, after all. Unfortunately, I only have limited time to play alpha tester for the sim… For god’s sake I’d just like to fly and enjoy it. :disappointed:

You’re probably right about the liveries. Makes sense, I’m just grasping at any straws I can to fix these issues, in the event they don’t come out with a hotfix soon…

I will still test it regardless just in case lol. Coincidentally, I am currently on a short test flight to Abu Dhabi as well, and I too don’t see any waypoint issues, unlike my longer flight from Amsterdam to Zanzibar earlier…

As for the Airac data theory, its the only thing that makes sense to me because I played the SU9 beta and I had zero issues of this nature whatsover, and the final release build for SU9, version 1.25.70, is the same as the final beta build. The Airac data has to play a role, along with servers.

1 Like

OK, I tested:

  • Default liveries: same result. The same waypoints are missing from the FMC.
  • Boeing 747-8i: same result! The 747 misses the same waypoints.

So now I’m certain the issue must be with the navigation data, somehow a lot of waypoints don’t load into the FMC, even though they are on the world map and in the Nav Log.

1 Like

Ive also found that as soon as the aircraft flies over these missing/invisible waypoints, every single avionics screen freezes just like it does on the A320n….

Here is another example. I tried flying from Taipei to Chengdu, but couldn’t because one single waypoint is missing from the FMC. As you can see on the screenshot and the Navlog, the DODSA waypoint is missing, but it should be there between SAGON and BEMTA. This breaks the flight plan and the autopilot is unable to fly the route.

This is a serious and critical issue that prevents the proper use of airliners, and this issue occurs in all parts of the world. I have met this bug in both Europe and Asia, and it’s a hit or miss whether the planned flight can actually be flown.

1 Like

Another example. VESAN and DIPER are missing.

It would be great if somebody acknowledged this bug because right now airliners are unusable with flights planned on the world map.

ALOLA is missing from the FMC.

Edit: Thank you for renaming the topic. It’s clear that some of the AIRAC waypoints cannot be loaded into the FMC. Unfortunately, I can’t programme the FMC manually (partly because I don’t know how to do it, and partly because it would be a nightmare with a controller), but it would be helpful if someone could try to input these waypoints into a flight plan manually, to see if the waypoints cannot be entered that way either. You can see some examples in the above pictures, as well as the corresponding departure / destination airports.

I tried to manually input a flight plan from simbrief data directly into the FMC at the gate and I just kept getting the same “not in database” error for more than half of the waypoints I was trying to enter…this was already a bit of an issue prior to SU9 but I personally think that using the world map to create a flight plan is the only way to go, with the default airliners on console…

Someone else mentioned in another thread that the frozen avionics fixes itself and unfreezes as soon as you fly over the following waypoint to the one that was missing, e.g. APTUG in your latest example, and that has been the only way for me to workaround this issue on the 787-10.

This still needs to be given high priority for a fix though…

1 Like

I’ve had that issue, quite a number of missing waypoints. Also STARs are sometimes skipping to the direct runway (last waypoint fix). Had to correct with heading mode and then intercept the ILS localiser.

I’ve also noticed that waypoints are taking a lot longer to load in the FMC. Or maybe its just me.

2 Likes

The avionics in the B787-10 aren’t fully frozen in that case, if such a thing is actually possible. The indicator that shows how far the next waypoint is still counts, and it indeed shows the very waypoint that is missing from the flight plan itself. However, the ND shows that the plane is diverting from the flight path (this could be because the flight path doesn’t take the missing waypoint into account). Now I’m really unsure as to what’s really happening. If I have time today, I will sacrifice a few hours for a seemingly “broken” flight, just let the autopilot fly, and see if it actually reaches the non-existent waypoint and continues with the plan. The last time I had this issue it ended up turning back to the very first waypoint, all while the ND still displayed the distance to the missing one. It would be nice if it was just a “cosmetic” bug in the FMC but I’m not sure it is.

1 Like

OK, so I had time and tested it yesterday. Here are my findings, pretty simple to be honest:

  • If you let the autopilot be then it does indeed navigate through the “missing” waypoints. Even though they are not in the FMC and don’t appear in the flight path, these waypoints still appear in the upper right corner of the ND and the autopilot knows where to go. Just do not interfere in any way, however confusing the display may become.

  • While the autopilot flies towards such an “invisible” waypoint, part of the ND freezes. Namely, the flight path. Thankfully, the other displays remain working, so you can keep track of which waypoint you’re flying towards and what the distance is.

  • The ND unfreezes after the plane passes two “legit” waypoints again (so waypoints that appear in the FMC).

So in short, it’s actually possible to complete these journeys. Last night I had a flight that had 3 missing waypoints in the FMC, and there were no problems, apart from the flight path always freezing. Since the approach phase usually contains many legit waypoints, the ND unfreezes towards the end so it’s not hard to navigate and land properly.

I think that in the end this is the very same problem that causes the G1000 screens to freeze. I guess the Garmin systems have the same issue, they simply don’t recognize waypoints and freeze, but recover then the plane passes a “proper” one. G1000 Screens Freeze - Bug Reports / Aircraft & Systems - Microsoft Flight Simulator Forums

I guess this is an AIRAC implementation issue. Hopefully it will be fixed sooner rather than later and we won’t have to wait until SU10. :crossed_fingers:

1 Like

All of Asobo’s airliners are broken. The A320 is having similar issues as well.

I arrived at these same conclusions too.

I’ve been completing flights on the 787 and working around these issues. Typically I’d need to overwrite the next legit waypoint to unfreeze the avionics immediately, but like you said, if you wait till the aircraft passes two of these legit waypoints it’ll sort itself out.

I’d guess that this issue will be sorted when the next AIRAC update comes next month/in WU9 in the upcoming hotfix(?), unless it’s a deeper issue with all the default aircraft.

Just to confirm, the new AIRAC 2205 implementation hasn’t solved the issue. The same waypoints are still missing from the FMC.

Waypoints are going Way making me go to airport but not the rest of the waypoints

Just download the Boeing 787 Heavy Division by KimLada. So much better than the standard MSFS version. Allows you to import flight plans from simbrief making the experience 1000x better!

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Yes. (Clean Install)

Brief description of the issue:

A flight loaded in the FMS with a DEP and ARR airport selected while conducting any type of Direct-To function enroute causes the FMS to draw a course line from the departure airport to the waypoint selected as the Fly-To waypoint. Example, If you are flying an arrival procedure and you choose to fly direct to a waypoint that is farther down the “Legs” list the aircraft will turn but not direct to the waypoint selected. The aircraft will turn to an intercept heading of the course line drawn from your departure airport.

Provide Screenshot(s)/video(s) of the issue encountered:



Detailed steps to reproduce the issue encountered:

Depart KLAS for KLAX ANJLL4 arrival. 10NM prior to HAKMN select SHTNR as the Fly-TO waypoint. FMS draws course line form KLAS not the aircraft present position (PPOS)

PC specs and/or peripheral set up if relevant:

Windows 11 / i7 13700K / RTX 3080 10GB / 32GB 6000Mhz / 4TB NVME M.2

Build Version # when you first started experiencing this issue:

1.29.30.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: