Default Asobo DA40 Flaps Positions

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

2 tags are required: One for platform, and one for aircraft.

Are you using Developer Mode or made changes in it?

NO

Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

YES

Which aircraft are you reporting an issue about? (Please also add the proper tag for it)

DEfault Asobo DA40NGX

Which aircraft version are you experiencing this issue on? (You can find this listed in the Content Manager under the Aircraft Name)

NGX

Brief description of the issue:

Only Flaps fully UP and flaps fully DOWN are available. Moving switch with mouse OR using Logitech SAITEK PRO throttle quadrant switch (using Increase Flaps/Decrease Flapsoptions) makes no difference. No control conflicts found. Flapindicator lights cycle through all three positions: UP, T/O and LDG but never stop at T/O position -confirmedby lights and outside observation.
What is odd, when I make the runway the departure point on loading, the aircraft initially positions to the runway holding point with Flap UP. Wihout input from me, the aircraft then positions onto the runway, and the flaps position to the T/O position. If I then move the flaps away from this position the problem returns and I cannot select the T/O position again.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

1.36.2.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

no

Provide extra information to complete the original description of the issue:

no issue to setup flaps on T/O position through the mouse or joystick
Make sure you test with no addon (even better start in safe mode) and your flaps assignation is correctly setup in controls options

If relevant, provide additional screenshots/video:


Do you have the same issue if you follow the OP’s steps to reproduce it?

No

Provide extra information to complete the original description of the issue:

I’m using a TM HOTAS, but the same settings (Increase/decrease flaps for separate buttons) and can’t duplicate the issue. I can use the mouse scroll function or click/hold to move the flap lever to each level separately also.

If relevant, provide additional screenshots/video:

Moved to User Support Hub Aircraft & Systems since cannot be reproduced at that point.

That’s the same for all, agree that flaps should be on T/O position during the cinematic that starts at the holding point if setup that way when starting on the runway. But this is not the root cause of your issue.

Thanks to all who have helped so far.
Could someone who does NOT have the problem described send me a copy of the FLAPS text as laid out in the <flight_model.cfg> for the DA40? I would like to compare my copy in that file. Hopefully I will find a meaningful difference.

See if this is what you need:
;===================== FLAPS =====================

[FLAPS.0]
type = 1 ; Flap type 0 = None, 1 = trailing edge, 2 = leading edge
system_type = 0 ; Flap system type 0 = electrical, 1 = hydraulic, 2 = pneumatic, 3 = manual, 4 = none
span-outboard = 0.6 ; Outboard span area (added area) (percentage, non dimensional)
extending-time = 3 ; Flap extension time (SECONDS)
damaging-speed = 120 ; Speed above which flap is damaged (Kts)
blowout-speed = 170 ; Speed above which flap is blown out (Kts)
maneuvering_flaps = 0
lift_scalar = 1.3 ; Scalar coefficient to ponderate global flap lift coef (non dimensioned)
drag_scalar = 1.3 ; Scalar coefficient to ponderate global flap drag coef (non dimensioned)
pitch_scalar = 1 ; Scalar coefficient to ponderate global flap pitch coef (non dimensioned)
max_on_ground_position = 2 ; Dynamically set in-tool to last flap-position index by defaut when -1 is found.
flaps-position.0 = 0, -1, 0
flaps-position.1 = 20, -1, 0.25
flaps-position.2 = 42, -1, 1

Despite the values at the end of the FLAPS section,it has sadlymade no difference.

1 Like

Could you try to unbind (apply/save) and bind back (apply/save) the increase/decrease flaps.

Yup, I’ve done that several times.

For information, it does not matter how I assign/use flap selection method (either by mouse click/drag, keyboard key assignment, or throotle quadrant switch), the flaps only move between two positions - 0 degrees and 42 degrees.

There are no known control assignment conflicts.

As an oddity: when I try and use keyboard assignments (eg F6=Decrease flaps, with F7= Increase flaps), or I assign a pair of throttle quadrant switches (eg Joystick Buttons 5 and 6, to respectively decrease or increase flaps), only the first assignment in either pair functions, and then it only works as a ‘toggle’ flap switch. The second assigment in each pair is functionless.

If I use mouse click/drag on-screen, it too only allows two positions of flap.

I am wondering if I should uninstall then do a MSFS2020 re-install. I hesitate bacause that is a lot of work for a small issue.

What you can try is to delete the DA40NG package and download it again:

@ExponentCard287
I use the same bindings than you and it works well.
Only one point to note:
a short press on the button increase/decrease one notch of flaps.
a longer press fully extend/retract flaps.
Is it the same in your case ?

Hi @ExponentCard287
What happens if you temporarily disconnect (i.e. unplug) all your controller devices (such as the Logitech SAITEK PRO throttle quadrant) & change the flap positions just using the mouse to click the flap switch or using the keyboard? If the flaps then operate as expected, it will have al least narrowed the problem down to a problem with one or more of your controller device(s).

I tried deleting and re-installing the DA40NG package - no luck.
I tried unplugging all control devices and using just the mouse to click/drag the panel switch - again no luck.
I tried using the shortest touch - again,no luck.

I am fast runnng out of ideas, here.

In your control settings, are you using the default profils ?, if not, could you try ?

Set all controls to DEFAULT profiles - no luck.

I did try again to restart the flight on the runway. Once again it initially set me up at the runway holding point before moving me onto the runway. The flaps again automatically (no input from me) positioned to the T/O position. This means that somewhere in the software it ‘knows’ there is a T/Off position for the flaps. However, if I then move the flaps using the mouse, I am back to the zero or full flap availability, with no T/Off position.

Have you tried to start the sim in safe mode ?

Do you mean with the computer in safe mode? Or can I start just the sim in safe mode?

Not the computer, the sim. To achieve that: once in the sim, go to task manager and terminate MSFS.exe. Restart the sim and you’ll have the safe mode option.

OK - started in Safe Mode (thanks for that heads-up!).

Sadly the problem is still there. I presume this indicates that the cause is not from any add-ons?.