Different mouse problem than legacy mode. Lagging and skipping in VR only after SU5

In VR only the mouse cursor becomes unusably jerky. I have tried legacy and locked mode. I have changed the mouse sensitivities etc. In 2D it is perfect, in VR it skips and jumps. Go to the menu in VR even, perfect. Go back to the cockpit, back to skipping mouse cursor. It’s almost like it does not like the lower FPS of VR. Ideas? Thanks

Just noticed also that it is fine until I click on fly now, then it immediately goes wacky. I am using default mouse controls. I have tried the stock 172, the DC-6 updated, the cub with skis and the 152. It is doing it in all.

16 Likes

I notices some strange mouse and cockpit button behaviour on the marketplace A32NX version.

I have the same problem….

the same here, my specs:

i9900k, Nvidia 2080 TI, Reverb G2

Same problem as well as many others. No point giving smoother frames if you break stuff that makes the sim useable is it Asobo

I saw the same, but only once. Then it went away. I think this may require a Zendesk.
I like the new cockpit interaction though (when the mouse works).

1 Like

Same probleme here, the mouse turns unusable.

I sent a zendesk ticket, here is hoping it gets resolved. The sim is unusable in VR currently for me.

1 Like

Ok, I removed all my hardware peripherals (CH yoke, quad, and pedals). Mouse works properly! So I added them back one by one. The pedals (inexplicably) are causing a mouse interaction problem of some sort. I added a 2% deadzone and voila, mouse works. I don’t know how or why my pedals were causing a problem but they were. This was on the 208 but I will test the others now…

1 Like

The issue I’m having with the mouse is that when switching views from external back to cockpit and/or when ‘translating’ the cockpit view around in any direction, I get a double visioned mouse pop-up directly in the center of my view, causing cross eyes and headaches. The only way to fix this is to ‘wiggle’ the mouse each time to get it to snap away and resume normal functionality. See below screenshot of the issue.

Well, clearly there was a conflict, because now all is well. But…without question all was well when I unplugged all my hardware, and it was adding the pedals in that made it glitch. So, a USB problem, or a hardware conflict? I don’t know. But now I am dealing with CTDs that I did not have before so off we go…I thought x-plane was tricky, hahaha.

The issue I had with the mouse, is that it jumps whenever I click on anything in the cockpit.
My first test of SU5 was to do one of the Discovery flights in a Cessna with floats.
I landed on the runway having lowered my gear and received a constant audio warning about gear down for runway landing. Orange light on far right of cockpit to silence the warning.
Moved mouse over to click the button and as I click it, the mouse pointer jumps over to the left by 4 inches (in the VR space!) and the warning does not silence. Not sure if it’s related to the OP but it’s strange!

Just wanted to report back on my mouse issue. I found the cause. In my case it was because I had somehow managed to assign left-mouse-click to toggle freelook in the view controls. Once I reset my mouse to the default profile, my issue was resolved.

2 Likes

Well I keep getting the mouse issue. The mouse in the 3D cockpit in VR sometimes doesn’t want to move around anymore. The pointer stays stuck while I move the mouse physically, then suddenly starts moving again. It’s like that usually after a few minutes of flight, and makes adjusting the dials impossible.
If I open the menu, mouse is smooth again. If I close the menus, it’s jerky again, resistant to movement.
If I go to the mouse sensitivity, click reset (which doesn’t change anything), then apply the “changes” the mouse pointer is smooth again… for a few minutes only. Then it starts again.

I have tried a dead zone on my pedals and peripherals to no avail, and don’t have incorrect mouse bindings, so not sure what is happening.

5 Likes

That sounds exactly like what I experienced. After flying more it does still happen for me also. I have noticed sometimes I have to jiggle my pedals and it will make the mouse better for a bit. There does seem to be an input issue. Hopefully fixed this morning with the update!

After the hotfix, it was still doing it. So, just messing around with settings I turned ASW off in OTT and that actually seems to have fixed it. mouse is now perfectly smooth and the sim is much smoother also, other than micro stutter when I turn my head. Anyway, maybe try ASW off?

Hi folks,

after the patch I had still the mouse problems. So I tried and found a solution that works (for me). I have a lot of USB equipment for flightsim ( HOTAS Warthdog, Alpha Flight Yoke, Cougar MFDs, selfmade trimwheel, Netxt Level racing motion platform… and so on). All that equipment is connected at the same USB connector via a powered USB distributor.

My solution:

Unplug device by device and check the mouse…until I had removed my last device (Murphy?) the mouse moves perfectly. So I repluged device by device, and checked the mouse, after I pluged in the last device, the mouse was still ok.

After that I quit the simulator and performed a reboot to check if the solution is persistens. And yes, even after reboot, the VR Mouse works well!

I hope this tipps can help you

Cheers Kotti!

1 Like

And I am back…

I still have intermittent mouse hesitancy, but better than before. I still feel it is there when FPS is degraded, but I am not sure what is going on, I just cannot pin it down. Still much better than it was and at least I can start the DC-6 now. I will keep trying things.

I wonder why peripherals would suddenly be an issue though, “conflicting” with the mouse - before the update we didn’t have this issue, and the issue doesn’t appear in the menus.
I will try your suggestion Kotti though, see if I can get it fixed.

I did create a Zendesk as well, with following steps to reproduce:

  • Launch a flight in VR
  • Fly a normal IFR flight (CDI, NDB setting, etc.)
  • After 5-10 minutes, the mouse pointer starts to be jerky, resists movement, jumps around
  • Open the menu (ESC), see that the mouse pointer now is smooth and normal
  • Close the menu (ESC) to resume the flight, the mouse pointer is back to being jerky
  • Go to mouse settings, reset sensitivity and apply changes
  • Go back to flight, the mouse is smooth again in the cockpit!
  • Wait 5-10 minutes, mouse becomes jerky again. Resetting the sensitivity will again fix the issue for a few minutes before it reoccurs.

I had a similar issue with my mouse pointer yesterday. Freezing, stuttering, lagging, despite the rest of the sim running pretty smoothly. It lasted about 20 minutes but then returned to normal, and hasn’t happened since. Very odd issue.