Different mouse problem than legacy mode. Lagging and skipping in VR only after SU5

I had the same problem with jumpy mouse movement and tried the unplugging peripherals one at a time and checked…and same as japaynnick found it to be in the throttle quadrant. For my Thrustmaster Warthog I would get the jumpy sluggish mouse if I was in the throttle reverser detent. Once the throttle moved off of that detent, voila, it worked just fine.

I usually dont use that detent for flying MSFS but I was trying to get the Aerosoft CRJ7 to reverse and was playing with that…then this mouse thing happened. So thanks guys for posting!

2 Likes

And just to add - I had a theory about the throttle quadrant having a fundamentally bad design and being dependent on the voltage from the USB being stable. It seems I was right. I bought a cheap powered USB 2.0 hub. The jitter on the quadrant is almost completely gone (when the hub is powered, otherwise jittering as usual), and the mouse issues are completely gone.

2 Likes

And to add again, I created an issue for that: https://forums.flightsimulator.com/t/poor-management-of-interrupts-in-su5-causes-laggy-mouse/

I had this jerky mouse issue for a few weeks until today. At first the jerkiness was sporadic. Then it got constant but when it went constant an axis on my throttle also started not working. Today I took the throttle apart, found a loose wire and fixed it. Now both the throttle and mouse are working perfectly.

So it seems a poor connection in my throttle affected my mouse. I think @japayannick is correct regarding the poor management of interrupts. Bottom line is another USB device affected my usb mouse. Funny that the mouse was only affected while flying though.

I have been having this exact same issue but I’m sure I did not have this before the update. I use a Reverb G2, i7-10700k, RTX 3070 with 32gb ram. Only after I click the fly button does the mouse get so herky jerky that it is impossible to use the mouse pointer to adjust fine settings on GPS and other items necessary for navigating. I can barely even click on the maps and move things it just locks up. I sure hope there is a FIX for this ASAP!!!

I was wondering about this as well, thank you for your astute research!

Have you tried plugging the quadrant in its own USB on the computer and the other peripherals on the USB hub without external power, or will it change nothing at all in the end?

Yes this is a very silly and very very frustrating bug that needs to be fixed hopefully in this next update. Makes you want to slam your head into a wall trying to get everything setup for take off and landing in a airliner

Same problem here. Get sometimes unusable in VR (laggy), but sometimes it works normal. Introduced with SU5.

+1 here. I really hope the today’s update will address this issue :slight_smile:

For me it has not been addressed and it’s still there. Like dragging a mouse through the mud.

Hello to all the members of the group. Since update 5 the mouse stopped moving fluidly inside the cockpit of my aircraft when I use the VR. I have Oculus RIFT, I have tested the simulator with no type of Addon installed and the problem persists. Wait for update 6, if it was solved, but I still have the same problem. Has anyone had the same problem? They would be so kind to help me figure this out. I already appreciate the help.

I confirm that the issues is still in WU6, unbelievable :frowning_face:
In 2021 a software is unable to handle a mouse move…

My jerky mouse mouse and hard to get the right depth to click on buttons in the cockpit make me want to throw MSFS 2020 in the trash can.

Lol the more common term is " We can put a man on the moon but we cannot…"

Problem still exists after WU6 (Reverb G2)

1 Like

I am still suffering from this problem today. I get the feeling it may well be an issue with my setup and not FS2020 itself. Any one ever get to the bottom of what was causing it?

Same issue as OP. Sometimes if I push down on the rudder pedal just a bit, the issue subsides, but not always. As others, this wasn’t a problem prior to SU5.
Zendesk submitted months ago. No reply, other than the generic response.

HI
I have a problem in VR mod

I lose the mouse click in VR mode, I can move the mouse but cannot enter the cockpit interaction or move the window (ATC, NavLog, …)

It’s intermittent.
are you having this type of problem.

Thanks for your help.
PapaPilote

I figured out my issue - I have a Honeycomb Throttle and an unknown mapping was conflicting with the mouse in VR. I reset the Throttle to default bindings and the mouse works “normally.” I do not know the specific binding that caused the issue; strange this only happened when I joined the SU10 Beta!