Mouse lags in VR

This issue is still out there and not fixed in SU9.

problem still alive

Hello friends,

Been chasing the very same bug for a few hours, intermittently.
And I fixed - for me.


My Config

I’m using the TCA (Airbus version) but to fly GA Aviation aricraft. And I have bound the spoiler axis to the propeller. BUT ! I did not bound the axis. I’ve bound the “virtual buttons”, which are JOYSTICK BUTTON 27, 28, 29, 30 and 31, to Propeller Pitch LO / HI. It’s read like this (BTN 28/29 not assigned)

PROPELLER PITCH LO | BUTTON 31 | BUTTON 27
PROPELLER PITCH HI | BUTTON 30 | N/A
PROPELLER PITCH REV | BUTTON 31 | N/A

Note that 31 give “PROP LO” + “PROP REV”, because I need to get my prop in reverse when the axis is full down.
I did not bind anything else on the course of the axis : full down, one up, full front.


My bugfix

I have discovered that, for me, the mouse bug is when I’m full forward with my TCA Spoiler Axis; which, so, push and stay pushed on JOY BUTTON 27. The moment I do this, my mouse starts lagging. Whatever I’m doing (parked, in flight), it lags; if I release the lever (one position down), then the mouse’s doing okay.

I doesn’t have to be the BUTTON 27.
I’ve rebinded to BUTTON 28 (“not full forward, one click in the middle”) and it goes the very same way.
It’s like “Press-maintain the PROP LO button” is the issue there.


What about you ?

Problem is : this was MY issue.

It may not be yours.
I’ve seen people talking about A32nx in the thread.
TCA has no binding by default for the PROP LO.
Maybe the issue doesn’t only exists with PROP LO, but also with something else.

I’m missing time for more research, espcially to try to recreate the issue somewhere else.
Maybe we could all try to find which button and/or functionality causes that on our sims ?
What are the buttons that are engaged when you encounter the bug ?

Cheers,
K.

Interesting. That would definitely help explain why it seems to be an intermittent problem.

1 Like

Ok, just passed 30 minutes trying to figure and…
mine is doing it because of any perifericals that has a little bit of shaking so when i took off the usb the bug stopped!

1 Like

SOLUTION:
instaled a HUB, so when i need to use mouse i turn off the joystick and then when i need to pilot i turn on ! hope to help u guys also

1 Like

Still there for me using a Warthog and Logitech G Saitek Pro Flight Rudder Pedals. Just tried to see if any button or axis caused the issue and nope. Just happens randomly.

Did you confirm that all the warthog throttle’s switches are in the position and whether that makes any difference?

image

Yeah looks totally normal there and no movement of the axis happen without me moving them.

This mouse lagging issue in VR has to be the just infuriating bug ever, I can only think it’s hard to fix as it’s been so long since first reported. I can’t reproduce it at all, it just happens, and his on two completely different PCs.

I had the same problem for ages. However, I’ve found a fix today (at least for me!). I was trying a performance improvement trick from another thread which somehow fixed the mouse issue as well!

Basically, what I did was reinstalling Nvidia drivers with NVCleanstall utility and setting MSI interrupt priority to high on advance settings. This improved my FPS, removed shutters (!!!) and fixed the mouse. Now feels smooth as in 2D. I don’t know how but worked for me! Would be great if someone tried to replicate.

This happened to me today with FBW. Realised that is due to my throttle not being exactly in the range for the CLB detent.

Went into throttle calibration and could see it was sitting slightly on the border of the CLB detection range. Moved my throttle level slightly up and into centre of the 2 green lines and viola - mouse lag went away.

I have the mouse lag almost every time I use VR. Apparently this bug was reported 1 year ago and still hasnt been fixed…

1 Like

Same here. The mouse seems to be sticky under VR most of the time. In any case, it’s not moving fluently as it does under 2D.

Did you see inprovment in SU10 ?
I made one flight and no problem but it is not enough testing

Had this issue throughout SU10 and sadly, even still in SU11 Beta so far…
Noticed that this gets better in certain positions of the throttle lever of my Saitek Pro Flight Quadrants.

1 Like

Would you mind looking if the buttons / axis associated to your flaps/spoiles on Saitek are a possible cause ?

I found a solution for my own setup but never had feedback about others’ :wink:

1 Like

Thanks for the hint! I checked that right away and even if I don’t have flaps/spoilers bound to an axis on the throttle quadrants, your post got me in the right way - at least I can reproduce it pretty precise now.
So here’s the deal:

  • The issue (at least for me) is mostly noticeable in zoomed mode (when you right click somewhere in the cockpit).

  • I’ve had the lags when I moved the throttle axis to idle (below that triggers a joystick button for reverse thrust). So I removed that binding and got rid of the issue in this specific scenario.

  • However, the mouse lags are happening also when I move my joystick (which is a Virpil VPC Constellation Alpha) across the center point of the Y axis. There’s nothing bound to that except the normal elevator movement axis (so it’s just a native axis, no axis to button whatsoever) but if I move it up and down, the mouse lags for a brief moment almost exactly when it crosses the center point - which is kinda funny because while I’m zoomed, those inputs are not recognized by MSFS (I think that’s a known issue, at least I was having that like forever and got used to that).

1 Like

Are there any new ideas about this problem, its still pretty bad for me and has been for ages now. I cant believe its something they can’t fix, it has never happened in any of the hundreds of games I’ve bought over the years so don’t see why it should be happening on this game at all. Its just as if the mouse is faulty or you are trying to move it without a mouse pad.

I know all games have their faults but with this I get so frustrated I have to keep myself from throwing the mouse at the wall from time to time.

7 Likes

Sadly, I think this is not on their radar to fix, because not enough people are filing Zendesk tickets for it. (Yes, I have)

1 Like