Mouse lags in VR

So this happened when flying in VR now. The (onscreen) mouse works fine, but the VR mouse gets stuck and lags behind. It is really frustrating to try to interact with the cockpit now. Why did you “fix” something that didn’t need fixing?

And why did you redo the interaction? Middle mouse button is for scrolling, not to select a specific action (Push or pull a knob), The new VR interaction with mouse is really horrible and has made the sim worse! First i got to hold down the right button (set by me as Zoom), then left button to select it, then press the middle mouse button to go from managed heading to a set heading.

And why - oh why - did you add that blue arrow that pops up? How do i remove it? It is extremely annoying. I KNOW where the mouse button is, it’s just stuck and doesn’t move like it used to before the latest patch(es).

Are you in legacy mode in the settings ?

Yes, my mouse gets laggy in VR too. It makes using it painful. It does usually go away after a while but it happens often to me. Agreed with @Pilotpete123. Going back to legacy mode is best for PC users.

1 Like

If you have a Logitech Throttle quadrant, be aware that its jitters combined with poor management of interrupts in SU5 seems to be the root cause.

I have a logitech T16000m/TWCS HOTAS and the z-rotation axis of the stick has jitters. I don’t assign that axis to anything though. Are you saying that this could be the cause? Where did you get this information?

I guess a simple test could be to just rotate that axis to its full extent to stop the jitters and see if it helps. I’ll try it next time I’m in the sim.

Probably not caused by z axis jitters, as it’s not linked to a detente action. But worth trying out!

I am the source of the information, after testing multiple potential causes for the mouse lag.
I noticed that:

  • mouse lag occurred suddenly, and was a problem in game only (pressing esc to bring up the menu overlay caused the mouse to be smooth again, until resuming the game)
  • mouse lag will be temporarily fixed in game as well by resetting the sensitivity of the mouse in the menus (resetting really doesn’t change anything in terms of values, but it does fix the lag for a few minutes)
  • after the mouse lag starts happening, unless I take action as above, it doesn’t get better on its own
  • disconnecting my peripherals selectively while the mouse lag was happening showed that disconnecting the Logitech Quadrant made the mouse work again, isolating the issue to my quadrant
  • as I was already aware of jitter issues with the quadrant and how it could trigger the detente action multiple times per second when one lever is on idle (due to poor USB voltage control by the motherboard with increased jitter the more the MB pulls power from the PSU - this was another long investigation I will not detail here), I tried reconnecting the quadrant, keep one lever on idle, and waited for mouse lag to start. Once it started, I raised the idle lever to above idle. Mouse became smooth immediately. Suspicion confirmed.
  • as plugging the quadrant into a regulated powered USB hub (mostly) fixes the jitter issue, this is what I’ve been using. No mouse lag since.

Nice troubleshooting skills and thanks for the details. I assumed it was a SU5 programming thing since it started with that update and didn’t take further action. However it makes sense that it could be a combination of the update plus a hardware issue. I’ll try to troubleshoot on my end as well and hopefully find something.

Sorry…kann zu schlecht Englisch um mein Problem hier zu Erklären.

Ich hoffe mir kann jemand helfen. Seit dem letzten Update bekomme ich es in VR nicht mehr hin die Bedienelemente im Cockpit mit der Maus zu bedienen. Die Maus springt nicht mehr auf das Cockpit. Bei Fenstern klappt das Springen noch aber leider nur dort. Ich muss immer mit dem linken Auge anvisieren dann findet man den Schalter schon. Das kann es aber nicht sein.

Hoffe das es sich um eine Einstellungssache handelt. Habe die Steuerung bereits resettet aber das hat nichts geholfen.

I have observed a similar issue. I am using an Honeycomb Bravo quadrant. Disconnecting it resolves the mouse lag issue. After reconnecting it I observe that the lag is gone. I will let it sit for longer and see if the issue returns.

EDIT: Still smooth after 20minutes. Was testing it on the CRJ. Will try the same thing the JustFlight Warrior which was exhibiting the same issues earlier.

1 Like

Same issue with Logitech rudder pedals, when they are not perfectly centered mouse lags horribly in VR.

i had the same issue, mouse lagging in VR but not anywhere else. i’ve got a button to activate / desactivate my warthog throttle on my USB switch. i’ve tried to disconnect and reconnect… as suggested.
and it worked !
my mouse was smoth back to normal in VR after that…
never had this issue before those SU5 nightmare !

thanks for the trick !

I was gonna post about this too as I am experiencing mouse lagging in VR after SU5. I have a HC Bravo and will disconnect and reconnect it to see if that fixes the problem as an interim solution. Got my vote on this hope it gets fixed in the next WU…

Thx for the tips in the thread! Resetting my usb throttlequadrant fixed it for me. Still had other issues in VR as well. Especially with the menu’s like ATC, Fuel, etc. They would not show at all, leave out the interaction buttons (this happened with ATC making it useless) or the especially anoying and somewhat painfull one where the windows act like they are sticked to your eyes/headset. Full in your face and move with you no matter where you look.

Performance seems good but with so many issues its back to the monitors for now i guess…

Same problem with the sticking, pausing mouse in VR. Tried unplugging my Quads, but still the same. Will try the pedals and HC Alpha next.

Hopefully MS/Asobo will address this issue soon. DC’ing and RC’ing controls causes other issues.

One thing that I did notice in my case is that this issue only occurs when Motion Reprojection is enabled in OpenXR Dev tools. I have disabled Motion Reprojection and have not had this mouse lag issue ever since. Re-enabling Motion Reprojection brings back the lag and the only way to fix it is to disconnect the Throttle Quadrant and reconnect.

As per the title, have any of you noticed since world update 6, the mouse cursor seems to moving at like 10fps?

I’m getting seriously good performance at ultra settings bar this odd bug with my mouse cursor. It never used to be like this for me until wu6.

I completely reinstalled the sim today and was hoping it would sort it. But nope still there??

I got the same problem.

With that, i got blurry thextures when the plane is moving. Its like seeing the plane 3 times, kinda a ghost of the plane doing the same movements. I even have floating lights at night. That game is buggy as hell chileeee

I get the wierd graphical cockpit glitches too, like the gpu frame sync is out of whack. It doesn’t last long and sorts itself out, however the mouse fps issue is seriously annoying me

As per with an update, let’s fix a few things, and brick a few other functions. Like seriously I’m kinda done with these updates bricking the sim

That is one of the bugs i got since the update.

Did disconnecting your Bravo solve your issue?