HOTAS Controls stop responding every 2 mins

Presumably your VR kit uses USB to track position and possibly also deliver USB audio?

FS2020 adds to that by being DMI heavy in its own way. Network streamed visuals, constant read/writes to storage if you are using rolling cache etc.

Being able to saturate the DMI sounds pretty absurd when you say it out loud, but depending on your system your DMI may only be x4 lanes of PCIe 3.0.
Saturating a USB Host controller on the other hand might not be so hard.
Combine the two and…

Could it still be Asobo’s code? Yes. Absolutely. But don’t overlook Hardware also, because there isn’t another game I can think of that essentially streams the entire experience.

1 Like

i would agree with you if it werent for the 3 following things.

  1. I play Elite and Star citizen one i run in VR and it forces the same load during planetary flying and i have no such issue.
  2. Its on an external hub on a different controller, meaning bandwith isnt the issue
  3. I also tried lugging it into the PC Directly also on a seperate controller dedicated to a single USB 3.0 gen 2.1 port and nothing changed.

Also IIRC, the Index does audio Via the HDMI from the GPU, the USB port is for the dedicated tracking and bluetooth controller.

Elite Dangerous does the same thing via the OpenXR framework too, if anything it does it worse.

A powered USB hub will not fix issue if they occur at the SOC.
Good luck sorting it though.

CPU has 16 PCIE lanes, dont think its saturated.

sofar it seems only yu has the issues, altho still recent post.
if its the game , many others would have the same issue.

The CPU to GPU interface is 16 lanes.
The rest isn’t on that path.

On Ryzen there are x4 PCIe for the chipset and x4 PCIe for USB/M.2/Sata (these are in addition to the x16 GPU lanes)

Yes. It can always be the FS2020 software, but a good, easy test of the hardware would be to turn off the rolling cache, turn off all online functionality (bing maps, photogrammetry, Azure ATC etc and test in VR, this will reduce network and storage I/O load)

ill give that a go…

I have a similar issue and wrote up this post:

Like the OP mentioned, this ONLY happens in VR. I’ve tried different ports, bought a powered USB hub. My issue happens whenever I start a flight, it drops most, but not all USB hardware. It’s almost like it’s loading a different peripheral config up until I manually go into the controls dialog. I have also seen it, once, where I went into the controls dialog and it showed the button mappings for one of my controllers, but no items listed in the controller slider at the top… not even the mouse and keyboard, even though those were working (or I wouldn’t have been able to get to the controls screen).

I’m also on a Ryzen and using a Quest 2. Can you explain where/how to turn off the rolling cache and what that does?

2 Likes

I found the rolling cache options. Tried playing with it turned off as well as upped to 50GB. neither effected the controls dropping out.

One other thing I noticed… I have Active Pause and normal Pause mapped to two buttons on my yoke. When MSFS drops my hardware, the yoke remains active but the Active Pause button doesn’t work. The normal Pause one does. When I go into control options and back out of it they both work again. This is making me think harder that some other hardware profile is being loaded or overwriting my profiles. Is it possible that MSFS is loading up some VR controllers or something that it isn’t telling me?

For those following this and if this is helpful… my current procedure when flying in VR is:

  1. Go into VR
  2. Start a flight
  3. Pause the game
  4. Go into control options (no need to change anything, just let it load and display everything)
  5. Back out of options back to the flight
  6. Hit Active Pause
  7. Hit CTRL-1 to show the dashboard view so I can move Nav Log and any other panels I have open
  8. Hit CTRL-0 to go back into the main view
  9. Toggle Active Pause off
  10. Fly away!

I do this for every flight. It’s not horrible once you get used to it since I’ve mapped buttons to most steps, but sure would love it to be smoother.

i tried everything you suggested and no luck.

ok, sweet thanks for this, ill give it a go, MSFS just seems to be a pain in the ■■■ to get working for VR for me so if i only have to do something once per flight then its fine

unfortunately it didnt stay, i still had to press CTRL+0 a lot. idk why. :sleepy:

The two of us can’t be the only ones with this issue. Mine is almost identical to yours. Only happens in VR. No change to hardware configuration, usb ports/hubs, etc. from SU6 to SU7. Every controller except my pitch/roll (TM TCA Airbus) stops working. It seems to coincide with the mouse almost ‘losing focus’ on the app. Most times, a middle click of the mouse enables the mouse cursor again and snaps all the other controls back to normal operation, but other times, i have to keep moving the mouse cursor (to prevent it from timing out and going invisible) in order to make throttle adjustments, etc. I have tried everything i could think of to fix this, including usb power management settings, tweaking which USB ports I’m using, setting my mouse/controller settings to default and I’m at a loss. Rolling cache is disabled. Again, only happens in MSFS. X-Plane, DCS in VR are working without any issues. I’m not sure if it is linked to any of the following other various issues we’re having, but it seems to me that there are a number of underlying issues with controls in general that are plaguing SU7:

https://forums.flightsimulator.com/t/controller-input-stops-when-changing-to-vr/473433/2
https://forums.flightsimulator.com/t/vr-controllers-disappear-and-have-to-be-woken-up-by-pressing-grab-button-very-often/472674/2

1 Like

It’s not just the two of you. I’m having severe issues with HOTAS controls in VR, and it’s completely ruined the game for me. It started with game of the year edition.

For VR I’m using an Oculus Rift CV1 with Oculus Touch controllers. Controller is Thrustmaster TCA Airbust joystick & throttle quadrant. Here’s what I’m seeing:

  1. If VR touch controls are enabled, my HOTAS does not work. At all. Since I don’t see any way to disable these in game, I have to pull the batteries out of the Oculus Touch controllers.
  2. Once I’m flying in cockpit mode, buttons on my HOTAS randomly stop functioning. Some axes will also randomly stop functioning. Most frequently it’s the rudder, but sometimes it’s one or both throttles, and once or twice the elevators and ailerons have stopped. Going into the control settings and backing out restores operation… for a minute or two.
  3. Here’s the crazy part: If I go to external camera - the controls work perfectly fine. If I return to internal camera, they’re still busted.

None of this ever happens if I’m not in VR. In VR, it’s constant.

My hunch is the VR controller support they added recently screwed things up. But I can’t play the game until this gets fixed. Frustrating.

2 Likes

I’m having the same issue. Using the t.16000 FCS and it keeps losing my throttle controller in VR. No issue in 2d. Going into and out of control options fixes it, for a bit…

1 Like

It seems to be fixed now. I set msfs to run windowed with a lower resolution. I also updated to the newest Nvidia driver, 497.29.

Run the menus in 2d mode using oculus link and then after clicking fly now, switch into vr. Still need to use tab to bring up menu bar and ctrl+0 to get the mouse to interact with the windows.

1 Like

This appears to be the bug, here, if anyone following this thread hasn’t seen it:

Be careful not to drag your mouse over any overlay windows as a temporary work around.

Hurrah (sort of) this isn’t just me! Joystick never drops out. Throttle and rudder do. A quick wiggle of the mouse and as you say, everything comes to life again. I’ve only tried this in VR as quite frankly if I have to run MSFS in pancake I’ll be flying any other sim in VR first. :grin:

2 Likes

One thing I think might have helped me that I changed recently is to set the Assistance → User Experience → AI Piloting in Cursor Mode to OFF. My controls don’t seem to be dropping out as much or at least they seem to be coming back. Worth a shot for anyone having these issues.

Besides not hovering your mouse over a window has anyone found a solid solution for this? I posted to the MSFS zendesk and am awaiting a response. I have the exact same issue you guys are dealing with.