Mouse lags in VR

I was actually disconnecting my Alpha (easier access to cable) and that did solve the mouse lag issue but lately it hasn’t been as bad. Maybe WU6 helped fix the problem.

I’ve also been having this issue intermittently since SU5, and finally traced it to one my rudder pedal toe brake axes jumping around. Just pressing and releasing the toe brakes fixes it for a while. Didn’t happen before SU5, so that update is a factor as well.

I noticed this was better in su6 but i got it back bad in su7. I also have the logitech (Saitek) yoke with the quadrant. I’ll try to disconnect it.

Asobo please give the mouse interrupt priority to controllers!


I get the same problem with the mouse lag, in the cockpit view it lags when trying to press switches and turn knobs, unplayable like this in VR, I will try to disconnect the USB

Yes same problem back again after SU7. I had this issue in an earlier SU but switching usb2 to usb3 solved it. Now neither solve this issue in VR and SU7. It makes it unusable.

Mouse lag and erratic moves are still there in VR, in (Open Beta)

Yep having this issue and have tried both a wireless and wired mouse and it only happens in VR. Between this and the VR menu issue things are not looking good for VR in MSFS 2020 at the moment which is shame :frowning:

Try using crtl 0 not num pad 0,it worked for me but you may have to do it again in flight

Same issue with mouse lag. not always but often. Only in VR, since SU6 or SU7, i don’t remember.

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?
Microsoft Store Version

Are you using Developer Mode or made changes in it?
No DEV mode
Brief description of the issue:
The mouse become extremely laggy while i’m on the ground and only in VR mode. It seems like an FPS loss and the mouse cursor starts to lag. Once in flying this problem, sometimes, disappears and reappears. I tried to read other posts about mouse but it seems that no one has this particular problem.

PC specs and/or peripheral set up of relevant:
I7 11700K 32 Gb ram 3080 Ti

I found that this problem occours only when i’ve my feet on the rudder pedals (saitek). It seems that they have come conflict with the mouse.
I’ll try another USB port.

1 Like

I had this happen to me tonight, the mouse was incredibly laggy. I’ve had it happen on the rare occasion in VR before but tonight it was constant and made the flight tricky (and using Toolbars all but impossible).
I too have Saitek (Pro) Rudder Pedals but my feet were not on them, I’ll keep an eye on this though in case there is a conflict somewhere.

I saw that sometimes i’ve to put my feet on the pedals, sometimes i’ve to remove them in order to make the mouse works… Incredible :smiley:

1 Like

Constant laggy mouse in VR tonight. I’ve only ever had this bug once before a few months ago but is every flight now with this beta.

I’m also experiencing this, it comes and goes and only seems to be a problem on the ground.

I’ve tried rebinding my rudder axis to rudder left as saw this mentioned but doesn’t make any difference.

Is there another workaround or fix for this issue?

Just for info on this I found the culprit for my laggy mouse issue. It was related to the Thrustmaster TCA Airbus throttle. The engine start selector switch if set to “IGN/START” the mouse lags. When switched to “NORM MODE” the lagging stops. Can anyone else confirm this?

@SpiffyFoil56429 this may explain why it only appears to be a problem on the ground for you if you have the Airbus Throttle Quadrant?

Yes I do have the airbus quadrant, I’ll check this on my next flight and report back. Thanks

1 Like

Okay so can confirm the lagging occurs when using the engine knob on the airbus quadrant.

I’m still having an issue where the mouse isn’t letting me click in some areas of the cockpit in VR. It wasn’t happening prior to the beta.

Thanks for confirming.

Will be interesting to know if everyone experiencing this lagging mouse curser all have the Airbus quadrant or if it has something to do with certain USB devices.

I’ve not noticed any issue clicking on certain spots in the cockpit in VR but will check again.

I noticed I had a different problem in VR: my Logitech throttle quadrant with pedals freeze when the mouse is over their controls sometimes. It is pretty annoying, especially when landing… Has anyone had this issue?