Discussion + Poll: World Update VI (1.19.8.0)

1 Like

Ok yes, your right, its finally started for me NZ, as you say above. Restart Xbox app, then click get updates and it found it. Thank you, it was driving me insane.

still unable to get the update microsoft cocked up again

I assume the xbox app can be removed since it has nothing to do with a PC after the update is complete

Missing here in France…

Try logging out and back in to the xbox app

that looks bad

1 Like

How do you get to Marketplace when its checks for updates and sends you to the Store; and nothing there, no way to get to marketplace or content manager!!

1 Like

Go to marketplace, then look for WU6 in the “FREE” category. 5GB download

Still a lot of CTD’s. After the update I had 1 CTD in world map and 1 CTD in first flight…. My oh my… so bad! Rebooting and trying for number 3…

I’m in from of the alpha fase. Never ever had single CTD until update 5…. Fix this ■■■■! Stop adding more stuff and fix what you to need to fix or give us back the update 4! Unbelievable….

Hi
Someone know why this happens? When i run the FS2020 it return “There is a update available, enter at Microsoft Store to update before …”, but i enter at my Microsoft Store, and at MSF2020 has only a button “Play”, and if a clcick at, i return again to the same advice, and not update.

1 Like

Same here, i thought maybe it took it’s time to make the update available say per 1900 hrs, but apparently, it does not want to budge… I tried logging out, and back in, tried rebooting… nothing just yet.

i guess we need to wait for a push to update or something.

Woof ~ Woof & Salute

Steiny

1 Like

When will there be a statement from Microsoft??

1 Like

i’m stuck at this, please help me

This is an issue they know about.
image

Their suggested steps:

  1. Go to the Microsoft Store and search for the ‘Xbox’ App.

  2. Download the ‘Xbox’ App and click ‘Launch’.

  3. Once the Xbox App is running, go back to the Microsoft Store to ‘Downloads and Updates’ and click ‘Get Updates’

  4. The MSFS update should start to download.

5 Likes

Same.
Looks like it updated partly - Now it is gone from Store update list.

you are the best, it works !!!

2 Likes

Yep, it works!!

Thanks a lot!!!

1 Like

Well timed solution. Thanks for outstanding support.

Doesn’t work at all for me