Discussion + Poll: World Update VI (1.19.8.0)

Padelborn download is 17.17 Gigs for a final install size of 3.81Gigs?

Is it just me?

1 Like

having the exact same problem anyone know how to stop the sim updating - I was happy with the previous versions I could at least play - im about to load up fsx and stick fs2020 in the bin - the xbox update killed the game for me :frowning:

Same, also Trondheim and Cologne.

1 Like

Lets remember all these issues when voting at this topic

I downloaded the update, the world update and the various updates in about 20 minutes with 0 issues. I haven’t flown yet, but I logged into my JF Warrior with no issues either, Great update!

1 Like

No, just PC

Wow! What an amazing update! Great job Microsoft and Asobo!

2 Likes

Thanks.
This is crazy.

When it all works, it’s really magical…

Yeah, this sucks, but you can always load sky vector and figure out how to get to the next airport using VFR.

i can fly without any issue on series x…

su5 all over again! Tried to start msfs, “mandatory update, go to the store.” Go to store no update,! Went through the zendesk checklist, the same issue, finally found that I apparently needed to download and install the “X-Box App” then in the store run the update apps. Did that, start MSFS, update now there, but I have the PREMIUM edition and the download is for the standard version. SU5 did this too! and I ended up having to reinstall the entire sim again! Hopefully, the toddlers’ programming have at least fixed that.
Standard update finished, now downloading 5 GB to get the sim updated completely, I hope. No idea why we need to continually update every previous WU!!! If they were that buggy, they should have never been released.

After sorting mods by SU05 for about 60 hours, I’m overjoyed that WU06 also doesn’t like at least one of my 1000+ extensions. Look at the start screen for the next 50 hours. :joy: :rofl:

Installing the Xbox app from the store triggered the update for me

Had this too. Just delete it and install the version from Aerosoft forum/shop. It is free.

1 Like

It’s very strange. Are you using live traffic, time and weather? Starting on a gate or runway can I ask please?

Not sure which reviews you are reading. On the Microsoft store this program has 2 stars out of five.

Update seems OK so far.no ctd yet. I am disappointed that the cache option to stop pop in is not in the VR settings… They should add this quick.

1 Like

Yes it is shameful. I would come back in 1 year … and again, I doubt … Go to GTA … it will calm me down.

I am having the same issue. :frowning:

Post Update: As a couple of people have mentioned, I got the download to work by using the xbox app.

I thought I had the Xbox app on my computer from another download or update but if I did, it is was not there now. I didn’t give it much thought because I don’t have an Xbox and my flight sim is from the Microsoft store and is running on my PC. I guess I don’t understand the relationship with the Xbox app and running Flight Sim on the PC.

Anyway, after trying many things to get the update to show up in the store for me, I downloaded the Xbox App, and started Flight Simulator from the icon in the Xbox App. The startup was the same as before, that is, it told me there was an update, and after pressing OK, Flight Sim crashed to desktop and opened up Microsoft Store. This time after selecting “getupdates” the new update was available.
Everything worked fine from there.
I don’t know if starting Flight Sim from within the Xbox App was the trick to get it going or just the fact the Xbox App was now installed on the PC.
As I said, I don’t know what the relationship is between the Xbox App and the program if you don’t use an Xbox.
Hope this helps others who may be having the same issue.