Download stuck on Decompressing

With the new update of I have had nothing but problems with trying to download the update. My sim was working perfectly fine, and the update could download everything perfectly fine as well, however once the update got to “Decompressing fs-base-0.1.64.fspatch.002” it became completely stuck!

  • I first tried to exit out of the sim, reload the game and try again - No Luck!! (I have tried this at least a dozen times)

  • I then uninstalled and reinstalled the game - It downloads about 30 GB’s and then again becomes stuck (I’ve tried this about 6 times)

  • I’ve tried every option that the support page offers. I’ve called tech support twice and they were no help.

  • And finally I reset my ENTIRE PC, and still the download becomes stuck on Decompressing fs base.

If anyone has any advice for me it would be so greatly appreciated!

Hi @v22ospreyman,
I have moved your topic into Bugs & Issues > Performance, Graphics & CTD as this area is also for downloading & installation issues.

Generally, you do not need to do this as it will not fix the decompressing issue.

The “decompressing” error you should report to zendesk. I agree there is a problem with this. If you have WinRAR or 7-Zip, you can manually extract the files.

See this post:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.