Downloaded update from MS store, opened the game, started update, game crashed, and now it says it's impossible to open the game

Hi everybody,

Happy to announce that my MSFS is now repaired and updated :smiley:.

Here is a summary of my problem, the actions taken and the solution finally found.

During WU7 Australia Update, Installation Manager suddenly crashed to desktop. And then I was’nt able to launch the game : I got a popup saying “can’t load this application, see MS STORE” :frowning: I had never got any problem while updating and very few CTD while playing so far.

I quickly found that repairing MSFS (settings / apps / apps and features / etc.) allowed me to launch again the simulator but that never changed anything.

After that I tried different things :

  • delete my community directory (never did it before), with non MS addons.
  • uninstall all my companion software (navigraph, fs2crew)
  • uninstall MSFS
  • clean my PC (disk, registry)
  • repair STORE and XBOX, wsreset
  • logout / login
  • reboot
  • search a solution : google, youtube, forums
  • etc.

MeanWhile I tried twice a full reinstall and was still blocked. But I noticed that the installation manager was able to restart fromt the point it crashed (that’s a good thing !). Unfortunately with the same result. So I tried to better indentify this point and found that it was always after downloading “fs-base-0.1.215.fspatch” that it erased all the files after “fs-base-0.1.206.fspatch.001” and then crashed.

That was important because I read in this forum that other people had similar difficulties. It was a serious indication that it was not a hardware problem or even a driver problem (my PC is WIN11, fully updated).

Then I tried to stop my antivirus Avast and Windows Defender, with no other result that changing the successive CTD into an endless loop restarting download at “fs-base-0.1.206.fspatch.001”.

Finaly as I explained in my answer @HaanShangaan, I saw the post of @FourCross2 (thank tou for that !) and uninstalled and reinstalled gaming services via PowerShell.

What I learned :

  • I should have taken more time before unstalling all my software.
  • The correct solution was in the ZenDesk Checklist. I guess I should have applied it right away…

My conclusion is that something went wrong between Installation Manager and Gaming Services. I don’t know what. But since this is all MICROSOFT software, it would be nice to have accurate error reports!
. Neither MSFS and especially Gaming Services gave any warning that something was wrong. And this caused a great lost of time.

I hope everyone will be able to fly again soon.

1 Like

Oops I forgot to emptied it. What should I do?

You can issue a new file into which you will transfer all the containt of your current community file located into your msfs. Then get it back into the new community which will be included empty into your new sim installation.
Even easier you just change the name of your current community file into your MSFS and spare it somewhere on your desktop or any other place outside the sim. Once the sim will be reinstalled you’ll just have to send back your spared file into the sim and replace the new empty one. Once done don’t forget to rename it properly.

There is no community file because I deleted MSFS.
That is all I could find

Yes I completly uninstalled the game. On MS store, you go top right where your account picture is,you click on it, there’s a little menu and you’ll find the “log out” option.

If you removed all files from the game correctly, the community folder has been already deleted.

Thank’s Fourcross2, I will do like you! I wanted to find a solution without uninstalling MSFS but I’ll go through it anyway!
Another question: would you be French? THANK YOU !!!

Hi I really think that a fresh reinstallation is the solution even if a bit boring. That’s how I managed this time as well as in the past when I was facing such a problem of update.
I think that all this is always coming from the Microsoft update system which is not good and mess it up most of the time whatever your PC is.

I think that FourCross2 is french so do I.

Lot of french people here! But I’m not from France, I’m from Canada.

A clean install has fixed everything, my game is working fine now :slight_smile:

1 Like

That doesn’t mean you’re not French!
from a fellow Canadian!! :+1:

Well thanks to everyone, but i´ve tried everything and my sim doesn´t work. I don´t know what to do, or what i did not do. If someone have another solution please i´ll apreciate

Did the same and it’s also working well now. Gonna have to go flying over Canada and say ‘‘Bonjour cousins… :wink:’’

1 Like

Hi Did you fully uninstalled the sim actually ? If not you’d rather do it, then recheck at all the possible updates about your windows and various apps in the library and restart a full download from the Store.
I did it, FourCross2 also and we are both flying again.

2 Likes

You are most than welcome here my friend!

Thks a lot

Hello everyone.

I have a problem with this game.

My laptop is ASUS ROG Strix G17 G712LWS-EV411 17,3"/i7-10750H/16GB/1TB SSD/GeForce RTX 2070 Super.

I buy this game from MS Store

I download this game from MS Store, and for me send 1.1GB size. Okey I click to start and then I see WARNING Your last session of Microsoft Flight Simulator ended unexpectedly.
This may be due to installed 3rd party content, out of date content, or
incompatible drivers.
Would you like to continue in Safe Mode? In this mode, 3rd party
content will be disabled.
If you do not have any issues when Safe Mode is active, then the
issue is likely related to 3rd party content. This content can be
updated or removed via the Content Manager or the community
folder.
If the problem persists, try updating out of date content or
incompatible drivers. You can also check the forums, or contact
customer support.

I click to normal mode or safe mode is doesn’t matter which I click, and the me kick out of the game… I try to reinstall, nothing changes.

welcome… can you open the “windows event viewer” and show us the error message ?

There is a FAQ ('s) where you can start:
: https://flightsimulator.zendesk.com/hc/en-us/articles/4406039624338-All-versions-Loading-issues-Checklist
: https://flightsimulator.zendesk.com/hc/en-us/articles/4406047820690-All-versions-Sim-freezes-or-crashes-before-loading-fully

e.g. often simple the US language pack was missing or there are some xbox login issues or antivirus tool blocks somewhat or…

If unsure about a setting recommended within the FAQ just ask :slight_smile:


Also I have a video but I can’t here add :smirk:

oh… the 0x8007042b error… about that we have existing topics which more “on topic” then.

Here you can check:
https://forums.flightsimulator.com/search?q=0x8007042b

Example: Just started getting a splash screen on launch - #24 by AndrijanJ

So far I remember reinstalling Game-Services per console ( or somewhat with the Digital Ownership ). But better recheck that :slight_smile:

A post was merged into an existing topic: MSFS doesn’t launch - opens MS store with Gaming Services instead