Downloader keeps resetting to 0% if you have certain router models

-This happens on files over 1Gb in size. it appears a “network TCP reset” is the cause of the download progress resetting to 0%
-This is related to QoS settings.
-This is all due to a poorly coded launcher which resets the download instead of continuing from where it left off it it experienced a completely standard network tcp reset.
-This makes it impossible to download the game for people with certain brands of routers (and has been recorded to happen worldwide so it’s not just one niche brand)
-This literally doesn’t happen with any other downloading program, so the problem is with the launcher.

And no, this isn’t a hardware issue. It’s a problem with the faulty launcher, the software. Because this doesn’t happen with any other programs. It’s an under sight from the developers. One which they failed to notice several months after release, probably because they don’t read these forums, only the moderators do.

It simply resets itself to 0% after a couple hours of re-downloading. This is absolutely ridiculous. How can it fail at such a simple task. Deleting every MSF file in my PC and re-downloading from scratch didn’t fix it either so that’s another day gone to waste.

Edit: It’s been 17 days now. Still having the same problem. Only solution is to have a friend from the USA pass you the files. Shame we have to do it this way because Asobo doesn’t care about the smaller countries, even pirates got a better download than this ■■■■■■ launcher.

Edit: A possible solution is to use netlimiter to limit your download speed, or to play with your QoS settings in your router. But some routers do not provide you those options, so it does not work for me.

The cause seems to be related to certain router models. The download is reset every time the is a “network TCP reset” apparently, which can be caused by some settings on some routers, but you may not even have the choice to change them. All that can be done is either buy a new router or wait months for Asobo to even notice there’s a problem.

Have you tried installing to a different disk? Also, Steam or MS Store?

Steam, and yes I’ve tried the default path in my sdd and my hdd.

Same basic problem on different file. Been downloading for three days. I’ve tried everything. The biggest issue is that this should not be happening. Downloading a game, even huge files, should just work. I’m to the point I just may wait a week or two. I dumped $1000 into my PC this week to be ready.


A reinstall didn’t solve it for me either. I got the sim working by reinstalling Windows, and formatting all the hard drives, though that’s not a very elegant solution.

Me neither

1 Like

I don’t even have that screen, nothing happens when lauching MSF2020. It seems to be dead.

People, can you check your packages folder and see if there are uncompressed packages? (.rar or .zip files)

I suspect the launcher for whatever reason may be failing to uncompress the files.

A friend suggested that the servers are providing bad files and so they don’t pass the integrity check, so it could be that too… in which case one would need a VPN but I definitely can’t get one…

1 Like

I have the same issue. To be clear, the download loop happens on most large files if you watch it carefully. Some percent of the file will be downloaded, then it will reset to 0% and re-download getting to a different percentage, then it will reset to 0% again, etc. Eventually the smaller large files are successful because they eventually make it to 100% without restarting. But the largest large files like fs-base-0.1.61.fspackage.002 never make it to 100%. It’s lucky to reach 10% occasionally before restarting.


That kinda suggest the issue was your end and not the flight sim’s.

Try uninstallting and re-installing the windows store app file if the sim won’t even start.

I’ve reinstalled from scratch 4 times, each time it got stuck on that specific file. I deleted all files, in appdata and in packages, and nothing. Keeps getting stuck on the same file, and MFS support won’t help at all.

I tried installing it in a different disk (Both had twice the space needed)

I tried installing it in a wired connection

I tried installing it with another internet connection

I tried installing it in an entirely different PC

Nothing works. It’s on their end. They must have a corrupted file in their servers.


Unfortunately, I tried to get the core update and it failed too. As mentioned to completely un-install FS202 and re-install from MS Store and it failed also. Why can’t we have a service pack to download and install like the old days. At least that worked :frowning:


I have the same problem although I was up and running on FS2020 for a week or so before ‘The Update.’ That caused me to have to re–download the entire FS2020 program and to get stuck at the same spot. That section of the DL kept cyclic over and over in which it would go to varying % of completion and back again. Eventually after talking to MS game box support, I emptied the caches from the download and started again fresh. I also stopped Window’s Defender and made sure I had no pending windows update. The re-download went smooth and slow but again stopped at that same section of DL that was mentioned! I am at a loss now. I like the game and I too invested in a computer upgrade so I could run this at ultra. I also bought a suite of peripherals . I am invested in this and I need it to load NOW. BTW my previous computer was great and I could have lived with that.


So… This seems to be an issue at MS servers!

1 Like

How can the people at Asobo be so inconsiderate of other countries. This 100% is a corrupted file on their servers. They could simply have let us download the whole game through steam or the store, but they had to force us to download it from their launcher. And because of that now those who aren’t in the popular countries like USA can’t download the game they paid for. And they won’t even bother looking at the issue and fixing it after 16 days. I bet they still have no idea what’s going on here…


Yes, seems like it. But what did I do wrong? Like, was is it a wrong configuration of Windows? I have used the computer for some time without reinstalling Windows until that point and have never had a problem installing any software. Everything was working fine, also, so I kinda doubt I messed up my setup that bad. I have seen others doing a reinstall of Windows and still having issues installing. And it looks like the last patch addressed some installation issues, so that probably wasn’t completely bug free.

Hermano, pienso lo mismo, he leido este chat y hay varios inconformes con el mismo problema pero todavía no hay una solución!! Has podido resolver el problema?? yo estoy hace una semana barado en el mismo punto.

Having as a issue here. Deleted files from store… failed to even get back to ls base package 2, whole game, still getting packages constantly reset to zero mid download… very frustrating…

Using Game Pass I have a really good WiFi connection too, around 100mbps task manger reports anywhere from 70-90mbps to flight sim… no wired is not a option for my pc is far from the router but like I said WiFi speed is very good.

1 Like

Mine has been stuck on that same file for the last week. The most it’s gotten to was approx 200meg then looping to zero. I’ve had the guy who built my PC spend about 4 hours going through my 3 month old system built to spec for this game with no luck getting it to work after I’ve spent the last 2 and a bit weeks trying every suggested or listed fix under the sun.
It gets frustrating as the only response I get from MSFS team is to check out the FAQ etc.
In the last 3 days I’ve downloaded about 40GiB of data all within the very first looping file download so it’s chewing up the data, thankfully i’m on an unlimited plan

1 Like