Downloading Small Update Repeating Over & Over

Exactly the same problem for me. Just kept looping at 112 MB. So I killed MSFS, and now it’s downloading 35GB. As long as it works, that’s ok, my internet is plenty fast and it won’t take long. But, we’ve been seeing a lot of install difficulties. I had a similar problem updating the Carenado PA44 that a lot of people had. Where I had to manually delete the install, and then it installed fine. Let’s hope this one goes ok.

It looks pretty clearly a file permissions problem, that it can’t write or delete files for some reason. My user has admin priveledges. But I didn’t install as administrator, and I’ve heard other people counsel against doing that, I imagine largely because you’ll likely create file access issues.

1 Like

Hi @DFWSupertrooper,
I’ve moved your topic over a few subcategories for installation issues. #bugs-and-issues:performance
Thanks!

Hi,

I had this problem too and after trying for 3 days (I made the mistake of uninstalling the simulator) I only managed to download it when I limited my download to the maximum speed that package downloads were achieving in my case was 20 Mbits.

This problem happened at least for me, because ONE DAY I made the mistake to limit the download speed in the DATA OPTIONS.

Then when you try to download some updates or reinstall the game, your download speed will be limited to the same speed that you set in DATA BANDWIDTH USAGE LIMIT and every time that your download speed exceeds the speed that you set in this option, your download is reset.

I solved my problem of reinstalling the game, by limiting the bandwidth of my network card to 10 Mbits, that way I managed at least to install the game again and set my Bandwidth usage to Unlimited again, now the updates don’t reset anymore.

PS.: uninstalling the game doesn’t solve the problem because the first thing that is downloaded is your profile, with all configurations that you were using before, so the Bandwidth limit is set again even if you uninstall the game.

Sorry about the bad english, I need to use google translator heavily to help me write this message.

How can it always be that you first have to select any settings and then worry whether it runs thereby… The community is fit and supports each other… Why can not I expect the same from the developers… Then they could save their ■■■■■■■■ not seriously meant standard excuses.

I can confirm that you must not install the Sim with administrator rights. I did that and it ended up in infinite loops due to the lack of write permissions. Btw, I encountered the same problem yesterday. It eventually installed after 3 hours.

Yes, I confirm that to fix the looping file problem, I had to limit my Internet connection to a speed WELL BELOW the DATA BANDWIDTH USAGE LIMIT set into MSFS options.

How do you know that’s what caused your problem? Just because you did that is no guarantee that’s what caused your problem, unless you’ve tested a million scenarios and narrowed the issue down to that one problem. Without full debugging and running all kinds of scenarios, that’s like saying you’re having this problem because you brushed your teeth this morning.

I got around the looping problem by killing the game. Then it came back and wanted to install 35 GB, which it did in about 10 minutes and the game was off and running again.

Wouldn’t it be funny if the file permission problems the game seems to be having are what’s behind all of the performance issues people have been seeing, IOW, tied to the DRM the game/OS uses. Yeah, kind of a stretch in thinking, but…

It was part 2/4 that was looping 01.156.8.0 only 112 Mb but now it is wanting to download 34.89Gb and will not move past 4.58 Gb.
I have had constant CTD and Blue screens of Death yesterday.
Why cant we have an option to decline updates ?

Yep.

That way I said “at least for me”.

I’m only sharing my experience because I work with networks and you can see clearly that the Microsoft update Servers close the connection because of the download cap.

Look in Task Manager | Performance tab the Ethernet graphic when you are downloading the update, ideally it will be a straight line not a roller coaster.

2 Likes

You cannot decline updates. The server model they use requires everyone to be using the same software. Despite how it may feel to you, this is a distributed platform, it is no longer a piece of software that only sits on your own PC. At the current level of technology in the world, there is zero chance they could possibly manage all the versions that would be in the field, especially with all the updates they are producing. Every single line of code interacts with the whole package.

same problem, download a update (in past mostly at world updates) it stucks or loops, I pause it, restart MSFS and suddenly 87GB. Now with patch to 1.15.8.0 too. It sucks - really. So good the sim might be in game, the installation/update procedure is a whole mess

My problem is. That I felt the same way as most people here. However, what was added to the fact that it loaded 34 GB afterwards. For this he needed a day 19 hours…
Also an update in the store he loads very very slowly. I do not know what to do. The bandwidth is not limited.

yo tengo el mismo probé hace 5 días y aun no puedo dar solución, he intentado mil y una opciones y no da. a Microsoft y asobo recomiendo evitar dar fechas de nuevas update y trabajar de una manera mas eficaz por que somos muchos los perjudicados. la update de reino unido corría perfectamente que carajos hicieron!.

Hi excelsior105729,

According to the Code of Conduct, you must use English when posting on the forums. The one exception is the #multiplayer category, where you can use any language to help you find users to connect with.

If you cannot read English, the forums provide a handy feature that translates posts into your native language, you can use this feature by clicking the translate button under a post. translate icon

If you need help converting a post from your language to English, try using Bing Translator, the same service used by the forums.

The World Update 4 is 88 GB ???
What is going on?

It downloads 88 GB for real.

Update : I did not use any IPv6 and Bandwith was limited too for testing which did not help.

It ended now in again downloading 88 GB which resulted in the same Issue with last Update Patch
File FS-Base and after unpacking this 2 Rar Files it looped again downloading that pack and then crashing the Applikation.

After a restart it again downloaded 88 GB which then worked.
Then the World Update 4 could be installed.
So at the and around 185 GB Downloading for a usually Short Patch and a World Update 4.
I had zero Issues with my Installation before.

Not good.

1 Like

@Hester40MT After you pointed out the unified language, marginal. What solution do you see to the problems raised here? Like my problem with a download that takes so long?
Isn’t that rather the problem. Than the language?
And by the way, you can translate the text yourself. I trust everyone here to do that. But of course it’s better to go into something like that than into the problems that exist…

First, moderators are not support for MSFS.
This is our role:
https://forums.flightsimulator.com/t/welcome-to-the-public-forums/121637

As far as your issue, have you tried using a VPN to bypass your ISP?

Nice that everyone has his task :wink: and there is always a nice text where you protect one :wink: Nice that everyone has his task :wink:
And no thanks for the tip I will try it

Ok, pls check the following file in the path: “C:\Users\User\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache”
UserCfg.opt
The last line in the opt file should contain the path to your msfs folder which in my case is:
InstalledPackagesPath “J:\MSFSPackages”
When I changed to 1.14.5.0 the path was suddenly changed to my windows drive C:\ for no reason. When You are at the point in the update menue where you see that path, it’s always positioned to the path where the update will install but might not be the path in the opt file. In this case change the opt file, save it and restart your sim again. No garanty but worth checking it.

I have managed the update. But with an eternity…
The problem that the download takes forever is still there. I tested it on an update from an airport from the content manager. It loads only with 2 to 3 Mbit. If I load normally via the browser I get a speed of 50 Mbit only in msfs not there it remains at the slow speed.
I have tried these tips without success.
https://flightsimulator.zendesk.com/hc/en-us/articles/360015761760-Slow-download-speed

Maybe someone has another idea?
Thanks a lot