Dreadful performance

And not even then, and not even in low…
Stutters no matter what.

1 Like

I’ noticing that frame rates are stable for about a minute but after that it drops to about 10fps. Anyone experiencing the same?

Some people say that they are not experiencing any stutters playing FS2020. That’s funny because the stuttering is just there, permanently all the time and you cannot avoid it. There is not one single YouTube-video of this game without it. Some people just don’t care about these micro-stutters as much as others but - nevertheless - you cannot get rid of the stuttering. You can even see these stutters in the Trailers from the Microsoft/Asobo-Studios… (for me this points out that this is a pure software-problem and not a hardware-related issue)

I run the game with mid to (mostly) high settings (avoiding to fly over big cities) with constant (!) 60fps (1920x1200, Ryzen5 3600, RTX2070 Super, 32GB 3200DDR4 Ram, M.2-SSD, TrackIR). Every (!) other game works smoothly with such a “high” and constant framerate - but not FS2020. The stutters are still there, even with constant 60fps and they are very annoying. Every single stutter reminds you that you are not flying a real plane and that you just sit in front of a (…very bad optimized…) simulator!

The graphics are great, no doubt, but as long as this problem exists this is just worthless. I don’t know whether the updates or the newer graphic-drivers made it even worse, but with an earlier nvidia 457.30 driver it was not as bad as it is with every newer driver (and/or with the newest updates).

Some may say 30fps are enough for a flightsim, but that’s just not true for everyone and - even more important - that’s not the point, because the microstutters of the FS2020-graphic-engine are always there, with constant 60+fps just more noticable than with just 30fps which stutters permanently anyway.

You first have to experience other really smooth sims (DCS, …) to really appreciate a smooth flying-experience - this is (at the moment) just not possible to achieve with FS2020 and that is very unpleasant because the potential of flying over all regions of the world in such a high graphic quality would be very desirable. (I even would prefer worse graphics just to get the sim smooth all the time. Reducing the graphics to low-quality-settings doesn’t help…)

I think this problem should be solved with highest priority, it’s more important than any bug-fixing or to add some new features or planes.

This problem kills the whole experience of flying with FS2020!!!


it is not funny if people tell you here experiance with MSFS, as like as you do same.

Visually very promising but really bad performace-fps. For VR, it needs to improve a lot. I can’t have a smooth experience and I have a 9900k 5ghz and a 2080ti. With other games and simulators like dcs and flyinside the experience is great.

1 Like

Hello IceManBMWM3,


Unfortunately there is still people out there, including the developers,
that have STILL not noticed that the graphics engine of MSFS is FAULTY,
and no matter the tweaks, settings or rigs, it just STUTTERS, as you
rightly write! They have dedicated far more attention to giraffes, flamingos, POI’s
and whatnot than to the very basic and most important issue, a fluid simulation…

You might be interested in my thread:


Stutters… this is my biggest thing. I’m finding that performance seems to degrade during flight. My system will be rock steady during departure, climb and cruise… however, during the arrival I’ll begin to notice stutters and by the time I’m on the ground the performance isn’t the same. I’m running a pretty beefy i9 9900k OC 5GHz, 32GB RAM and a 2080ti. Plenty of others have complained of this. I’m convinced this a problem with the SIM and not hardware.


Hey don’t forget MSFS is not using the features of our graphic cards that are available. It’s like you have 64 GB Ram but working with windows XP 32-bit. So without changes in the MSFS graphic capabilities none of our expensive equipment will solve the problem. It’s like driving a Porsche in Manhatten - no need for speed. Guido

1 Like

Hi, I have recently started to play MFS2020 on a Precision 7740 laptop, it’s reasonable spec’d,

i9-9980HK (8 core, 16MB Cache, 2.4GHz up to 5.00 GHz Turbo, 45W)
64GB, 2x32GB DDR4 2666MHz Non-ECC Memory
Nvidia Quadro RTX 3000 w/6GB GDDR6
3x 1TB PCIe NVMe Class 50 SSD’s

With no other programs running and windows and my anti-virus running in games mode, I find that MFS2020 is unplayable, even with setting all down to minimum. The screen is jerky as hell and I keep getting constant but random popping from the speakers. When I look at the GPU in task manager it’s quite erratic, (Seen in Image). However, after approximately 25 minutes of play, on autopilot, the play suddenly smooths out and I can ramp all the setting to ultra and everything seems fine, when I look at the GPU the graph displayed is settled with the occasional blip. I known the RTX 3000 utilises DirectX12 and MFS2020 is only ultising DirectX11 at present, could this be the cause?

1 Like

You can do whatever you want, it just stutters and is jerky, as you write.
I am utterly astonished that it is STILL not clear that the graphics engine of MSFS is badly programmed,
and no matter the tweaks, settings or rigs, it just STUTTERS… “jerky”…


and again a sentence from you “clipboard”.

Just all your posts within this forum are the same… possible you should think bit more about helpfull content within the Bugs&Issues categories.


I think you might have a CPU temp issue. When MSFS is starting, for the first several minutes, loading all kinds of stuff, CPU/GPU, etc is very high. Once you get in the air and all is loaded, things can start to settle and get steady.

My advice (I have a Razer Blade 15; 10875h, RTX 2080 Max-q, 32Gb 2993, 1Tb NVME.) - disable turbo boost (probably in your bios) and see if that keeps temps under control. If that helps, then try something like Throttlestop to manage your Turbo somewhere b/w base and max clock. In my case, my CPU goes from 3.6 to 5.1, but I cap them at 4.2. The FPS change from 4.2 locked to wide open is 2 FPS with nearly zero stutters.

Or, if you don’t want to do all that yet, download and run something like HWinfo to watch CPU temps.

i have the 5600x overclocked to 4.8GHZ with RTX2080s and it’s not any better than my wife’s 3600x desktop with 1660 (both PCs run the game pretty choppy in busy areas around cities and airports). so this is not a hardware issue but a software problem. i think this topic has been beat to death at this point.


Interesting that you say that, as I did load HWMonitor onto my laptop yesterday and left it running in the background and the CPU Cores peaked at 100°C, (displayed in red text I might add, so guessing thats not a good thing) typical they sit at around 50°C at idle. I believe max operating temps should be around the 80°C and only to pushing to 85°C for short periods of time. I have just ordered a laptop cooling pad to help with the cooling. Fingers crossed that this resolves the problem.
Failing that I might look into Throttlestop. Thanks for the suggestions. :+1:

A fair comment but, for me at least, I know my PC is capable of running this game smoothly, when it finally does it’s brilliant. It’s just frustrating that there is just something that is causing a problem somewhere. I’m always looking for that illusive check box hidden deep in the depths of the options labelled something like ‘turn off cr@p performance mode’. I’m still looking! :rofl:

Incidentally Picklertune, how do you display all that frps and cpu data that you have in the top right of your screen image?

1 Like

I used to have intel 10th gen Lenovo gaming laptop and it produced so much heat I could fry eggs on it. Max operating CPU temps for them are 105° celcious though but it will throttle back from 95

Indeed, I agree. This is not a hardware issue but a software problem.
Astonishing that there is still people, including maybe the developers,
that still have not accepted this…

1 Like

COMPLETELY agree! Thanks!

I started getting that just a few days ago. Had never been an issue ever. Then this started quite randomly. Everything can be working fine without issue, then the process freezes for 10-20 seconds, then resumes. I’ve even had it happen on the world map. With or without mods makes no difference. Even tried disconnecting all my peripherals just in case and going in old school with mouse and keyboard only. Still froze for 20 seconds as I was sitting on the apron before I could even start the plane.

I can’t find anything in my event logs to indicate a driver problem.

“pauses” are discussed more within following thread:

This thread here is more for users which have “a not smooth feeling” ( and in meanwhile comparing of apple and pears :wink: )


unfortunately there is no cure for this. The game is very sequential and it uses 1 main thread and 3 background threads only. However the main thread is responsible for processing most of the instructions including physics calculations, AI and draw calls. I’m actually not sure what the other threads do since when i monitor them with HWiNfo they’re almost idle. Most modern CPUs are not built for single threaded application but I specifically bought a CPU which is very strong at single thread processing , the Ryzen 5600x…specially when overclocked. Even still the main thread maxes out for me on lowest settings and the picture is quite choppy at low altitudes. Some say DirectX12 will solve this but i doubt it since the engine will not be replaced? If you take some C++ courses you can learn about multi-threading, concurrency, and how to code applications to take advantage. This is the lesson that Asobo developers ignored, but they are not the only ones. US Navy has issues with their own simulators but they use hardware that are sometimes decades old.