Dreadful performance

Hi all,
First I just want to congratulate the team on the release of the sim.
I completed the installation earlier and it seemed to install without any issues at all. I got into the sim and went to my local airport and the performance is terrible, panning around is jumpy and stutters, nothing appears to be smooth at all.
It’s currently not possible to fly In the sim.
My specs are: i7700K, 1080ti, 16gb DDR4 ram. I have been using my 4K monitor but also have the issue at 1080p.

I have tired all different setting presets & resolutions to try and figure out what’s going on. My internet is 350mbps so that seems to be ok.

Even when loading into a flight it seems sluggish and slow. Very odd as I’ve seen people with lower specs than mine have it running smooth.

I would be very grateful if anyone could try and shed some light on this or if they are having a similar issue?

Thank you I’m advance :slight_smile:

19 Likes

Same here. Dreadful performance even on the lowest settings.

6 Likes

yup same here too, same specs as you too but i have 32GB RAM and 85mbps internet

1 Like

Yep same here. Unusable 7600k & 1070ti

2 Likes

were you not experiencing it before the release?

I wasn’t part of that unfortunately. So first use for me.

I have i7-6700K, 32Gb Ram and Zotac 1070 ti Mini with 8gb GDDR5. Drives are 2 x Samsung SSD , internet is 72mb fibre connection. Monitor is a 32inch Samsung monitor at 2560 x 1440 set to 100hz refresh. Sim runs smoothly on ‘high’ settings.

It’s very strange… what’s more frustrating is when I can’t identify anything and start running out of ideas. I also have it installed on a m.2 SSD.

vsync off by chance?

i’ve spent 15 hours trying to find the problem and trying potential fixes, i’m giving up and waiting for a patch i think.

Seems a lot of the performance problems are with users of 7 series cpus. Seems a bit of a coincidence.

1 Like

Tried it on and off. Tried virtually all different combinations now. A non detailed default airport etc… nothing seems to budge that performance issue.

Doesnt make much sense to be honest. The beta had it’s issues, but it ran decently.

Im still downloading, so I can’t compare quite yet (75GB down)

2 Likes

its not hot, its not overloaded, nothing noticeably wrong with it.

Ditto with I7 7700K

Same with mine. But I’ve read several posts and owners of 7600 and 7700 are seemingly having similar issues.

Interesting point…
Seeing lots of users with i7.
I checked my task manager and it was showing red with 100% usage when loaded in.

2 Likes

So it’s limited to 4C/8T CPUs?

Ryzen, i9, and 8th/9/10 gen i7 do seem better

Folks who are streaming it dont seem to have 7th gens either… coincidence?

i was thinking at one point that its dx11 thats the problem, why not dx12 or vulkan.

2 Likes

I think that when the sim development began, DX12 was non existent. MS would not use vulkan as Direct X is MS proprietary.