[FIXED] Random CTDs due to internet and hardware issues

I’ve searched on a couple of sources online where people reported the same exception code (0xc0000005) as you did.

The following solutions were posted:

  • Reset overclocked RAM to stock speeds

  • Bump up GPU fan curve in e.g. MSI Afterburner to keep temps lower and prevent throttling mechanisms from underclocking

  • Install the English Language Pack (US, not UK) for Windows

  • Disable ATC services in game

  • Update everything in the Microsoft Store App

  • Uninstall GPU driver with DDU and reinstall the driver

1 Like

I have done a fresh windows install from scratch and losT (kinda) my work that i had collected for P3D over the years. I can get those back but the time required would be a lot. Instead I have been crazy trying to do anything to run this bs on my system that i had preplanned to bbuild so i would have the best possible preparedness. All alphas worked but trouble came with introduction of IR tracker in the Beta. Why would it not be easy for the devs to figure out what were those changes that led to this. ALl i keep getting from them is that my hardware is bbad or conflict of my programs. Their program is perfect.

I have taken my system as last resort to the expert who has fs running smoothly in his system. I have also asked for change in memory modules. I had 2133mhz and upgrding to 3600. If after all this, it doesnt run then thats that.

:warning:

According to the latest development update, patch notes of Patch #2 will be provided Thursday, September 10th.

I’ll keep you guys updated. Let’s be patient. The developer team said they’re working on the simulation experience itself.

Hello,

Can we expects that it does include some improvments on players which actually do not have simulation experience due to a miserable unhandled null pointer exception on loading ?

Regards,

September 9? Source? and i dont see any CTD related fix in their next update list meanwhile CTDs thread are treading with many upvotes.

225/03 Wind Thread
Wind Testing
Live Weather and Wind Readings are Not accurate
Live Weather Not Working
Live Weather Error
Garmin G1000/G3000 & Autopilot Related Issues
Turboprop Engine Logic Issues
ATC Incorrect Phraseology
Baron G58 Missing ALT Knob
Night lighting – Terrain emits light?
Dreadful Performance

Where the ■■■■ is https://forums.flightsimulator.com/t/crash-to-desktop-without-error-message in their list? This thread already surpassed the upvotes of issues mentioned above.

On https://www.flightsimulator.com/september-3rd-2020-development-update/ it sais:

Patch #2 has advanced to the final testing phase. While we’re not quite ready to provide a release date for Patch #2, it will be released this month. Patch #2 will have an increased focus on the “in-sim” experience and we will post a complete patch list prior to release.

­
and further down the page under development update:

  • Patch has entered the final testing phase.
  • Team working to define release date pending results of final testing.
  • POR is to release Patch #2 in September.
  • Update on timeline and patch notes will be provided in our upcoming post on 09.10.

­
It’s not clear yet, whether this patch will also contain any crash related fixes. We’ll see what the upcoming patch list will reveal.

I wonder who the testers are. In house or do they have a group of MSFS users. I think these tests should go out to those having problems (if they want to test unreleased patches). I would volunteer for testing.

Microsoft ® Windows Debugger Version 10.0.20153.1000 AMD64
Copyright © Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Windows\Minidump\090920-6406-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: srv*
Executable search path is:
Windows 10 Kernel Version 19041 MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Edition build lab: 19041.1.amd64fre.vb_release.191206-1406
Machine Name:
Kernel base = 0xfffff8046f000000 PsLoadedModuleList = 0xfffff8046fc2a310
Debug session time: Wed Sep 9 16:18:09.895 2020 (UTC + 3:00)
System Uptime: 0 days 4:57:09.537
Loading Kernel Symbols




Loading User Symbols
Loading unloaded module list

For analysis of this file, run !analyze -v
nt!KeBugCheckEx:
fffff8046f3f3ea0 48894c2408 mov qword ptr [rsp+8],rcx ss:fffff30d93d37860=000000000000001a
6: kd> !analyze -v


  •                                                                         *
    
  •                    Bugcheck Analysis                                    *
    
  •                                                                         *
    

MEMORY_MANAGEMENT (1a)
# Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 0000000000061941, The subtype of the bugcheck.
Arg2: 00000266568f9030
Arg3: 000000000000000d
Arg4: fffff30d93d37a00

Debugging Details:

KEY_VALUES_STRING: 1

Key  : Analysis.CPU.mSec
Value: 2186

Key  : Analysis.DebugAnalysisProvider.CPP
Value: Create: 8007007e on DESKTOP-6N98JSF

Key  : Analysis.DebugData
Value: CreateObject

Key  : Analysis.DebugModel
Value: CreateObject

Key  : Analysis.Elapsed.mSec
Value: 22084

Key  : Analysis.Memory.CommitPeak.Mb
Value: 77

Key  : Analysis.System
Value: CreateObject

Key  : WER.OS.Branch
Value: vb_release

Key  : WER.OS.Timestamp
Value: 2019-12-06T14:06:00Z

Key  : WER.OS.Version
Value: 10.0.19041.1

ADDITIONAL_XML: 1

OS_BUILD_LAYERS: 1

BUGCHECK_CODE: 1a

BUGCHECK_P1: 61941

BUGCHECK_P2: 266568f9030

BUGCHECK_P3: d

BUGCHECK_P4: fffff30d93d37a00

BLACKBOXBSD: 1 (!blackboxbsd)

BLACKBOXNTFS: 1 (!blackboxntfs)

BLACKBOXPNP: 1 (!blackboxpnp)

BLACKBOXWINLOGON: 1

CUSTOMER_CRASH_COUNT: 1

PROCESS_NAME: FlightSimulator.exe

STACK_TEXT:
fffff30d93d37858 fffff8046f472c08 : 000000000000001a 0000000000061941 00000266568f9030 000000000000000d : nt!KeBugCheckEx
fffff30d93d37860 fffff8046f40205e : 000002630d081c00 0000000000000000 0000000000000000 ffff950f00000000 : nt!MmAccessFault+0x184488
fffff30d93d37a00 00007ffdb28b9474 : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : nt!KiPageFault+0x35e
000000ca0a5af7b8 0000000000000000 : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : 0x00007ffd`b28b9474

MODULE_NAME: hardware

IMAGE_NAME: hardware_ram

STACK_COMMAND: .thread ; .cxr ; kb

FAILURE_BUCKET_ID: 0x1a_61941_PAGE_TABLE_RESERVED_BITS_SET_IMAGE_hardware_ram

OS_VERSION: 10.0.19041.1

BUILDLAB_STR: vb_release

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

FAILURE_ID_HASH: {c6e5c6cf-692e-7852-5dc5-b74944540fc0}

Followup: MachineOwner

congratulation, now we have memory_management blue screen, first in my life i used memory test(windows memory diagnostic tool) 2cycles no errors… thank you for wasting time… must be they start fix it, after this implementation will destroy ram or drive store…

I left my pc to a computer service center on Monday and asked them to do anything to just make it run. They used my system from Monday till Wednesday. The only change they did was to turn on Xmp. They said the sim worked fine all this time. They only had one ctd when the xmp was disabled. I brought pc home, I tried 1 hour flight 4 times and ctd every single time mid flight. I tried with minimum peripherals just wired keyboard and mouse. No live weather or ai. Is it my monitor or my home is jinxed? Or is it something in internet router settings

I hope it is neither! However I did come across one forum user who said they used a different power outlet for their PC’s power supply and that fixed their problem. It turns out the power socket they had been using was dodgy. Just thought I would mention it.

Thanks. This is something I haven’t tried. I have a good quality surge protector that I am using and have had no troubles. Just to make sure I can try direct connection and see what comes out of it.

@Hester40MT tests are performed in house AFAIK. But I’m not sure how they distribute the patches. Like with Windows where not everyone gets the update on the same day. They said the patch release notes will be posted today. Let’s wait for it.


@ContrivedTea675 doesn’t look like your hardware is being destroyed, but there was an error whilst accessing data stored in the RAM. Did you overclock your ram? Other games and programs may run fine, but FS taxes the system so much in certain situations that any overclocked hardware may fail and a blue screen is triggered.


@MasterYodakin, Tamalien is right, I’ve seen people report their power outlet was faulty. Did you try another wall socket yet?

no, i didn’t oc ram, and started first in my digital life from 1995 memory test “windows memory diagnostic tool” two cycles without problems, sure it was metaphor about destroy hardware, but i don’t sure right now, this problem not looks like oc problem, maximum is big temp problem, if 53*c is over for ddr4, i haven’t any big temp place, i haven’t any voltage drop more than 2%(pci-e +12, other much less than 2%), and i haven’t ctd yet after uninstall some software - intel driver updater(assistant), sennheizer firmware updater, addmuncher, afterburner, but i don’t sure it stay stable, as i had before this many stable long time flights, so i just don’t sure… i can say, affinity mask doesn’t help, play with page file doesn’t help, except change it from auto use all drives, to place auto use for one of fast drives, i think it go more stable after i move the game to system store c:\ in my and usual cases… as in any situation like this is can and will have hardware cause, but it certainly have software causes too, as bad code, conflict with some software, blocked dir where simulator live, or and something else…
but i have one more question about amd64 Microsoft ® Windows Debugger Version 10.0.20153.1000 AMD64… why i see this in the intel/nvidia system?

1 Like

AMD64 is the name of the instruction set which was developed by AMD but got adopted by Intel. It doesn’t matter if you’re running an AMD or Intel system, this is just the name of the “instruction set” for 64bit systems. Intel’s proprietary ISA is called Intel 64. They are nearly identical and the difference is only important to software developers that write code for 64bit OS.

More info on this topic:

2 Likes

thanx, so must be the code is wrong, so why we have ctd, and for intel cpu better to use intel instructions, and not adopted amd?

I made one flight without crashing. After that its same old…

1 Like

You can add this too, this fixes my CTDs for the first time.

Fix for those who are facing CTD’s on installing/mid flight, main menu. CTDs Temporary Fix (Awaiting Patch)

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5f467af2
Faulting module name: nvwgf2umx_cfg.dll, version: 27.21.14.5206, time stamp: 0x5f34699f
Exception code: 0xc0000005
Fault offset: 0x0000000000759086
Faulting process id: 0xce0
Faulting application start time: 0x01d687b32a709344
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.7.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b2dd7130a686a22f\nvwgf2umx_cfg.dll
Report Id: c320187f-1b61-48d5-b39e-94485d2b3843
Faulting package full name: Microsoft.FlightSimulator_1.7.14.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

may be it help, but not with all ctd problems

Best way to test is to set your BIOS to default and test again. Couldn’t hurt could it?