Garmin G1000/G3000 & Autopilot Related Issues

Hi,

I’m allowing myself to start a new thread about Garmin G1000/G3000 and autopilot related issues, such as:

  • Unability to enter and properly edit routes in-flight
  • Utilization of SID/STAR/Approach entries (erroneous, missing, etc.)
  • Erroneous Direct-To functionality
  • Erroneous Activate Leg functionality
  • Erroneous autopilot functionality, e.g. Flight Level Change (FLC)
  • CTD experienced while using systems

Most of the issues have been posted in the aircraft related sub-sections where no upvoting is available to increase priority. I personally believe it’s important to upvote the topic here as it appears to pertain lots of users which have at least a basic interest for proper IFR flying.

Among the whole lots of issues we should distringuish between bugs and not yet implemented features, e.g.:

  • VNAV is an additional feature for future
  • Flight plan editing and autopilot FLC inaccuracies I would consider as a bug since the functionality itself is implemented.

To give this post a bit more structure, following are links to the most prominent posts:

Do note that issues reported for a specific aircraft type are likely to occur on other aircraft using the same Garmin avionics, e.g. C172 vs. DA62.

Regards,

Stefan

PS. I am aware that bugs should be reported via Zendesk, yet the priority on the forums has been increased by adding the upvoting functionality.

Agreed , Autopilot is in a rough spot atm for the more fun things it can do/ bring to the sim.

4 Likes

I agree, there are multiple threads about this.

1 Like

I even agree, being a real world pilot, the simulated autopilot in most of these aircraft is really buggy atm.

6 Likes

I’ve just added links to the most important threads for better overview.

1 Like

Here’s my top list of issues, condensed from my original thread about this problem:

  • Initial approach fixes with a hold don’t get added to the flight plan (not just the hold is missing; the fix itself is not present).
  • Missed approach procedure is missing from the flight plan.
  • Vectors-to-final is not available.
  • Feeder routes are not available on the transition drop down.
  • G1000 GPS stays in ENR mode, doesn’t enter TERM, LNAV, or LPV modes.
  • Direct to flight plan waypoint does not work (highlighted waypoint is not loaded, even if entered manually navigation won’t resume from that fix).
  • Direct to a manually selected fix is not considered a flight plan (can’t select approaches if the direct to destination is an airport).
  • “Act leg” soft key is not available for approach legs.
  • Deleting an approach fix deletes the entire flight plan.
  • Approaches start with a random “USER” waypoint which is sometimes behind you, which means you have to turn around and intercept it to get guidance (it can’t be skipped due to the above issues).
  • Entering a fix in an empty flight plan (when none was loaded from the menu) is considered the departure, rather than the destination.
  • PFD shows a glidepath for RNAV approaches (even when not in LPV mode), but it seems to start far too low (well below the FAF), and the glidepath indicator is shown on the PFD far too early.
  • CLR button doesn’t always close pages when it should.
  • FMS cursor disappears sometimes, e.g. after selecting an approach (should move to transition instead).
    • FMS cursor sometimes disappears on the flight plan page and can’t be turned on without closing/re-opening the page.
  • Messing with any of this carries a non-zero chance of crashing the game.

I consider all of these bugs, because even the ones that are technically missing features (like vectors to final) are bare minimum requirements for IFR flights, especially if you want to go online on VATSIM where a controller could give you instructions that you currently can’t comply with due to these limitations. Stuff like VNAV or setting the minimums for an approach would be awesome, but I would be totally fine if that kind of thing is left to third parties.

26 Likes

Yeah, outside of the installation issues some people seem to be having, I’d say autopilot should be priority #1 for Asobo. As someone who is really trying their hardest to learn IFR to hopefully eventually use VATSIM, having a half functioning G1000/3000 makes following tutorials and other online resources a royal pain.

And I am not sure if someone mentioned this already, but the overall “smoothness” of the autopilot could use some work. For the most part HDG and NAV functionality seems good, but occasionally the autopilot will be WAY too heavy handed when changing altitudes. And also one time in the TBM I had to reactivate the autopilot mid descent and it decided that was a good time to pull full back on the yoke and do a complete loop.

6 Likes

All excellent points. Just a small addition I don’t think has been mentioned is the lack of an OBS function for waypoint suspension and transition into the missed approach.

7 Likes

Yes, OBS mode would be very necessary e.g. if ATC on VATSIM tells you to hold (published or otherwise, since neither is supported right now). Related, creating a hold at an arbitrary way point would be nice, but I’ve flown real planes with older software versions that don’t support that, so I’m okay without it. Supporting published holds that are part of approaches is much higher on my list.

SUSP to transition to the missed approach is also crucial, but I would hope that would be part of supporting missed approach procedures in the first place.

4 Likes

Thanks for posting the details :smiley:

I agree that flying IFR on VATSIM appears impossible or at least with a high risk of creating issues as a pilot due to erroneous or missing flight management/autopilot functionality. I wouldn’t dare to get online at VATSIM in the current state except some very basic VFR flying.

I guess filing /I instead of /G (or whatever the ICAO equivalent is) could also work, and just rely on old fashioned navigation. Kind of stupid, though.

Even the Carenado C182T has autopilot issues (suddenly strange trimming, that brings the airplane to the ground when AP is turned on).
It has no garmin-autopilot but seems to be a cheap copy of the MS-Garmin 1000/3000 airplanes with no own programming of behavior.

The Carenado 182 explicitly states on the marketplace page that it uses the default MSFS G1000. Which is why I haven’t bought it. :slight_smile:

3 Likes

Yes, but is has a nicer autopilot. It is this little box with the orange states. Better to see and to use as the garmin buttons.
But same bugs :wink:

I tried using the G1000 for IFR navigation. I took off, climbed to 500 ft engaged the autopilot and the damned thing tried to take be back to the start of the runway! Is this a bug or am I doingi something wrong?

If You had no flightplan it’s that bug.
Reload the aircraft with the dev menu.
If You had a flightplan try disabling Beta:Use UTF-8… in the locale settings.

Ah so glad I found this, I have been struggling to test some RNAV approaches on an add-on airfield I am building and I couldn’t work out what I was doing wrong… seems like nothing, it’s just issues with the sim.

It’s just the same old 3rd party devs with nothing new to offer. The FS Developer forums state that the new engine uses heavily from FSX config files, with the exception of terrain and world generation. I bet Carenado just imported an old model and slapped the MSFS garmins into . no thought no talent, 38 bucks. everyone’s want’s a piece of the action. stop supporting them.

3 Likes

Adding a visual comparison of a real G1000 vs. in-game. It’s a small thing, but it really takes away from the realism when everything else in the cockpit is faithfully recreated. Some callouts:

  • The frequency of the blinking cursor is too fast
  • There is a lack of white border around the ASI and altitude tapes, the menus, and the top display
  • NESW compass font is too big
  • The font is off, for example the 0 should be more square
  • NAV1/COM1 etc. are too large
  • The white lines separating the AP modes, etc. are too thick

7 Likes

I have also AP issues with the TBM 930, but don’t see this behavior mentioned yet (737 NGX type behavior).
It simply violently steers me to the ground within 5 seconds. It appears to be only happening when flying IFR plans generated from the world map. Already made a regular bug report for this.

Video here

NAV source = FMS
AP/TRIM = ON
YD/FD = ON
It happens also with HDG on or NAV on.
You can see the FD is totally wrong (it’s always banked to the right) and it also happens with the FD being closer to attitude. Regardless it doesn’t even try and match FD and steer/dives WAY past, quickly seeing 10000m/s VS.

5 Likes