Drzewiecki Design Chicago and Moscow Scenery not loading after SU5

Hello Dear Pilots.

Have you noticed that the Drzewiecki Design Chicago and Moscow Landmarks are not working after World Update 5? I got instant Freeze of Flight Sim while loading those 2 cities now… only way to close FS is via Task Manager. All other Addons function properly so i guess its not my system…


Don’t quote me on this but I believe Drzewiecki is working on an update for their scenery. Their forums indicate others have had some issues with certain sceneries/airports.

EDIT: I have literally all their airports and sceneries and am avoiding those areas pending further updates from them as well. I love their stuff!

1 Like

Okay i might be check that out. So simply uninstalling and installing the Addons will do nothing i guess. We have to wait for an update. I just wonder cause all ORBX City Sceneries like Dubai, Capetown, Sydney etc. and even the SamScene Hongkong work absolute properly.

Correct. No need to uninstall/reinstall. You might consider simply uninstalling and waiting if you want to fly those areas without the scenery for a bit. Easy if you bought through OrbxDirect or Marketplace obviously.

1 Like

Moscow scenary works very well

I did fly low over the Chicago shoreline today with the Drzewiecki landmarks installed. No problems so far. Nothing unusual. FPS took a huge hit though, going down into the low 20s , even high 10s (usually I am in the high 40s). But I guess that’s normal. Before SU5 I always had to lower the graphic settings when flying over one of Drzewiecki’s landmarks.
I did start at Aurora Airport. That was my route: KARR LL22 KMDW OBK KPWK.

DD Chicago was never optimized and for it to run smoothly you need a beefy card with a lot of vram.

Still can’t load Drzewiecki Moscow or Chicago Landmarks after SU5.
They both freeze MSFS after 60% loading, forcing me to exit via Task Manager.
I know other people have same issue, but Drzewiecki say they can’t replicate the problem.
Please help!!!


I read in the forum they still try to fix ist. Have The same problem Chicago and Moscow scenery.

1 Like

Hmmm……I have that problem with another add-on airport ENBR (over and over again) so decided to fire up my add-on UUEE en Moscow landmarks from Drzewiecki and they worked fine….makes no sense

1 Like

Has someone with The loading freeze issues tried to uninstall and Install The Chicago and Moscow addons again?

Sorry it’s maybe OT but I did this with another airport addon, it worked one time but after that it went back to freezing……and this is all with only that addon in my community folder….

I uninstalled and installed again both products a few times. They keep freezing at 60% loading.
Read what they say in their support forum here:
They say they can’t replicate the problem, so they don’t seem to do much more, suggesting Asobo should take action instead.
The workaround suggested in that message is also useless.

1 Like

Based on some research I did today, and possibly the reason they can’t replicate is because I think it only happens with the MS Marketplace version. It’s the same version as they use but I’m sure there’s something Microsoft may do to marketplace files that’s causing the issues.

If you uninstall it in the content manager, and then load into Chicago it works. If you reinstall it and load into Chicago without closing the sim it works. The moment you exit the sim and restart it and try to load into Chicago, boom it freezes. Just thought it was worth noting what happened on my end when researching. Note I do use FSDT KORD. I tried uninstalling it and just loading in with Chicago and I had the same issue.

I only started having this issue after Sim Update 5 and have no problems flying into Chicago. The issue only arises when trying to load straight in from the main menu.

1 Like

I wonder what Happens If you move The folder from “official” to “Community” folder…

Just tried it. same issue :frowning:

1 Like

Also no luck for me with community folder… :neutral_face:

But i tried to load a flight outside of visual chicago range and then flew into chicago… no problem it runs… same with moscow… as you mentioned above.

What kind of strange “loading direct” error is that?

I spawned at this range and no problem. What i wonder is that you can see all the building already in Chicago but ok with lower details. Strange error i wonder what causes the crash in an direct spawn in Downtown area.

It’s the same with DCA. I can fly into it with no problem but if I try to spawn there I get a CTD. Whatever is causing it appears to be common in most, if not all, of their packages so once one is fixed the others should soon follow.

EDIT: I don’t get a CTD, the sim just freezes during the load after pressing the Fly button.

1 Like

same with me

1 Like