Dual Saitek throttle quadrant issue

I have 2 Saitek throttle quadrants that I am trying to use for multiple engine GA. I can map bindings to one with no issue however any time I try to map to the second throttle quadrant with a different profile, it will not save any of the key bindings. Tried searching Youtube and the Interwebs for help and didn’t find anything (or I missed it?!?). Anyone get two throttle quadrants to work? Both of these connect via USB and possibly I need to differentiate the two controllers in order to map? Would appreciate any and all help!

What exactly are you binding it to?

1 Like

This is what I am getting when trying to bind to the second throttle quadrant. I am also not getting the option for joystick R like your screenshot is showing.

Read this thread, I think your solution is here:

1 Like

Have you checked to see if they are calibrated separately. It looks very much like they are using the same axis on both left and right. Try your driver software or check out controller settings in the “Control Panel\Hardware and Sound\Devices and Printers”
This is mine
Z-rotation is the left throttle and Z-axis is the right.

1 Like

take a look at PlumbGuest’s sugestion you find youre anwser there. bind the two Throttle’s and one Mixture to one quadrant and the second Mixture and two Prop leaver’s to teh second quadrant. that’s the way i configured mine with and they work fine.

1 Like

Thank you kindly, this did resolve my issue. I was looking for Saitek rather than logi while doing my searches.

I’m having a similar issue with two Saitek USB throttle quads. When I set the first throttle up with T T P and the second with P M M MSFS 2020 saves the settings on both to T T P.
I save each with different names like Left Throttle and Right throttle but MS saves both with the T T P setting. Any ideas as to why this is happening. I’ve tried everything on this thread and nothing changes it.

Did you resolve having two logitech flight control quadrants working together??