Eletric System Suddenly Shut down

Hello All,

My MSFS is showing a very weird behavior. During the flight around 10 minutes after start up, my electric systems in all propelled or turbo-propelled airplaines suddenly shut down.

I did a video, using the ICON turning on in a fast way and during the flight, to be more clear.


I used this basic checklist

-Turn on engine
-Turn on Battery and Alt
-Start Magneto
-Turn on Avionics
-And turn lights

Important Notes:

  1. This happens in cold start and in automatic start either

  2. I tried to reproduce using turboshaft motors but all systems worked ok so far. I could not reproduce in propelled airplanes during the trainings (there everything is just fine)

  3. I am using no addons in the community folder. I tried to find other articles with other people with this same problem but I had no success.

  4. During the issue, the magneto enter in a loop and sound like clicking trying to turning on

  5. I tried to use the AI pilot, to fix any possible mistake but the AI pilot did not solved the problem.

I am wondering if I am forgetting some detail. Please someone could help me?

Thank you all

Sounds like you keep your starters on. Make sure magneto is on ‘both’ and if the bird has starter switches, turn them off once stable. Otherwise they’ll drain your engine real quick

After 3 Hours debugging, I discovered in the standard configuration profile created by the msfs of the TCA Quadrant Airbus edition controller of Thrustmaster, one configuration comes wrong.

The ignition button come assigned together with the fuel release. Thus when you select the fuel, the controller enter in a loop trying to perform also the ignition. This makes the battery run out. I removed the assignment of ignition and this solved my problem. Thanks!


I too have the same issue, so what buttons of the quadrant are affected?

I just cleared the mapping of the option set engine/start mode and set engine norm mode. As you can see in the picture above the same buttons are also assigned to the fuel valve. So, when you set the fuel valve, you think that you are setting one thing but the controller also try to set engine. This cause a conflict and creates a loop in the simulator, stucking forever the ignition and draining completelly the battery.


Extremely helpful, many thanks :grinning:

Thank you sooo much!

I have this problem with just one aircraft, but I get about an hour before electrical shutdown.
I will have to dig into the settings and see if that has been the issue.

Thanks for the info.

I had recently the same issue, the failure occuring between 3 and 15 minutes after the take-off, and the solution really helped me, thanks !

I have had this problem since the 40th anniversary update. I have tried this solution with no success. Does anyone have an alternate solution. I have the TCA captains pack and use spad.next and loupedeck live as control add ons.

1 Like

I’ve had this problem with all propeller and turboprop aircraft. As stated by others, the Thrustmaster Throttle Quad is mapped for buttons 7 and 8 (Crank, Mode Norm, Ign/start) to control both “Set Engine Norm Mode” and "Set Engine Crank Mode).
Also, buttons 3 and 4 are set to "Set Engine (1 or 2) " and "Set Starter (1 or 2) and "Set Engine Master (1 or 2) and to control fuel valves for engine 1 and 2. All this causes a battery drain as starters are constantly engaged.
Solution: create a profile for affected aircraft that eliminates buttons 7 and 8 completely and buttons 3 and 4 that eliminates control of fuel valves.
You will still be able to shut down engine with buttons 3 and 4 and buttons 7 and 8 are not needed for prop or most turboprop anyway.
Hope this helps.


Can you please put another image up of what you actually did to fix the issue?

Hello LePewSK8, I am having exactly the same problem for over a year now, did post it twice already but did not find a usable solution so far. I followed your instructions regarding the TCA controller, unfortunately, the avionics and electronics went dead again. I then disconnected / unplugged the TCA quadrant controller and voila, everything stayed on for ever…there must be something else within the conroller settings that causes the problem…

In that case I would suggest you to unmap all other switches/knobs except the throttle sticks. That might solve the issue. I had to face the same and this helped.