ERROR Crash: msfs error: dxgi_error_device_hung (0x887a0006)

Do you have the same issue if you follow the OP’s steps to reproduce it?


Ryzen 7 7800X3D
MSI RTX 4080 OC (Also tried downvolting as suggested above, no change)
32GB 5600 Corsair Vengeance
536.67 as driver

Provide extra information to complete the original description of the issue:

Session lasts around 30 seconds or so. DX12 and HAG enabled for DLSS 3. When DX11 selected, crashes are less frequent, however still occur.

If relevant, provide additional screenshots/video:

No screenshot - Error DXGI_ERROR_DEVICE_HUNG (0x887a0006)

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

2283705724156051539, type 4

Got this today on final. I find it odd that I haven’t had a ctd for a graphics fault in months. Yet two days ago MSFS forced me to update my nvidia drivers that I haven’t touched since I got MSFS stable months ago. My suggestion to asobo: stop forcing your users to update drivers when you clearly can’t get this sim stable on new drivers.

Plaese show us where msfs forced you update your Nvidia drivers.

2 days ago, logging in, I got a message that the cloud data was more updated than my local hard drive data, so I synced. From that moment, the game would not load. It kept crashing saying my display driver was unsupported and to update it. This happened multiple times until I finally updated to the latest nvidia driver, then that error message immediately went away.

What is your gpu and are you using dx12?

Moin Leude,

had the same problem over the past 5 days and tried nearly everything. The error appeared unregularly between 2 or 20 minutes after starting the game, but I was not able to finish a single flight, in some cases the time wasnt even enough to start pushback.

In my case, after trying nearly everything else that was recommended in this topic and by the support, I found the solution in lowering the clock of my GPU, specifically the boost clock, about 20-60 MHz via MSI Afterburner (silent mode in Apps like GPU Tweak worked too, this lowers the GPU Clock by -20 MHz). Since then, no problem at all. To Test the reliability of this, I played an 4 hour session offline yesterday in the morning und had an Vatsim session for about 5 hours in the evening and it worked very well.

Hope this could be a help for some of you

For Info my system:

CPU: Intel i7 6700k
GPU: MSI RTX 2080 Trio X
Mainboard: Asus Maximus VIII Ranger
RAM: 32 GB DDR4 Corsair Vengeance 3200 MHz
OS: Windows 10 64-Bit

1 Like

Update on my issue - Turns out my one is a GPU fault - This DXGI issue started occurring on other games, and has disappeared after a replacement GPU was sought.

I also got a message a few weeks ago, where it said I had too old Nvidia Drivers, and had to install the latest… This message popped up when starting MSFS.

1 Like

Still CTD when switching from Window to “Fullscreen” … make the mistake after task bar was still visible switching to window mode by alt+return and to fullscreen back to get rid of the taskbar in the foreground … instant CTD with the mentioned error and message.

If someone reads this and is interested in fixing bugs (or get paid to do so) from asobo: Full Crashdump is available (26 GB)

ExceptionAddress: 00007ffcc1001363 (nvrtum64!rtcGetVersion+0x00000000001c2493)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000000
Parameter[1]: 0000000000000000
Attempt to read from address 0000000000000000

000000e9cd5fde90 00007ffcc0fe4ae5 : 0000000000000000 0000000000000000 00007ffcc2745b01 000000e9cd5fe000 : nvrtum64!rtcGetVersion+0x1c2493
000000e9cd5fdf40 00007ffd9519491e : 000002138383b280 000000e9cd5fe051 000000e9cd5fe090 0000000000000000 : nvrtum64!rtcGetVersion+0x1a5c15
000000e9cd5fdf90 00007ffd9518f172 : 000002138383b280 000000000000c997 000002138383b280 000000000000c997 : nvwgf2umx!NVENCODEAPI_Thunk+0xfdfde
000000e9cd5fe190 00007ffd9518b4ff : 0000000000000000 0000000000001348 000002138383b448 000002138383b448 : nvwgf2umx!NVENCODEAPI_Thunk+0xf8832
000000e9cd5ffaa0 00007ffd950011a2 : 0000000000000007 0000000000000000 00007ffd94f20000 0000000000000000 : nvwgf2umx!NVENCODEAPI_Thunk+0xf4bbf
000000e9cd5ffb40 00007ffd96cc969e : 000002138379c060 0000000000000000 0000000000000000 0000000000000000 : nvwgf2umx!NVAPI_DirectMethods+0x66fc2
000000e9cd5ffbb0 00007ffdaee126bd : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : nvwgf2umx!OpenAdapter12+0x66a4ee
000000e9cd5ffbe0 00007ffdafcadfb8 : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : kernel32!BaseThreadInitThunk+0x1d
000000e9cd5ffc10 0000000000000000 : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : ntdll!RtlUserThreadStart+0x28

SYMBOL_NAME: nvrtum64+1c2493
MODULE_NAME: nvrtum64
IMAGE_NAME: nvrtum64.dll
STACK_COMMAND: ~26s; .ecxr ; kb
FAILURE_BUCKET_ID: NULL_POINTER_READ_c0000005_nvrtum64.dll!Unknown
OS_VERSION: 10.0.22621.1
BUILDLAB_STR: ni_release
OSNAME: Windows 10
FAILURE_ID_HASH: {25834353-6e39-d97f-3398-5e7302035246}


1 month as pass since launching MSFS 2020 i got black screen. System complete crash.
Couldn’t run Windows 11 after that. Ran directly to BIOS and safe mode.
Have to buy Intel Optana memory card . Got burned after system goes down with MSFS 2020 .

Have been the last 3 weeks with support team of my computer supplier.
We ran several tests of hardware . No errors.
Computer runs other simulator and games pretty well.

Interl Core i9 9900K
GeForce RTX 2080 Ti
Windows 11

Since the release 3 years a go this was my 1first problem and went very badly causing system to crash completely.

Even MSFS 2020 don’t launch no more like before. Start with small screen , then sign in, then sync then load to normal lauching screen. as sson reach main menu i have this

We couldn’t find a solution for that.

Any sugestion please ?

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, had de problem today a few times, with different aircraft and places.
Try with DX12 Beta and DX11

Provide extra information to complete the original description of the issue:

RTX2060 537.42 driver

If relevant, provide additional screenshots/video:


If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Fault bucket 1755956904228973006, type 5

Again, its just impossible to make a nice flight on MSFS, maybe try buy the XP12.
Microsoft Flight Simulator 01_10_2023 21_18_38
Falha no bucket 1755956904228973006, tipo 5
Nome do Evento: MoAppCrash
Resposta: Não disponível
ID do CAB: 0

Assinatura do problema:
P1: Microsoft.FlightSimulator_1.34.16.0_x64__8wekyb3d8bbwe
P2: praid:App
P4: 00000000
P5: FlightSimulator.exe
P7: 00000000
P8: 80000003
P9: 0000000001a5be82

Same Problem here :cry: please fix this!!! RTX 4090, DX12


Just happened to me. Radeon RX 6800.

I have been on this error for 2 days now. My gpu goes to 2 fps and crash. The game freezes. It has to be either the add on scenary or FSLTL. Those are the two things that can be causing the issue. I have a 4070ti.

any one fix this problem yet only start happening today on my brand new 4060 ti coild some one let me no if theres a fix thanks

This has started happening to me a lot since WU15 was released (7 instances so far in around 12 sessions). Seems to happen at random points in a flight, anywhere from on the ramp preparing for departure to final approach.

GPU-Z logs don’t indicate anything particularly unusual at the point the crash occurs, all stats are within normal ranges. No other games exhibit this issue.

Have tried various drivers (536.23, 536.40, 537.42, 546.01), all of which still crash with this error.

I’m using DX11, GPU is an RTX 3080

yeah updated drivers and directx still seems to happen

Same here with 4090 with DX 12
Using driver v546.17 from 2023/11/14

Reverting now to 526.98 …

Crashes with ALL drivers:

  • the latest driver 546.17
  • 526.98 (recommended by Microsoft for this problem)
  • 528.49
  • 537.58
  • 546.01

Gave my money for frame generation, but it dos not work.

Just had this crash
Driver 536.23