ESC Key Moves Control Surfaces When Honeycomb Bravo Throttle Connected

I have noticed problems similar to this have been raised a few times in the past affecting the Thrustmaster TCA throttle but now I am getting a very similar problem with the Honeycomb Bravo Throttle

When I have Bravo Throttle connected and press ESC (PAUSE) and it displays the 3 general options menu, when I then press ESC again to resume flight I find that the throttles have been moved to mid position the flaps have been extended and the spoilers fully deployed.

Even after starting a blank new profile as soon as I assign a throttle axis the problem is back. Anyone else experiencing this with Bravo Throttle, looking back through the forum it looks like its affecting different controllers at different times.

I was beginning to think I had a duff Bravo Throttle but having checked the forum I think MSFS 2020 is to blame.

I have same issue.

Press the ESC key to bring up the menu, and all AXIS will move to the middle position. Then move the throttle to return.

Also, when I look at the Bravo preset at that time, it is always set to Default. However, it is only the name, not the actual selection. If I re-select some of the presets, it returns to normal.

Also Presets can be lost, as reported below.

Confirmed this happens to me using a Thrustmaster T16000 M and Honeycomb Alpha yoke.

Maybe check this thread out. It should be of interest.

Throttle/Flaps/Mixture/Speedbrake/etc axis at 50% when exiting menu WU IV (1.15.7.0) - Bugs & Issues / Aircraft Systems - Microsoft Flight Simulator Forums