EXE.xml Often Not Starting Addons Correctly

Are you using Developer Mode or made changes in it?

No.

Brief description of the issue:

Addons or manual editing to the EXE.xml in Visual Studio and correct indentations for the xml format often breaks the file. It either does not load anything if indents are used or it starts certain applications only.

Provide Screenshot(s)/video(s) of the issue encountered:

None.

Detailed steps to reproduce the issue encountered:

Create new EXE.xml file in “LocalCache”. Use Visual Studio or other text editing software with ability to use indents. Create complex EXE.xml with CommandLine tags & more than 1 exe to start. Run Microsoft Flight Simulator.

PC specs and/or peripheral set up if relevant:

Ryzen 5950X OC
Gigabyte RTX3090 24GB OC
ASUS ROG STRIX X570-F Gaming
Klevv BoltX 3600Mhz (2x 16GB)
1200W FSPLife 80+ Platinum Certified PSU

Version # when you first started experiencing this issue:

SU8


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Yeah, I had to move my auto started apps to a different drive where the “user” user had access. So, it seemed to be a permissions issue but I couldn’t nail it down 100%

Same, ive checked the permissions and all, seems to be the xml not being read correctly.

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

My exe.xml reads:

<?xml version="1.0" encoding="UTF-8"?>

<SimBase.Document version=“1,0” Type=“SimConnect”>
Auto launch external applications on MSFS start
exe.xml
<Launch.Addon>
RealSimGear Add-on<
False D:\MSFS\Community\RealSimGear\bin\RealSimGear.exe
</Launch.Addon>
<Launch.Addon>
Logitech Microsoft Flight Simulator Plugin
False
C:\Program Files\Logitech\Microsoft Flight Simulator Plugin\LogiMicrosoftFlightSimulator.exe
-r
</Launch.Addon>
</SimBase.Document>

If relevant, provide additional screenshots/video:

same here. exe.xml syntax perfectly fine. It seems MSFS doesn’t read exe.xml anymore.

There are many problems going around with exe.xml files. I look after a piece of open-source software that installs itself into exe.xml and I’ve had to write explicit code to fix up corrupted exe.xml files, and handle several bug reports from people asking for help with corrupt exe.xml files.

If you think you have a valid exe.xml file but it still isn’t working, I’d suggest paying very careful attention to encoding, both of the explicit encoding mentioned in the first line of the XML (encoding=“Windows-1252” or encoding=“UTF-8”) and any hidden byte-order marks that may have been added to the start of the file. Mismatches there can cause all sorts of problems.

Try opening the file in a tool such as Notepad++ and look at the encoding reported at the bottom of the screen. For instance, somebody just sent me a problematic exe.xml file which had an XML encoding entry of ‘Windows-1252’ but it had the hidden UTF8 byte-order-mark characters at the start suggesting that it should be UTF-8.

Also, be careful when posting your exe.xml files here. The one posted by @GhostlyFrend above is missing a load of the XML elements such as <Name> , <Disabled> etc that I suspect were in their original XML but didn’t make it into the forum posting. I’d suggest putting any pasted XML inside ‘pre-formatted’ blocks using the ‘triple backticks’ editing feature. Like this:

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>Autolaunch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
</SimBase.Document>
1 Like

Took your advice and did a quick check. The formatting seems correct

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
    <Descr>SimConnect</Descr>
    <Filename>SimConnect.xml</Filename>
    <Disabled>False</Disabled>
    <Launch.Addon>
        <Name>Aerosoft VDGS Driver</Name>
        <Disabled>False</Disabled>
        <Path>D:\MSFS\Community\aerosoft-vdgs-driver\aerosoft-vdgs-driver.exe</Path>
        <CommandLine/>
    </Launch.Addon>
    <Launch.Addon>
        <Name>Volanta</Name>
        <Disabled>False</Disabled>
        <Path>C:\Users\Someone\AppData\Local\Programs\Volanta\Volanta.exe</Path>
        <CommandLine/>
    </Launch.Addon>
    <Launch.Addon>
        <Name>FSUIPC7</Name>
        <Disabled>False</Disabled>
        <Path>C:\FSUIPC7\FSUIPC7.exe</Path>
        <CommandLine/>
    </Launch.Addon>
    <Launch.Addon>
        <Name>FS2Crew Command Center</Name>
        <Disabled>False</Disabled>
        <Path>C:\Program Files (x86)\FS2Crew Command Center\FS2CrewCommandCenter.exe</Path>
        <CommandLine/>
    </Launch.Addon>
    <Launch.Addon>
        <Name>noolaero-module-vdgs</Name>
        <Disabled>False</Disabled>
        <Path>D:\MSFS\Community\noolaero-module-vdgs\Data\Nool Aerosystems\VDGS\vdgs-util.exe</Path>
        <CommandLine/>
    </Launch.Addon>
    <Launch.Addon>
        <Name>FSRealistic</Name>
        <Disabled>false</Disabled>
        <Path>C:\Program Files (x86)\FSRealistic\FSRealistic.exe</Path>
    </Launch.Addon>
</SimBase.Document>

This is my exe.xml file. Both in Local AppData & AppData Roaming

Yeah…The handling of exe.xml by MSFS seems strange.

  1. I re-wrote the (non-working) complete exe.xml in notepad++, and it worked. Exactly ONCE. :thinking::unamused:
  2. After MSFS shutdown and relaunch, it didn’t work. Again.
  3. Setting all but FSUIPC to disabled=TRUE didn’t help. It does not work.

Stripped exe.xml down

<?xml version="1.0" encoding="UTF-8"?>
 <SimBase.Document Type="SimConnect" version="1,0">
  <Descr>Autolaunch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.Addon>
    <Name>FSUIPC7</Name>
    <Disabled>False</Disabled>
    <Path>C:\FSUIPC7\FSUIPC7.exe</Path>
  </Launch.Addon>
 </SimBase.Document>

even THIS does not work🤔

Yea. Same case here. I have two entries in exe.xml. One for AFC_Bridge.exe and the other for TDSGTNXiFlightSimEXE.exe The syntax is correct, but I never saw MSFS launch any of them . I have to start them manually after MSFS is up. This sim is so buggy it’s infuriating. At launch they made a big deal about stability. But with all the mandatory updates that consistently break more and more things they basically ruined it. Now it’s the least stable flight sim out there. Even FSX was more stable.

1 Like

delete exe.xml and let msfs autogenerate again.

delete content.xml as well and let msfs autogenerate again.

worked for me

Will try this one.

Seems like MSFS isn’t regenerating the EXE.xml itself

why dont you write a simple BAT script? start “” /b “C:\xxxxx.exe etc”

Apps like the aerosoft vdgs driver has to be started at the correct time else it won’t work.

what timing is that? with a bat script you can use wait commands, so you can exactly time when each program would load if you want…

Too advanced a fix for most.

Did that. But I like things to be working the way they should be working… :stuck_out_tongue_winking_eye:

This should the “most” get up and running with batch files…

Here is my exe.xml which now doesn’t load - been that way for a long time, but more noticeable now as the fenix app doesn’t run at start up:

I’ve no idea if this is corrupted or not, or what the “hidden bytes” are referenced above. Any suggestions on how to fix it?

Thanks