EXE.xml Often Not Starting Addons Correctly

Same problem here, don’t know how to fix it

This problem first started with me about a year ago and then suddenly disappeared some months later only to reappear a few days ago.
It started again after installing GSX.
Here are some of my observations for what they are worth…
Uninstalling GSX or removing its entry in EXE.xml doesn’t solve the issue.
Removing any other individual entry in EXE.xml doesn’t solve it.
Leaving a single entry in the EXE.xml doesn’t solve it.
Disabling the firewall in case one or more of the apps can’t access the internet doesn’t solve it.
Changing admin rights on the program executables doesn’t solve it.
If MSFS is started and allowed to fail running EXE.xml then closed down and restarted the next time EXE.xml launches the applications successfully. Proving there is nothing wrong with EXE.xml itself i.e. no syntax or format error.
This is the most frustrating illogical problem yet with MSFS.
I give up unless anyone’s got any other suggestions…

1 Like

I agree it happens the same to me as well. I found that if I open the exe.xml after a reboot or the last simulator close, it’s saved with UTF-8 format again. I save it to Windows-1252 and starts working back again. This is a nasty bug who nobody seems what causes it

1 Like

I have added
(<?Descr>Launch<?/Descr>
(<?Filename>exe.xml<?/Filename>
to the top of the file to match (icebird4all) file and removed Run as Administrator for the Couatl program.
Launched the MSFS2020 as administrator and all are running. :grinning:
Back to normal

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

No

Provide extra information to complete the original description of the issue:

@MuchoJamone
Interesting.
I don’t think it changes for me, but I don’t think I saw the issues described here yet.
For me <?xml version="1.0" encoding="Windows-1252"?>
always remains on top.

If relevant, provide additional screenshots/video:

That helped me mate! Thank you very much!!! :pray: :pray: :pray:

1 Like

Credit goes to @icebird4all I found it on his reply to the topic. :slight_smile:
Happy flying :pilot:

1 Like

Hello, non of my programs are in admin mode and nothing starts sorry :slight_smile:

This happens way before 1000 addons ^^ My community folder consists of 90 Addons and this happening.

I dont have AIG also. 90 Addons, thats it.

For me this continously got worse, with every entry* (please read the explanation below).

At the beginning with only 1 entry, it worked 100% of the time. Then when it added AS VDGS and a few others, it worked 50% of the time.

Now after GSX and Fenix, it went to 0%. It doesnt load at all now.

*of course, many other things happened in this time also. This is how it appears but with many simupdates and addons added, the cluprit be somewhere completely different of course.
I also dont want to say that one of those addons/entries in the file is causing it. Its just how it appears to me. It works at the beginning and went worse over time. From 100% to 50% to 0%.

1 Like

Btw, why do some of us have

<SimBase.Document Type=“Launch” version=“1,0”>

and others

<SimBase.Document Type=“SimConnect” version=“1,0”>

Some third-party apps directly create or update the exe.xml file. I have one app that does that. There is no error checking on updates or changes except sometimes things don’t work correctly.

1 Like

Hello, yes it depends of the app that has created the Exe.xml. For example: FSUIPC will create with “Launch” but GSX will with “SimConnect” if there is no existing EXE.xml there

1 Like

Hi I am using this exe.xml, FSRealistic and Traffic injector start with no problems, but Realturb do not, any idea?


thanks!

HI Alexandro

on your file I saw that your Name is Rea k Turb but your software name is Rea l Turb not K.
I do not know this software but is it a mistake if you fill in form yourself the exe file.

Thanks!, I fixed the typo but my understanding that it is only the name for that