Expectations for Quest performance

I’m wondering what I should expect in terms of performance with my Quest 2 headset. On my monitor I get 35-40 FPS. In VR I get around 20 FPS which is not really usable. My question is, relative to performance on your PC, how does performance on the Quest compare?
There were struggles to get things to work but that seems to be standard. Although Oculus recognizes the headset when using the cable, MSFS does not. If I switch to Air Link, it is recognized by MSFS and I am able to make it work but like I say, 20 FPS is not adequate. I’m on Windows 11, is that a problem. If/when the cable issue is fixed, should I expect better performance? Thanks for any inforrmation.

Nvidia GeForce GTX 1060 6Gb
AMD Ryzen 7 3700X 8-Core
32 Gb DDR4 SDRAM
NVME drive

Bill

1 Like

When you use cable be sure to turn off airlink inside the Quest. Cable should work better. Performance depends on your PC of course. Mine is about the same except a 1080. I set the VR graphics to default and get reasonable but not spectacular performance. I don’t know how to measure FPS. I just go by how smooth (or not) the video. I think you and I need to upgrade but it’s expensive. Best of luck.

I also have a 1080 and a ryzen 5 3600. performance is decent and playable.
I don’t use any FPS counters, but rather tweak the system to get a smooth experience. saying that, the 1080 is borderline and a newer card would be better - but the they are expensive.

20 fps sounds about right with a 1080

I have a 2070 super and barely get 30FPS. I suggest turning on the performance HUD in Oculus Tray Tool to see what settings work best for you.

It’s possible that that using the NIS tool to sharpen your image and scaling it down could help gain performance without losing too much clarity.

Thanks for the tip, I just came to know about the NIS - will try it.

I’m living with a 1080 as well for now. I’ve fiddled with the MSFS, Oculus app, OTT, and NIS settings and now have readable instruments (important to me), and a whopping 18FPS. I can enjoy the sim but look forward to a new GPU once they cost less than a BMW.

3 Likes

Thanks everyone for the thoughtful responses. I’ll try tweaking things a bit. I certainly enjoy the feeling that comes with flying in the headset. I priced new GPU’s but for the price of one that would resolve my issues, I thought perhaps I would just buy a used airplane and take flying lessons.

BTW, I used the Oculus DeBugTool.exe in the C:\Program Files\Oculus\Support\oculus-diagnostics folder to count FPS and the developer kit for counting FPS on the monitor.

Bill

1 Like

An Update…
I discovered I was missing a step in setting up my Quest with cable. If I go to the Quick Settings, there is a large selection box next to WiFi and Guardian. If I click on it, then MSFS recognizes the Quest and makes use of it. There does seem to be a performance boost with the cable, but not dramatically so. I’m using the default graphics settings for VR (which are pretty low). It shows that I’m getting low 20’s for FPS but there is pronounced stuttering that makes it difficult to enjoy. Compared to what I see on my monitor, the stuttering in VR seems much more pronounced relative to the FPS that I’m getting. Unfortunately I get a CTD each time I toggle from VR to Desktop mode so that slows down the troubleshooting process.
Thanks again for the advice. I’ll see if I can do something about the stuttering before I give up.

Bill

check Pie in the sky’s video and the NIS tool. I tried it this morning and it does bring smoothness.

While you’re in the ODT (Oculus Debug Tool), you should turn off/disable the ASW and set your FOV to 0.65 for each eye. It will significantly improve your performance/results.

1 Like

I tried the NIS, but found no improvements:

Using Quest with AirLink:
Windows 11 (cable connect does not work)
i7-9900 RTX 2070 32GB ram, 32GB VRAM
Oculus Diagnostics Tool

I have found that when I first jump in the sim, things are a little stuttery, but after abour 20 minutes, everything smooths out (strangest thing), almost like something continues to load in the background and takes about that long to sort out.

I’m also waiting to upgrade my GPU… Or buy a new plane which ever is cheaper…

1 Like

I also had to play a bit with it. i had a lot of wobbling and decided to leave the ASW to auto and it worked fine.
I have been playing with the setting and it allowed me to push some settings a bit up.

My OpenXR resolution is 2160x2192. I am posting my settings (sorry took them with my phone, it was easier)




I dialed my Level of detail to 100 and have a smoother experience.
Texture supersampling has been changed to 4x4

in the OTT, ASW is set to auto.
Mirror FOV multiplier is set to 0.8.
Supersampling is set to 1.0

As for the Quest 2 settings, it is set to 90Hz at 1.7x (maximum)

I have no real idea on the settings, just following guides and changing 1 item at a time to see the difference. Hopefully this helps.

My computer ungraded itself to Win11 and got the stutters. I downgraded back to win10 and all was smooth again.
Oculus say win11 is not supported yet. Perhaps soon they will fix this.

So I upgraded to 511.2? Plus the latest Windows 11 updates, and hardwired “Link” worked well, but to be honest I saw NO difference between Link and AirLink last night…. Think I’m gunna stick to AirLink for now…

Here is a link to a similar thread:

In summary, I found smooth operation in Windows 11 with choosing 72Hz, 1.3X, and OTT@30Hz => 24HZ ASW (one-third of 72) > I wish both ODT and OTT referred to downcounts of Oculus PC app settings of HMD update rate - like one-half (instead of 45Hz) and 30Hz as one-third

I think the link cable may perform the same as Airlink, unless you manually change the bitrate. In the Debug Tool it’s set to 0 by default, which I think translates to a value of approximately 100Mbps.

Airlink requires 0 as its setting, however, when using the cable you can push the bitrate higher and use any number between 0 and 500Mbps, with 500 being the highest.

Try changing it to 500, then re-entering VR in the game. You should notice a difference. Even 300 is pretty good.

Just be sure to switch it back to 0 when you want to use Airlink, otherwise, it lags really bad.

Cheers,