External lights only render on Right eye + Random ghosting image on Right eye only

Before I send anything to Zendesk.

Has anyone noticed that the external lights on the Cessna 172 at least, only render on the right eye?
Creating an unpleasant effect. They also flicker.
Using external view, there’s a checkered patter on top of the light cast.

Also, there’s what appears to be an image, showing up at random on the right eye only for like a millisecond.
Has anyone noticed this?

This happens after yesterday’s update only.

Im using a Reverb G2 + 3080 TI + 471.41 Nvidia Drivers.
Fps are much better though.

1 Like

I have also seen some large artifacts on the horizon, only affecting the right eye and only since SU5. It’s not all the time, just certain cloud conditions

I don’t believe I have a solve for your question, but related to it, here are 2 topics about this you might want to check out to see if you agree with:

[BUG] Shader code ‘viewdir’ and shadow/light rendering are inconsistent on right eye

Airliner exterior lighting bug - Bugs & Issues / Virtual Reality (VR) - Microsoft Flight Simulator Forums

Do you found a solution for that, it looks like we are the only one having this problem there. And I did not receive any response from asobo

There is no solution that I know of, and I don’t believe we’re the only ones either, it is just lacking enough visibility or otherwise I’d tend to think the night lighting is so unflyable anyhow that most VR users are not flying at night.

This problem has been documented in greater details in the dedicated night lighting community solution topic. Here are some reference posts about this issue:

Night lighting issues still present - The community solutions - Bugs & Issues / Scenery - Microsoft Flight Simulator Forums


I try to turn off hardware-accelerated gpu scheduling in windows game setting, and the checkered patter is now fixed. I will do more test tonight.

1 Like

Thank you all for your kind replies.
And apologies for not answering earlier.
My brand new 3080ti died, or well, two of the fans did, and I’ve just got a new one.

Can confirm that disabling gpu scheduling makes the ‘ghost image’ that pops up at random is now gone.
The exterior lights seem fine now,


Reflections on the windshield (?) only render on the left eye. Tried different planes and no reflections on the right eye, no matter what.
It makes a really weird effect for the eyes.

Anyone with this issue?

Did you actually visited the 2 topics I’ve linked to in my answer to your OP?

I’m on it now, thank you :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.