Famous Flyer III: Beechcraft Bonanza V35

This definitely does not happen for me. I can use the knob to set an altitude, but pressing ARM just switches me between Pitch & ALT mode, which shows on the light panel, but not the KAP panel. I never see ARM enunciate on the light panel (are you sure you’re not seeing ALT?). Another weird thing I’ve seen with testing today. When I pre-select a VS speed, say +800, then press ENG, it will enable VS but put me at like -100 or some other random value that isn’t the +800 I selected. (edit. oh, it’s capturing. i’m pretty sure it used to take the pre-set value if you’d set one, not capture your current)

My issues with ALT capture mode are definitely related to the WT GTN530. Things work normally without that mod installed.

Edit: Carenado has let me know they are working with Working Title on a fix.

1 Like

This workaround works for me, thanks!!

If I’m not wrong, before having WT GTN530 installed, I used to preselect altitude, press ARM, push in the dial (seeing +500 fpm in the display when climbing) and then adjust to +1000 fpm, for example. I didn’t have to use ENG button anytime…

You’re not wrong, I tested by removing the WT beta to ensure it was the cause and not some undocumented Carenado update.

I found this one as well from Beechcraft

5 Likes

I can’t change my heading bug on xbox, anyone have a solution?

Did you tried right rotary wheel under HSI?

I did yes, I may have to try it with a mouse. I can’t seem to move it at all.

1 Like

Will the autopilot (altitude arm) be fixed?
The aircraft I bought in August is now broken for two of the five months I owned it - that’s just not good enough to buy further aircraft.

1 Like

When I set the altitude selector and hit the ARM button, the plane levels in the current altitude instead of arming the selected one.

When I hit the ALT mode on the AP panel during a climb or a descent, the plane levels off and the Altitude Selector goes to 99,900 ft.

I will try to fly without the GNS mod to see if the issues persist.

EDIT: Yeah, removed the GNS mod and the issues are gone.

Thank you so much, @DowglasLima !!

1 Like

try to use xbox game pad LT/RT to control the heading bug , it is another bug ….

It’s a shame that there’s been no updated after the GNS improvements. It’s a great plane to fly but without developer support and with WT changing so much of the avionics it’s going to take a committed developer to stay with it. As a “in-game” plane, I expected a much higher level of support.

3 Likes

Realistically, I don’t expect any updates until the WT GNS package replaces the base version, until then Carenado needs the V35 to support the base GNS package.

4 Likes

Did you not know about Carenado. This is what you get from them. It’s sometimes good while it lasts and they may update at some point but they do very few updates and leave aircraft broken for an age. Learn the lesson and move on.

2 Likes

This actually may be a wider issue. Whenever I fly the Islander/Trislander on Xbox I have a bunch of issues with the KAP 140 autopilot.

I’ve seen mine get selected to ridiculous altitudes and can’t really control VS well, and it all worked well before (I want to say before World Update 10).

Ironically, all my key bindings for the g1000 AP work perfectly.

Yer on Xbox so no mods, and had this on other KAP units