Fix G Sync

Would be a massive improvement of smoothness for the users that have G Sync monitors. It doesnt work correctly now. This is a very important feature for me to really enjoy this title in smoothness.

Should be standard for a next gen game like this anyway.

Use the windowed mode in gsync settings in nvcp. ■■■■■ hack but it works. Or use specialK to enable.

I have G-Sync enabled in full screen my monitor has the red light. How would I know its not working?

I do. It works generally but then goes back to fixed monitor refresh rate, then back to gsync and so on. It doesnt stay in gsync mode as it is supposed to be.

Check your monitor OSD settings, i have a counter that shows monitor refresh rate. Thats the only way to confirm it really works. As the Nvidia indicater stays on the whole time but the monitor refreshrate isn’t syncing anyway… its broken, not stable.

And specialK crashes my sim before i can get to the menu… (steam version). No fix yet, already asked in specialk forums a few days ago…

OK set the g-Sync display to on in NVIDIA CP (set to Windowed and Full Screen) and it displays on every game but FS 2020? So yes it may well be not working. I did check this when the sim first came out and it did display…

For me G-sync switches off and on when the framerate is around 30fps resulting in a strobe effect. I think this is how G-sync behaves with lower framerates, so i turned it off because the flickering was driving me crazy.

1 Like

exactly. Tested it with ACC and there it works as it should. Its MSFS related problem.
Even tried to force it with Nvidia Profile inspector, same problem.

GSync will work from 30fps and above afaik. My framerate is 40+ and still it goes off for a few seconds, comes back for a few seconds, goes off again and so on… only with MSFS, other games work fine.

i have exactly the same issue, trying weeks now to synchronize G-Sync with MFS and its not possible. Works only on windowed mode ( g-sync indicator is always visible and enabled on screen).

1 Like

MSFS doesnt use “real” fullscreen. Thats why we need to turn on fullscreen AND windowed Gsync. But if you will look at the refreshrate counter from your monitor (if yours have one) you can see that it doesnt work correctly anyway… :frowning:

The weird part is :
-micro-stutter, soft tearing/flickering/jumping is always visible Airliners cockpit
-Exterior cameras,views are ultra smooth with out any issue.
Looks like MFFS dont use at all g-sync , as i have almost the same results with out

1 Like

yes its trying to synchronize but not 100%, for sure Monitor Fps counter is moving and trying to catch GPU fps , but not accurate

after the patch, made a short flight with A320, no more stutters + G-sync is working at last.

Really? I tried it again yesterday after the patch and it still wasnt working correctly.
Works for a moment but then goes back to default refresh rate, still the same as before for me…

so your Monitor fps indicator while is trying to synchronized with gpu changes to default monitor refresh rate?

Yes, it syncs, switches to 100 (default), then syncs and back to 100. every few seconds

try with V-sync off ( nvidia control pane snd mfs) , also disable variable refresh rate from windows 10 graphic settings. Looks like MFS is trying to force v-sync and reach your monitor refresh rate ( 100hz). G-sync works 100% on my seutp right now

1 Like

My gsync wasn’t working and this fixed it, might work for you too:

Install nvidia profile inspector, choose the msfs profile and force gsync on both fullscreen and windowed. It has to be done on the msfs profile, global didn’t work, or setting the windowed and fullscreen setting in the nvcp.

It’s probably since the game is not exclusive fullscreen. Hope this helps you.

1 Like