Flickering and partially disappearing airport/runway lights

No but I rarely flight for that long and I always had the issue right away.

1 Like

Pretty sure it happens immediately after the game is loaded, as I’ve seen flickering runway lights while taxiing for takeoff even during the light of the day. At the time I even thought this was an issue with Rex airport textures (as I hadn’t experienced it from the air yet) and it was only much later I realized the sad truth when I couldn’t find the airport at night.

Let’s just hope it gets fully fixed with 1.21.17.0.

1 Like

I did another flight between two airports, completely randomly picked and lights were fine during take off, when I looked behind me, on approach, landing and taxiing…

Had runway lights for take-off on my night flight just now, nothing on landing though.

2 Likes

Just jumping on the bandwagon, I am having the same issue. If I didn’t know better it almost feels like a LOD issue on the runway lights. The airport looks fine to me from far away but around 3nm the lights start disappearing but then show up again when I am around <1nm away and it seems to be every set of lights like the rabbits/ PAPI/ edge marking/ taxi markings etc.

3 Likes

Been flying some legs in northern Norway the last few days and all airports are dark due to this bug. The taxi lights are hovering over the ground. Anyone in the beta program that can confirm if a bugfix is on it’s way ?

A few flights today in northern Scandanavia (Land of the Midnight Sun in summer - absolutely the opposite in winter :roll_eyes:), Restarted the sim between each and found that arrival airports would have no lights, or in one case just approach lights, even though the departure field had full lighting. Restarting the sim would give me lights at the new departure field (the one that I’d landed at before which had no lights) then my new destination would have no lights.

Not using any addon scenery other than WUs .
Pretty sure this is a problem that has only just started on my sim as most of my flying is in the evening in real time - so in the dark this time of year.

3 Likes

Noticed this today in a night flight. Some runway lights flickered on final including PAPI lights.

1 Like

Microsoft Store

No Dev Mode

Lights on destination airport dissapearing/floating

VIDEO LINK

To reproduce simply setup an ifr flight edfm-esms in a tbm9 at night around FL270, Live Weather, Live Traffic, Group Only and do it.

The issue only occurs on destination airports. If I setup IFR ESMS-EDFM the same issu applies for EDFM whereas ESMS is perfectly fine. It happens pretty much at any destination airport if not any.

Xbox Series S, Keyboard, Mouse, Gamepad

1.21.18.0 (and previous)

4 Likes

This just happened to me too at ENAT (Alta) by Aerosoft.

2 Likes

Same happened for me tonight. IFR LFAC > LFPG. Lights floating on arrival LFPG 27R.

1 Like

Any updates on this issue? I’ve been having the exact same problem since SU6 came out.

1 Like

So, here’s a video I shot on my iPhone just now, showing my settings, then showing the flickering lights all over the place. I’m using an 85" Sony Bravia TV as my monitor, over HDMI, with an nVIDIA RTX 2070 Super GPU (latest driver).

I’ve tried running FS2020 with all addons removed from the Community folder, tried other display resolutions, tried adjusting settings on the TV, tried adjusting the nVIDIA settings, tried all kinds of tweaks to the FS2020 settings. Even tried completely uninstalling and reinstalling the game. Nothing works. This type of flickering has been going on since SU6 for me. Any suggestions whatsoever?

1 Like

I have the same problem! I also noticed that on some airports during night time light are floating above ground like street lights but without the poll that is connected to the ground…

I also tried to remove all my mods but it’s not that, plus any settings that I change make no difference… I didn’t notice any troubles before last update so it might have something to do with this one :confused:

Just a thought, could the size of the screen be having any effect? 85" is a VERY big display and although I have no real knowledge how modern displays work and what graphic power is needed (I note you have a top-spec system) could it maybe something to do with that? Have you tried it on a smaller monitor maybe?

I know this was a regular problem some updates ago but thought it had been fixed - never had the problem on my (admittedly mid-range) rig. Just wish I had the room and the spare cash !

Weird, it was fixed for me last time I checked (and posted about it), I was literally missing lights or having them flickering like crazy so I couldn’t miss the difference. (VR with a Quest 2).

Looks like I was wrong and just got lucky.

Yeah, I was wondering that too–but no, I tested it with a small regular computer monitor, same exact thing happening. Definitely not a question of the display.

1 Like

Update:

I bit the bullet and completely uninstalled and reinstalled Windows 11 (fresh install, nothing from previous installation retained). Then did Windows Update. Reinstalled FS2020, did any updates it asked me to do–no other addons, used default in-game settings (which are different than the customized settings I had–the default in-game settings just used “High-End” as the default). All to no avail–experienced the exact same problem as shown in my YouTube link a few posts up.

So this, combined with the fact I’ve verified it’s not the monitor, means that it’s either a problem with my particular hardware setup (which I’d find strange, since I didn’t experience this problem when I first installed FS2020 after buying it back in 2021), OR there’s a problem with something in the way Asobo’s software interacts with a particular hardware setup, OR Asobo’s software is just…broken in this particular way.

I guess I’m just going to have to live with it broken like this. It’s so, so disappointing :frowning:

1 Like

What graphics card do you guys experience this? I had GTX 970 where this issue was present. I recently upgraded to RTX 3060Ti, and since then I have not experienced this any more.

It looks like it might be the hardware, firmware or driver together with the simulator.

I’m seeing it with an RTX 2070 Super.

The strange thing is, I’m pretty sure in previous iterations of FS2020 (like within a year of its release), I didn’t have this issue. I’m pretty sure it started around SU5 or SU6.

I agree with your assessment that it’s likely some combination of hardware, firmware, driver, and/or simulator (and maybe even OS too), but I can’t fathom what it could be, since the hardware I’m using is pretty standard, I’m using the latest driver (and tried earlier drivers too), and have tried lots of different settings combinations of nVIDIA control panel and FS2020 (as well as just basic default settings for both).