Flickering Landing Lights

yes - there is some kind of artifacting. I updated my drivers recently - maybe 2 weeks ago?

this is exactly what I experience. I was a bit worried if my GPU would act up - but I see that’s more an issue of the game then.

1 Like

thx - gonna give it a try!

I noticed it was happening on my, I managed to stop it by turning off HAGS and Game mode. Not sure why it worked stab in the dark.

I’ve seen the squares at the top of the screen in videos, but I’ve not seen them first hand.

I confirm this is also happening with me also.
I am not sure on this but, The volumetric lighting was missing until hotfix#2 I am wondering if it is still not fully fixed/implemented?

Intel Core i9-9900X 10 Core HT @ 3.5GHz, and @ 4.40GHz Turbo.
MSI X299 Raider Ultimate Force Motherboard
64GB Ram DDR4 @ 3600 Quad Channel
2 x MSI GeForce RTX 2080Ti (sli)
M2SSD 1TB 3400Mb/s
Hyper Liquid II medium kit (Rigid)
Corsair AX 1200i 1200W 80+ Power unit

Big thanks @rixtrick5893 !

The problem is solved for me. I updated also the nvidia driver.

Could these reports be the product of users that write protect that file, causing changes between updates to fail to apply correctly?

If so this should be another one of the things to do prior to updating.

This is the thread about it, apparently setting render scaling to 100% solves it for now:

Not just you, the search function confirms:

That explains why I haven’t seen it as I’ve never used anything other than 100%.

1 Like

For me the issue was the Nvidia drivers, rolling back to 466.77 fixed the lights.

My render scaling is at 100 and I’m getting it.

Then contribute in the according thread…

Download Nvidia drivers v466.77

Uninstall Nvidia drivers and restart PC.
Install 466.77 drivers and restart PC.

1 Like

Hello everyone,
My name is Manuel and I work for NVIDIA. Our QA team has not been able to reproduce the flickering landing lights issue. Our next driver release coming soon includes a general fix that may resolve this issue. Please look out for this driver and if the issue persists after updating your drivers, please take screenshots of your in game graphics settings used and email it to me at driverfeedback@nvidia.com so that I can pass it to our QA team. Thank you.



What about dxdiag?
What about NCP settings? :wink:


@pidge2k Bug with taxi and landing lights seems to be fixed.
Thank you :slight_smile:

1 Like

Terrific. Thanks for the update.

Same thing in a day light. But I\m sure it first appeared after my last update of NVIDEA drivers a week ago. Neve before I had such problems. This appeared not always but ofter after some minutes in sim.

There’s a separate thread for it, this one is about flickering lights.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.