Flight sim won't load--stuck on Syncing Data

For 2 days Flight Sim won’t load. I get the splash screen with Syncing Data in the corner and it just keeps going round and round. Anyone having this problem? I am playing on a PC.

1 Like

Yes. Since WU9 I have it everyday. I need to kill the process as it will never finish the sync.

Cheers

Are you able to play? I have been just shutting down.

After two or three attempts it uses to launch well. So kill process and restart game.

Cheers

Nope, doesn’t do any different. Tried a few times and still in endless Syncing. It used to take maybe 20 seconds.

Ok, I suffered that some times as well. Then go to:

\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

and delete “SceneryIndexes” folder. It will be regenerated after next game launch. This normally unblocks the sync loop if you can´t get rid of it.

Cheers

1 Like

Did it but still the same.

By any chance, have you recently uninstalled the MSFS Google Maps Replacement scenery? I had the same issues until I discovered some residual code that this program left in one of the Windows system files. Once I deleted that all was well again. You can find instructions somewhere in this forum.
I don’t know that’s your problem but the symptoms seem the same.

No I haven’t messed with any scenery or anything else for that matter. I don’t have any 3rd party apps or anything additional. It is in original condition. But thanks for your reply and also gelaxo.

Hi there,
I’m sorry to hear about your issue. There is an area of the forums for asking questions of the community called Community Support. I have moved your thread there.

Fixed the problem. Go here and go to #5.

2 Likes

@TheWildcatman1 solved it for me, ty!

Glad to hear it!!

Thanks that works for me

How do you open the \AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache part?

The app data file is hidden. You have to unhide it to open it. Google how to open hidden files and you will be good.

Hi,
I’ve got the same problem that’s published in this topic, the only thing is that I’ve tried everything that you have written here. Can anyone help me with this?

I have/had the same problem as published here ( emptied CF & tried Vanilla but no change )

To fix it I went to

Xbox app / Installed / flight Sim / the 3 dots ( Ellipsis ) / Manage / Files / Verify and Repair.

Accept the warning about settings.

Click on Start Sim, Sim started as normal

P.S. all my General Settings remained in the sim including control options. Will have to re-install FBW

I have installed MSFS2020 from the 10 DVD set, I have installed MSFS2020 on my MacBook Pro M1 Max, using Parallels 17 and installed Windows 11 Home edition. The installation had taken almost 6 hours to finish, once the install had finished I was asked to sign into my Microsoft Store account and then for some reason Microsoft Flight Simulator, Gaming Services, just don’t seem to do anything as part of the final install process.

Not sure what to do from here to finally get MSFS202 up and running, as unable to find the MSFS202.exe file or if it’s named something else.

Because of the issue from Microsoft Store not being able to download, once this download finishes will I then be able to start MSFS2020.

Any help or advice will be welcome.

I think the Disc MSFS should install as usual, but I would suspect that the Sim would then have to be updated to the latest version using the Xbox app, hopefully, that would not require the whole installation to be downloaded again.